none
Outlook Anywhere (problema no acesso externo RRS feed

  • Pergunta

  • Boa tarde caros amigos.

     

    Aqui na empresa temos um AD com Windows 2003 todo atualizado e funciona internamente só, para autenticar os usuários e esses terem acesso à politíca da empresa.

    Instalei aqui um Exchange 2007 STD com sp1 e todas as atualizações possíveis. Este Exchange 2007 está ligado a este AD para adicionar os e-mail através do usuários do AD. Até aí tudo beleza.

    O domínio principal nosso está alocado em outro local, responsável por hospedar nossa página de internet. Nossos e-mails pertencem também a este mesmo domínio, exemplo: www.site.com.br e email: @site.com.br.

    Parece confuso não?. O meu AD interno, tem o mesmo nome de domínio do site que está alocado fora.

    Enquanto meus e-mails ficavam na Locaweb. Estava tudo certo funcionava bem. Meu chefe quis instalar o Exchange 2007 aqui. Instalamos, funciona bem tanto interno (MS Outlook) e externo (OWA ou configuração de uma VPN, para acessar pelo outlook).

    Acontece que meu chefe quer que este acesso externo pelo outlook seja feito pelo método "Outlook Anywhere". Configurei ele todo chequei as configurações em vários foruns e tudo o mais e verifiquei que está tudo certo. Já chequei as configurações do Exchange, do Firewall (inclusive sem firewall, acesso direto pela internet) e questão de DNS.

    Acontece que internamente o "Outlook Anywhere" funciona e externamente eu não consigo a conexão. De forma alguma. Até aparece a janela pedindo senha no Outlook, mas depois de digitá-la, o Outlook da uma mensagem de erro dizendo que, não foi possível se comunicar com o servidor Exchange se ele estiver Off-line. Funcionando ele está.

    Minha pergunta é a seguinte:

    O fato de eu ter o domínio www.site.com.br hospedado externamente e este mesmo domínio www.site.com.br na minha rede interna, tendo instalado...DNS (interno), AD e o Exchange 2007 ligado a esse AD instalado em outra máquina, pode estar causando esse erro no acesso ao "Outlook Anywhere" externamente?

    quarta-feira, 12 de novembro de 2008 16:01

Respostas

Todas as Respostas

  • Ola Carlos,

     

    Até onde eu li do teu texto.. tu habilitou o outlook anywhere no exchange? o firewall é isa?

     

    FAz um teste interno, marcando qualquer cliente para usar em redes rapidas e lentas outlook anywhere, se conectar via https tu sabe que o problema nao é exchange e sim o teu firewall.

     

     

     

    quarta-feira, 12 de novembro de 2008 16:04
  • Então. Meu firewall não é ISA e sim firewall por hardware. Internamente funciona. Externo não

    O que acontece é que mesmo sem firewall não funciona externo. Como eu disse meu domínio está em 2 lugares. Aqui internamente em meu AD site.com.br e externamente site.com.br hospedando nossa página. Em testes externos que faço de Autodiscover do office 2007 ele acaba fazendo consulta ao site.com.br no provedor externo onde fica minha página de internet e não onde fica meu Exchange 2007. Gostaria de saber como eu faço para funcionar da maneira correta.

     

    quarta-feira, 12 de novembro de 2008 16:16
  •  

    Nao importa para um cliente externo, tu tem as portas publicadas corretamente. Se funciona interna Outlook Anywhere (confirma isto no teu cliente outlook, segurando o ctrl + botao direito no icone do systray e Connection Status) se for estiver fazendo https é teu firewall.

     

    como o cliente tá externo ele vai fazer a consulta sempre no externo, devido tu ter um split-dns tem que ter certeza que os mesmos registro (autodiscover e tudo mais) existe no externo.

    quarta-feira, 12 de novembro de 2008 16:22
  • Tem algum erro sim no meu.....configurei o autodiscover conforme url publicada por ti: http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-exchange-server-2007-web-services-urls.html

     

    Segui todos os passos corretamente e mesmo assim eu não consigo o Outlook Anywhere e nem o Autodiscover....

    Agora desabilitei o Outlook Anywhere depois dessas mudanças sugeridas e habilitei ele novamente....vou aguardar os 15 minutos que ele pede para voltar a funcionar e depois eu faço o teste.....

    Caro Anderson. O que pode estar acontecendo aqui no meu caso?.

    quarta-feira, 12 de novembro de 2008 20:44
  • Opa Carlos,

     

    Cara se funciona internamente o componente do outlook anywhere tá ceitando comunicaçoes, teu problema é dns externo/firewall.

     

    Tu tem que ter pelo menos 2 registros: autodiscover.empresa.com.br e nome.empresa.com.br onde é o mesmo que tu configurou nas configuraçoes externas do tutorial. Se já tem isso teu problema é firewall e vai ter que habilitar log e/ou trabalhar ocm o fabricante para ver o pq nao está passando.

     

     

     

    quarta-feira, 12 de novembro de 2008 22:00
  • Caro Anderson.

     

    Ve se você pode me ajudar.

     

    Ontem, depois que segui os procedimentos para o autodiscover.....aconteceu alguma coisa estranha aqui....O OWA não abre de jeito nenhum, na verdade não abre nada que está no IIS. Digito https://email.empresa.com.br/owa e não abre nada.....

     

    Você por favor, pode me dar uma ajuda a resolver isso..?

     

    quinta-feira, 13 de novembro de 2008 11:46
  • Ola Carlos,

     

    Junto com a dica do Anderson e atropelando o post dele vou fazer a pergunta básica: O que tem nos logs e o que você alterou? Outra, digitando o endereço interno rola?

     

    Abs.

     

    quinta-feira, 13 de novembro de 2008 12:33
  • Vocês me desculpem. Tive problema no meu certificado, que é o que é instalado junto com o Exchange 2007

    Eu não estava conseguindo fazer nada....e acho que com esse certificado talvez não consiga mesmo.

     

    Gostaria de uma ajuda sua se possível amigo.

     

    Com esse certificado básico de Exchange eu habilitei todos os services (POP, IMAP, SMTP, NONE e IIS), mas o OWA porque diz que não tenho permissão para acessar. Como posso fazer para ele voltar a funcionar????

     

    Obrigado.

     

    Quanto ao autodiscover, vou comprar um certificado mais completo e refazer as configurações dele.

     

    Desde já obrigado.

     

    quinta-feira, 13 de novembro de 2008 12:44
  • Ola Carlos,

     

    Cria um novo com esse tutorial: http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?tut=912 e habilita ele para todos os serviços. Não tem problema usar apenas um. Depois pode remover o antigo.

    E quanto ao autodiscover, comprar um certificado sempre é uma boa solução mas não é necessário, ele pode funcionar numa boa usando apenas o certificado criado pela CA interna.

     

    Abs.

     

    quinta-feira, 13 de novembro de 2008 18:52
  • Bom dia, Carlos e amigos do forum, eu estou aparentemente com o mesmo problema, tenho um Exchange que irá ficar atrás de um Linux por enquanto pois irei colocar o ISA também. Mas para validar todas as funcionalidades eu coloquei o Exchange diretamente de cara para a internet, a questão do Outlook Anywhere funciona internamente. Todas as conexões aparecem como HTTPS, porém externamente não funciona.

    Carlos, no seu caso o que era?

    Obrigada

    Letícia

    sábado, 17 de abril de 2010 13:24