none
IE não resolve nome, Firefox Resolve RRS feed

  • Pergunta

  • Agradeço infinitamente se alguém puder me ajudar.

    Estamos com este problema desde o início de Dezembro.

    Temos uma VPN L2TP sobre IPSEC site-to-site entre nosso ISA 2006 e o CheckPoint de um cliente.

    Nossa fábrica de teste precisa acessar a aplicação do cliente e realizar as atividades esperadas pelo cliente.

    O teste tem que ser realizado exatamente como o usuário acessaria na casa dele, diante disso, precisamos testar a aplicação no Firefox e no IE.

    No firefox a aplicação funciona perfeitamente quando digitamos https://servidorcliente-hi/Logon ou quando acessamos via IP https://10.96.170.139/Logon.

    O problema: No IE a aplicação só funciona por IP. https://10.96.170.139/Logon.

    Realizei milhares de testes.

    1º - Criei um registro HOST A em meu DNS interno e apontei para o IP da aplicação do cliente. Não funcionou, mas se eu colocar o hostname do cliente + o FQDN do meu domínio AD, aí funciona. Ex.: https://servidorcliente-hi/Logon (Não funciona), mas https://servidorcliente-hi.minhaempresa.com.br/Logon (assim funciona). O fato é que isso comprometerá totalmente os testes, Obs.: Infelizmente o antido ADM da minha rede, criou o domínio do AD com o mesmo nome do nosso domínio público (Site).

    2º - Como a resolução via FQDN estava funcionamento, pensei: Retiro o DNS na placa de rede e implemento o WNS na rede para resolção apenas netbios. Também não funcionou.

    3º - Já arreganhei as configurações do meu SA e nada. Algumas pessoas me falaram que podia ser o firewall. Eu descordo, caso contrário, não funcionaria perfeitamente no IE e por IP no IE.

    4º - Arquivo hosts, reduzir as opçoes de segurança do IE, arreganhar as configurações do ISA, tentar acessar a aplicação diretamente do ISA, nada funciona.

    5º - Pensei em criar um encaminhamento em meu DNS para o dns do cliente, mas o fato é que o cliente não quer fazer isso (Óbvio), alegando que se funciona no Firefox, então o problema é nosso e que o DNS deles está resolvendo.

    Me ajudem pelo amor de Deus.

    sexta-feira, 11 de fevereiro de 2011 21:24

Respostas

  • Olá!

    Se tu já colocou um aentrada no teu arquivo hosts, e o Internet Explorer não conseguiu acessar o site, então podes ter certeza que não é nenhum problema com Netbios/Wins/DNS/Whathever...

    A primeira consulta que o Windows faz ao tentar resolver um nome, é SEMPRE o arquivo hosts, portanto, se quiseres excluir todas as outras opções pra teste, deixa este endereço cadastrado no arquivo hosts.

    Qual é EXATAMENTE o erro que aparece ao acessar o site através do IE8? Tens como postar algum print?

    Tu tens acesso a outros sites https? eles acessam normalmente através do IE8? Caso negativo, o protocolo pode estar desativado nas configurações de internet, mas acho bem dificil...

    O certificado SSL está criado para qual nome de host? O FQDN inteiro? Só o nome do servidor?

    • Marcado como Resposta Richard Juhasz quarta-feira, 23 de fevereiro de 2011 16:27
    sábado, 12 de fevereiro de 2011 01:33
  • A primeira consulta é o cache, depois o arquivo host.
    Missão dada é missão cumprida.
    • Marcado como Resposta Richard Juhasz quarta-feira, 23 de fevereiro de 2011 16:27
    sábado, 12 de fevereiro de 2011 14:51
    Moderador

Todas as Respostas

  • Se você pingar servidorcliente-hi responde o IP 10.96.170.139 ?

    Poderia executar um ipconfig /all e colar aqui ?

     


    Missão dada é missão cumprida.
    sexta-feira, 11 de fevereiro de 2011 23:25
    Moderador
  • Olá!

    Se tu já colocou um aentrada no teu arquivo hosts, e o Internet Explorer não conseguiu acessar o site, então podes ter certeza que não é nenhum problema com Netbios/Wins/DNS/Whathever...

    A primeira consulta que o Windows faz ao tentar resolver um nome, é SEMPRE o arquivo hosts, portanto, se quiseres excluir todas as outras opções pra teste, deixa este endereço cadastrado no arquivo hosts.

    Qual é EXATAMENTE o erro que aparece ao acessar o site através do IE8? Tens como postar algum print?

    Tu tens acesso a outros sites https? eles acessam normalmente através do IE8? Caso negativo, o protocolo pode estar desativado nas configurações de internet, mas acho bem dificil...

    O certificado SSL está criado para qual nome de host? O FQDN inteiro? Só o nome do servidor?

    • Marcado como Resposta Richard Juhasz quarta-feira, 23 de fevereiro de 2011 16:27
    sábado, 12 de fevereiro de 2011 01:33
  • A primeira consulta é o cache, depois o arquivo host.
    Missão dada é missão cumprida.
    • Marcado como Resposta Richard Juhasz quarta-feira, 23 de fevereiro de 2011 16:27
    sábado, 12 de fevereiro de 2011 14:51
    Moderador
  • MMAlves,

    novidades a respeito?

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    segunda-feira, 21 de fevereiro de 2011 12:18