none
Despromover DC utilizado pelo Exchange 2010 RRS feed

  • Pergunta

  • Bom dia, desde já agradeço a ajuda de todos.

    Vou descrever meu cenário, possuo 3 servidores Win2008R2, dois são AD e outro Exchange 2010. Preciso despromover o 1º AD criado na rede, já movi as FSMO's para o segundo DC, desmarquei a opção de Global Catalog do primeiro e verifiquei que o segundo é o GC. Vi que o Exchange estava usando o GC errado então executei o camando Set-ExchangeServer -Identity <server_name> -StaticGlobalCatalogs DC-02.contoso.com para setar o GC correto. Verifiquei via ambiente gráfico e ele está buscando corretamente agora.

    Segui de acordo com o http://support.microsoft.com/kb/298879/pt-br para excluir o DC do exchange, mas ao excluir o DC-01 o exchange para de autenticar os usuários. Então tive que setar o DC automaticamente $ NULL, mas quando desligo o DC-01 o exchange para de funcionar.

    Lembrando que os dois DC's são servidores DNS e ambos estão setados como primario e secundário nas estações.

    A pergunta é a seguinte, quando eu desligo o DC01 o exchange para, se eu despromove-lo do dominio acontecerá o mesmo?


    terça-feira, 23 de outubro de 2012 11:52

Respostas

  • Breno,

    Tem um evento que expressa a saúde do AD para o Exchange ele é o 2080, e se encontra no application log, você consegue postar o resultado deste evento aqui, eles nos dará uma visão do Macro de como o Exchange está enxergando a sua topologia de AD.

    Maiores detalhes:

    http://support.microsoft.com/kb/316300 (o artigo fala de Exchange2000/2003, porém esse evento continua sendo válido até hoje)

    um abraço,

    Robson

    • Marcado como Resposta Breno Munaldi segunda-feira, 29 de outubro de 2012 10:19
    quarta-feira, 24 de outubro de 2012 10:34
  • Finalmente problema resolvido, e realmente o problema era na saúde do meu DC02, após despromovê-lo e promovê-lo a DC, transferir as FSMOs, checar todos os serviços do ADDS, verifiquei que o Netlogon estava parado, após corrigir este problema, o Exchange funcionou corretamente.
    • Marcado como Resposta Breno Munaldi segunda-feira, 29 de outubro de 2012 10:23
    segunda-feira, 29 de outubro de 2012 10:23

Todas as Respostas

  • Bom dia Breno,

    Verifique os procedimentos citados no link abaixo:

    http://marckean.wordpress.com/2011/06/30/exchange-2010-domain-controller-and-global-catalog-servers-being-used-by-exchange/


    Marco Antonio Silva - MCP / MCSA Messaging / MCTS / MCITP (Messaging)

    terça-feira, 23 de outubro de 2012 13:11
  • Bom dia Marco, o comando que citei no post, retirei a sintaxe justamente do artigo que me sugeriu, sendo assim já fiz tais procedimentos.

    Grato

    terça-feira, 23 de outubro de 2012 13:26
  • Boa tarde, Breno!

    Roda o comando netdom query fsmo para verificarmos se esta corretamente no servidor correto.

    Outro ponto, digitando no prompt nslookup, esta retornando corretamente o ip  e host do server em questão?

    Douglas Urbano

    terça-feira, 23 de outubro de 2012 15:29
  • Boa tarde Douglas,

    Executei os comandos sugeridos nos 3 servidores (dois AD e um exchange), e ambos retornam o servidor correto (DC02), tanto no netdom quanto nslookup.

    Grato pela ajuda

    terça-feira, 23 de outubro de 2012 17:24
  • Boa tarde, Breno!

    Vamos tentar, eliminando os possíveis erros. Como rodou os comandos e estão ok. No seu servidor Exchange, tu adicionou algum servidor no host? cito: Exchange     C:\WINDOWS\system32\drivers\etc\hosts. Exemplo: 192.168.0.250   dominio.local (seu DC atual)


    Douglas Urbano

    terça-feira, 23 de outubro de 2012 17:31
  • Ei Douglas..

    Não adicionei nada ao arquivo hosts. Acredita ser necessário inserir as informações do meu novo DC?

    Grato

    terça-feira, 23 de outubro de 2012 17:49
  • A resolução de nomes nos ping's está correta. Também executei um netstat no exchange, e todas as conexões além dos clients são para o DC02 (correto), tanto conexões ldap quanto msft-gc
    terça-feira, 23 de outubro de 2012 18:02
  • Em > Exchange Management Console

    * Organization Configuration > Botão da direita > Modificar a Configuração de Domain Controller

    Ao escolher o que realmente tu esta usando, e desligar o outro servidor, o erro persiste?

    http://msexchangeguru.com/2011/02/27/move-exchange-to-a-member-server/

    Douglas Urbano


    terça-feira, 23 de outubro de 2012 18:07
  • Sim, já havia feito isso .. marquei especificar controlador de domínio, setei o domínio e depois o DC correto. Neste momento está setado para o DC02, porém se eu desligar o DC01, o Exchange Management Console não abre e todas as estações solicitam senha de autenticação no outlook, mas msm digitando senha ou reiniciando as estações ela não autentica.

    Obrigado pelo empenho Douglas

    terça-feira, 23 de outubro de 2012 18:14
  • Bom dia, Breno!

    Imagina, vamos tentar resolver o problema, é um prazer ajudar.

    Em sua barra de tarefas, o icone do outlool seguro a tecla Ctrl clique sobre o icone com o botão da direita e clique em Status da Conexão...

    Os diretórios, estão buscando do DC correto?


    Douglas Urbano

    quarta-feira, 24 de outubro de 2012 09:43
  • Breno,

    Tem um evento que expressa a saúde do AD para o Exchange ele é o 2080, e se encontra no application log, você consegue postar o resultado deste evento aqui, eles nos dará uma visão do Macro de como o Exchange está enxergando a sua topologia de AD.

    Maiores detalhes:

    http://support.microsoft.com/kb/316300 (o artigo fala de Exchange2000/2003, porém esse evento continua sendo válido até hoje)

    um abraço,

    Robson

    • Marcado como Resposta Breno Munaldi segunda-feira, 29 de outubro de 2012 10:19
    quarta-feira, 24 de outubro de 2012 10:34
  • Boa tarde Douglas,

    Verifiquei conforme sugerido, e ambos tipos de conexão estão buscando do mesmo servidor "EXCHANGE", conforme imagem abaixo:

    Obrigado

    quarta-feira, 24 de outubro de 2012 17:36
  • Boa tarde Robson, verifiquei o evento citado e analisando juntamente com a documentação que me passou, acredito estar tudo em ordem, segue print:

    Obrigado

    quarta-feira, 24 de outubro de 2012 18:04
  • Bom dia, Breno!

    http://marckean.wordpress.com/2011/06/30/exchange-2010-domain-controller-and-global-catalog-servers-being-used-by-exchange/



    Será que não existem ponteiros restantes para o controlador de domínio antigo dentro de DNS, ou seja, em DomainDNSZones e ForestDNSZones. Certifique-se de excluir todas as entradas ainda referenciando o DC antigo.

    Eu acho que você tem _ldap SRV registrado com o antigo.

     


    Douglas Urbano

    quinta-feira, 25 de outubro de 2012 10:15
  • Bom dia Douglas

    Sim, realmente existem entradas ldap nas zonas DNS para ambos os servidores, mas acredito que não posso remover do antigo, visto que ainda não o removi do domínio, pois ambos servidores ainda são DC's.

    Quanto ao link que me passou, estive verificando juntamente com a informação dada pelo Robson Elias da Silva, e no evento 2080 está registrado (CDG 177101101),  acredito que o foco no momento seria em solucionar o motivo deste penúltimo zero, visto que o correto seria 7, isso indica algum problema no "netlogon", justamente a falha de autenticação que estou tendo.

    Logo após este evento é registrado uma falha no evento 2114

    "Processo MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=2044). Falha na Descoberta de Topologia; erro 0x80040a02 (DSC_E_NO_SUITABLE_CDC)"

    Estarei focando nesses dois eventid, acredita que pode ser isto?

    Obrigado

    quinta-feira, 25 de outubro de 2012 10:44
  • Bom dia, Breno!

    Creio que sim. Estou verificando problemas semelhantes para tentar ajudar, vi este documento, vejas se te ajuda. 

    http://blogs.technet.com/b/richardroddy/archive/2010/06/16/msexchange-adaccess-dsaccess-errors-and-the-manage-auditing-and-security-right.aspx

    Eu pensava que tu não estava mais trabalhando com o servidor que tu despromoveu.


    Douglas Urbano

    quinta-feira, 25 de outubro de 2012 12:22
  • http://www.howexchangeworks.com/2010/07/exchange-2010-error-process.html

    Douglas Urbano

    quinta-feira, 25 de outubro de 2012 12:28
  • Ei Douglas, eu já tinha lido esses artigos e realmente são bem semelhantes ao meu problema, entretanto, eles tratam problema no parâmtro "SACL à direita".

    O meu problema seria no parâmetro "Netlogon" do evento 2080, mas em todos os casos eu conferi os grupos do exchange e estão corretos de acordo com o artigo sugerido.

    Obrigado

    quinta-feira, 25 de outubro de 2012 12:45
  • Finalmente problema resolvido, e realmente o problema era na saúde do meu DC02, após despromovê-lo e promovê-lo a DC, transferir as FSMOs, checar todos os serviços do ADDS, verifiquei que o Netlogon estava parado, após corrigir este problema, o Exchange funcionou corretamente.
    • Marcado como Resposta Breno Munaldi segunda-feira, 29 de outubro de 2012 10:23
    segunda-feira, 29 de outubro de 2012 10:23