none
Configurar o Sql Server para uma rede

    Pergunta

  • Olá turma,

    Estou com dificuldades ao configurar o sql server 2008 express na rede.
    Tenho dois Not's conectados computador a computador com fio. Em um tenho o banco instalado em um deles, no outro, apenas o executável (este dentro de um Pendrive). Consigo executá-lo normalmente, no entanto, no momento que ele tenta conectar ao banco ele informa que não foi possível conectar a instância do sql server.

    Conforme leituras neste fórum, já segui os seguintes passos.
    1.º
    Liberar a porta (1433) usada pelo SQL Server no Firewall (Obrigatório)  - ok
    2.º Modo de autenticação configurado no SQL Server - ok
    3.º Habilitar o Sql para aceitar conexões remotas - ok
    4.º Habilitar o protocolo TCP/IP - ok
    5.º A string de conexão é essa: "Data Source=192.168.0.1\SQLExpress,1433;User Id=NomeUsuario;Password=SenhaUsuario;"
    6.º Apenas o serviço SQL Browser que não estou conseguindo Startar, o menu Start aparece desabilitado. Por quê?

    Em fim, estou frustrado, pois não consigo minha aplicação ao banco.

    Grato a todos que me ajudarem.



    sexta-feira, 21 de novembro de 2008 14:54

Respostas

  • Oi Sandro,

     

    Agora parta para verificar se a porta é a correta. Eu recomendaria que você procurasse nos posts anteriores. O procedimento do 2005 e do 2008 é semelhante. A diferença é que o 2008 não tem mais SQL Server Surface Area Configuration, mas você pode utilizar o SQL Server Management Studio para habilitar conexões remotas.

     

    Sugiro os posts anteriores, porque muitos já tiveram a sua dúvida. Seguir um roteiro passo a passo descrito em um dos milhares posts é bem mais fácil, rápido e produtivo do que interagirmos novamente na mesma dúvida.

     

    [ ]s,

     

    Gustavo

    sexta-feira, 21 de novembro de 2008 22:39

Todas as Respostas

  • Boa Tarde,

     

    Não é obrigatório liberar a porta 1433 para o SQL Server funcionar. O que você deve liberar é a porta utilizada (que não necessariamente é a 1433). Verifique a porta utilizada através do SQL Server Configuration Manager.

     

    Para habilitar o SQL Browser você deve retirar o status de Disable verificando as propriedades do serviço.

     

    [ ]s,

     

    Gustavo

     

    sexta-feira, 21 de novembro de 2008 16:11
  • Estou utilizando o Sql Server Express 2008.
    Não encontrei, nas propriedades do serviço essa opção.
    sexta-feira, 21 de novembro de 2008 17:49
  • Boa Tarde,

     

    Ao clicar sobre o serviço e exibir as propriedades, devem haver algumas abas.

    Procure nessas abas a propriedade Start Mode. Retire-a de Disable.

     

    [ ]s,

     

    Gustavo

    sexta-feira, 21 de novembro de 2008 18:08
  • Consegui habilitar o serviço.

    Restartei todos os serviços.

    No entanto, o problema continua.
    sexta-feira, 21 de novembro de 2008 22:06
  • Oi Sandro,

     

    Agora parta para verificar se a porta é a correta. Eu recomendaria que você procurasse nos posts anteriores. O procedimento do 2005 e do 2008 é semelhante. A diferença é que o 2008 não tem mais SQL Server Surface Area Configuration, mas você pode utilizar o SQL Server Management Studio para habilitar conexões remotas.

     

    Sugiro os posts anteriores, porque muitos já tiveram a sua dúvida. Seguir um roteiro passo a passo descrito em um dos milhares posts é bem mais fácil, rápido e produtivo do que interagirmos novamente na mesma dúvida.

     

    [ ]s,

     

    Gustavo

    sexta-feira, 21 de novembro de 2008 22:39
  • A mensagem que está aparecendo é essa:

    Ocorreu um erro ao estabelecer uma conexão com o servidor. Ao conectar ao SQL Server 2005, essa falha pode ser causada porque, dentro das configurações padrão, o SQL Server não permite conexões remotas. (provider: Interfaces de Rede SQL, error: 26 - Erro ao Localizar Servidor/Instância Especificada)
     
    Ajudem-me!!!
    sexta-feira, 21 de novembro de 2008 22:42
  • Boa noite Gustavo,

    Obrigado pela sua ajuda. No entanto, já consultei dezenas de posts e segui todo o passo a passo adaptando ao 2008, mas, o problema persiste.
    sexta-feira, 21 de novembro de 2008 23:01
  • Ok Sandro,

     

    Você verificou a porta utilizada pelo SQL Server ? Qual seria ela ? Tenho a impressão de que não é a 1433.

     

    [ ]s,

     

    Gustavo

    sábado, 22 de novembro de 2008 15:10
  •  

    Olá Sandro,

     

    Se realmente a porta for a 1433 e o serviço Sql Browser estiver rodando, tenta o seguinte

     

    No Management Studio,no server e clique com o botão direito e em seguida em propriedades.

     

    Na guia connections, verifique se a opção "Allow remote connections to this server" está habilitada, caso nao esteja, habilite

     

    Abraços

    domingo, 23 de novembro de 2008 12:58
  • Aqui ele está usando a porta 1433.

    Já habilitei a
    opção "Allow remote connections to this server".

    Mas o problema continua.

    domingo, 23 de novembro de 2008 22:00
  • Bom dia a todos,

    Instalei o Sql Server na máquina que não conseguia acessar o banco. Depois disso, consegui conectar!

    Para conectar ao banco precisa de algo instalado no lado cliente?

    Grato.


    segunda-feira, 24 de novembro de 2008 12:21
  • Bom Dia,

     

    Se na connection string você usa o SQL Native Client (SQLNCLI) é preciso instalar o SQL Native Client no Cliente. Só que se fosse esse o problema a mensagem de erro seria outra. Estranho ter funcionado.

     

    [ ]s,

     

    Gustavo

     

    segunda-feira, 24 de novembro de 2008 13:12
  • Concordo com o Gustavo,

     

    Pode ter ocorrido que após você habilitar a opção allow remote connection, ele tenha funcionado e você não percebeu.

     

    Abraços

    segunda-feira, 24 de novembro de 2008 13:16
  • Mas eu já havia verificado. E estava habilitado antes de instalar!
    segunda-feira, 24 de novembro de 2008 13:18
  • Estranho como citado pelo Gustavo, não deveria ser essa mesagem. Mas ao menos foi resolvido srsr.

     

    Abraços

     

     

     

    segunda-feira, 24 de novembro de 2008 13:22
  • Atenção

    Entre no
         SQL Server Configuration Mananger -> SQL Server Services -> SQL server (SQL Express) - Botão direito do mouse -> na propiedade Built-In Count selecione Netuser Services.

    entre no nó SQL Server Network Configuration -> Protocols for SQLExpress ->  Ative os protocolos abaixo
    Shared Memory - Enabled
    Named Pipes - Enabled
    TCP/IP - Enabled
    Via - Enabled

    Restart os SQLServer

    Se não ter certo me mande um email

    elias@estadao.com.br

    Elias

    quinta-feira, 4 de fevereiro de 2010 14:22