none
"Failed to retrieve the information for the cluster resources" in Failover Cluster

    Întrebare

  • Hi,

    after taken over a failover cluster as admin i need some help to understand the problem with one our failover clusters. The origin of the problem is a failed node and apparently a accidently deleted cluster name object in AD. The previous admin did recreate the object in AD named "CLUSTER" as it was before the deletion. After that, i took over and the cluster is working as intended with failover occurring and no problems with other resources. The only thing that is not working is to retrieve the information about the cluster core resources. In failover Cluster Manager no information about the cluster is given and in summary all object is displaying "<unavailable>". Under cluster core resources "Failed to retrieve the information for the cluster resources" is shown though both cluster name and ip is online after checking it with Get-ClusterResources.

    I have followed the following article and changed the ObjectGUID of the resource "CLUSTER" so it matches the ObjectGUID in the corresponding AD computer object but it did not resolve the problem.

    https://blogs.technet.microsoft.com/csstwplatform/2010/10/14/cluster-network-name-resource-cluster-name-cannot-be-brought-online-unable-to-get-computer-object-using-guid/

    Any thoughts and suggestions about what could cause this behavior and maybe how to resolve it?

    joi, 17 mai 2018 07:40

Toate mesajele

  • Hi,

    Thanks for your question.

    > The only thing that is not working is to retrieve the information about the cluster core resources. In failover Cluster Manager no information about the cluster is given and in summary all object is displaying "<unavailable>". Under cluster core resources "Failed to retrieve the information for the cluster resources" is shown though both cluster name and ip is online after checking it with Get-ClusterResources.

    1. Could you please provide a screenshot of the cluster manager that shows the issue? Do all cluster nodes’ failover manager fail to show the information?

    2. What is the cluster node’s OS version? Please check if the Cluster nodes are patched with the latest windows update, if not, please update them?

    3. Please run Cluster validation wizard at a maintenance time, check if there any error or warnings.

    4. Please check the cluster failover events in event viewer, check if there’s any error, if yes, please provide the information for us.

    5. Have you tried to restart the cluster services, could a reboot work?

    Highly appreciate your effort and time. If you have any concerns or questions, please feel free to let me know.

    Best Regards,

    Michael


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    vineri, 18 mai 2018 09:48