none
Unable to connect to cluster using Failover Cluster Manager

    Întrebare

  • In the last day or so I've discovered that I'm no longer able to connect to my cluster using Failover Cluster Manager.  When I try to connect it gives me the error "An error occurred connecting to the cluster <cluster name>.  An error occurred trying to display the cluster information.  One or more errors occurred."

    If I log onto the node that's hosting the "Cluster Group" cluster resource, and open Failover Cluster Manager and connect to <Cluster on this server...> it gives me a similar message.

    As far as I can see, the Cluster Powershell commands still work, so I've moved the "Cluster Group" group to another node, but I am still unable to connect to the cluster using Failover Cluster Manager.

    The Cluster Service is running, and I'm reluctant to restart it becuase I know my Virtual Machines are going to start failing or failing over when I do this.

    I have verified that I am logged in as a super-duper user, even tried logging as the Domain Administrator with no luck.  I have also tried the WMI Mofcomp suggestion as described in http://www.yusufozturk.info/windows-server/failover-cluster-manager-an-error-occurred-to-display-cluster-information.html with no luck.

    Any suggestions?

    joi, 20 martie 2014 15:12

Răspunsuri

Toate mesajele

  • joi, 20 martie 2014 16:09
  • Thank you for your post.  I have run the script and can confirm that one of my servers is hosed.

    Getting the cluster nodes...Found the below nodes
     

    Name                 ID    State                                                                                                           
    ----                 --    -----                                                                                                           
    mgmt41               1     Up                                                                                                              
    mgmt42               2     Up                                                                                                              
    mgmt43               3     Up                                                                                                              
    mgmt44               4     Up                                                                                                              

    Running the WMI query....
     
    mgmt41 : WMI query succeeded
    mgmt42 : WMI Query failed //
    mgmt43 : WMI query succeeded
    mgmt44 : WMI query succeeded

    Unfortunately, it's not giving me an exception, and the

    cd c:\windows\system32\wbem
    mofcomp.exe cluswmi.mof

    Instructions do not resolve the situation.  Since (fortunately) my Powershell cluster commands still work, I will live migrate my 150+ virtual machines off to the other 3 nodes, give this a reboot and check the status thereafter.  Will provide further feedback.

    joi, 20 martie 2014 17:01
  • I think you should first try to restart winmgmt service on node 42, although I don't expect that to work. A reboot will solve the problem most likely.
    joi, 20 martie 2014 17:55
  • A reboot did solve the problem.  I didn't try to restart the winmgmt service though, if this happens again, I will attempt that first.  Thank you for your assistance.
    joi, 20 martie 2014 18:13
  • Hello,  
    I have tried almost everything and the problem is still there. Can't establish connection using Failover Cluster Manager MMC. Checked everything related to WMI and it looks good, no errors. 

    Another thing is I am able to connect and manage cluster using VMM Manager installed on other host w/o any problem. Any idea what else can be done? 
    Thanks 

    joi, 23 februarie 2017 16:59
  • I have found WMI connection issue with one of cluster node. After restarting WMI service on the host, Cluster got connected.
    duminică, 13 mai 2018 12:01