none
Откат на предыдущую версию. RRS feed

  • Вопрос

  • Добрый день!

    Установил свежую версию Exc 2016 CU8. Оказалось, что в новой версии у всех проблемы с открытием в браузере owa, ecp открывается нормально, дело в том, что это новое обновление затирает сертификат, пробовал всяческие инструкции не помогает. Пишет - X-OWA-Error Microsoft.Exchange.Diagnostics.ExAssertException

    Наверное был конец декабря и сотрудники Майкрософта выпили и не до тестирования было ))

    Вообщем похоже надо качать и ставить предыдущую сборку CU7, как мне корректно удалить с серверов CU8 и установить CU7? Просто через установку/удаление не так просто, ругается то на базы, то на еще что, есть какое-то руководство? Или проще будет грохнуть сервера и базы в оснастке ADSI - Конфигурация?

    Сервер пустой, нулевой, ни чего не потеряется, ни пользователей, ни писем нет. 

    31 января 2018 г. 13:02

Ответы

  • Удаляйте все. У вас все равно нет других серверов Exchange. Название какое захотите, можно прежнее, можно новое.
    • Предложено в качестве ответа Dima RazbornovMVP 1 февраля 2018 г. 6:02
    • Отменено предложение в качестве ответа trofimovslava 1 февраля 2018 г. 9:30
    • Помечено в качестве ответа trofimovslava 1 февраля 2018 г. 9:30
    31 января 2018 г. 18:13

Все ответы

  • Добрый день,

    если не получается через установку и удаление, да и сервер у вас пустой, то сценарий номер 3 ваш.

    31 января 2018 г. 13:56
  • дело в том, что это новое обновление затирает сертификат,

    Вот с этого момента поподробней, пожалуйста.

    Обжигающие брюнеты лечат без переустановки.

    31 января 2018 г. 14:48
  • Вероятно имелось ввиду вот это.

    Если уже начали ломать через установку/удаление, то без переустановки может уже и "не взлететь", смотря до куда дошли))

    Дима, поправь ссылку на рабочую.

    P.S. Станислав Булдаков еще на фб писал про поломку EWS в CU8, но там специфичный случай...

    31 января 2018 г. 15:10
  • Да  это мой случай по нему и пытался вылечить, но мне не помогло. Пока ни чего не удалял и не ломал, тренировался в тестовой среде. Какие прогнозы?

    Это возможно вылечить или надо ставить CU7? 


    31 января 2018 г. 15:27
  • Т.е. есть прям

    Log Name:      Application
    Source:        MSExchange OAuth
    Event ID:      2004

    ?

    Странно, что не помогло- полфорума бегало с этим. В общем случае решать Вам- что быстрее, полечить или установить 7-й.

    31 января 2018 г. 15:35
  • Если еще ничего не ломали, пробуйте по ссылке от Димы, он там немного лишнего накопировал,  подправил на рабочую.
    31 января 2018 г. 15:35
  • Если еще ничего не ломали, пробуйте по ссылке от Димы, он там немного лишнего накопировал,  подправил на рабочую.

    Меня подставили!!!111
    31 января 2018 г. 15:36
  • Вот кстати этого эвента нету, но симпомы такие же, ова открывается с такой же ошибкой и при запросе

    Get-ExchangeCertificate(Get-AuthConfig).CurrentCertificateThumbprint - выдает также сертификат not found.

    Я с этим весь день мучаюсь, вот уже решил что проще поставить заново более старую версию. Вопрос как это корректно сделать?

    Достаточно грохнуть виртуальную машину с экченжем, и в оснастке Сайты и Сервисы, удалить из

    CN=Servers,CN=Exchange Administrative Group и CN=Databases,CN=Exchange Administrative Group, сервера и базы?

    Или нужно прям всё грохать?

    31 января 2018 г. 15:47
  • Вот кстати этого эвента нету, но симпомы такие же, ова открывается с такой же ошибкой и при запросе

    Get-ExchangeCertificate(Get-AuthConfig).CurrentCertificateThumbprint - выдает также сертификат not found.

    Я с этим весь день мучаюсь, вот уже решил что проще поставить заново более старую версию. Вопрос как это корректно сделать?

    Достаточно грохнуть виртуальную машину с экченжем, и в оснастке Сайты и Сервисы, удалить из

    CN=Servers,CN=Exchange Administrative Group и CN=Databases,CN=Exchange Administrative Group, сервера и базы?

    Или нужно прям всё грохать?

    Раз не выходит, в первом посту есть ссылка, там очень даже по по русски написано, что нужно "грохнуть". ВМ естественно переустановить.

    31 января 2018 г. 17:55
  • Спасибо это я понял. вот и возник вопрос действительно необходимо всю организацию удалять или достаточно будет только сервера и базы как я написал и переустановить сервер в туже организацию, чем это чревато? И если удалить организацию, при установки сервера лучше дать другое название организации или можно прежнее использовать?
    31 января 2018 г. 18:08
  • Удаляйте все. У вас все равно нет других серверов Exchange. Название какое захотите, можно прежнее, можно новое.
    • Предложено в качестве ответа Dima RazbornovMVP 1 февраля 2018 г. 6:02
    • Отменено предложение в качестве ответа trofimovslava 1 февраля 2018 г. 9:30
    • Помечено в качестве ответа trofimovslava 1 февраля 2018 г. 9:30
    31 января 2018 г. 18:13
  • В тестовой среде, почистил, установил Exc 2016 CU7, все нормально открывается и ecp и owa. В сертификатах есть 3 штуки и Microsoft Exchange Server Auth Certificate в том числе.

    А после установки CU8 его не было, было только 2 сертификата.

    P.S. Единственное, было создано 2 ящика, один у того пользователя которым установка была и второй тестовый и у этих юзеров какие-то данные в профиль записались, о базе и т.д. и теперь ругается при открытии их в панели экченжа, можно как-то их исправить указать путь к новой базе почтовой или удалить пользователtй этих и заново создать в AD?
    1 февраля 2018 г. 6:00
  • Нет, пользователей удалять точно не надо. Попробуйте посмотреть, показывает ли их Get-Mailbox. Если да, то удалить через Remove-Mailbox. 

    Если не поможет, то можно будет почистить атрибуты через ADSI edit. 

    1 февраля 2018 г. 6:57
  • Да Get-Mailbox показывает этих пользователей, так если я наберу команду Remove-Mailbox "пользователь" - он удалит не только ящик но и учетку в AD.
    1 февраля 2018 г. 7:14
  • Да, вы правы, извиняюсь :) Конечно же, надо использовать Disable-Mailbox.

    1 февраля 2018 г. 7:44