none
Exch2007: Autodiscover, заместитель и постоянный запрос логина RRS feed

  • Вопрос

  • Exchange 2007 SP1 + Rollpack8 на Windows 2008 Standart (выполняет 3 роли: мейлбоксы, клиентский доступ и хаб). Существует параллельно с несколькими серверами Exch 2003 (идет процесс миграции)

    Устал бороться со следующей проблемой.

    1.       Когда первый раз запускаем Аутлук 2007 на рабочей машине определяется локальные пользователь, его адрес и сервер на котором находиться ящик (новый сервер с Exch 2007). Тут же появляется диалог для ввода логина и пароля, вводить этот логин можно вечно – запрос появляется снова и снова.

    2.       На уже настроенных Аутлуках 2007 при доступе к пункту Заместитель выскакивает ошибка.

    3.       Тем не менее на некоторых машинах на которых аутлук настроен давно Заместитель чудесным образом заработал.

    Понимаю,   что проблема в настройке веб-сервисов Exchange , но в чем именно проблема понять не могу.

    Детали

     

    [PS] C:\Windows\system32>Get-ClientAccessServer |fl

     

    Name                           : VL-SRV1

    OutlookAnywhereEnabled         : False

    AutoDiscoverServiceCN          : vl-srv1

    AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service

    AutoDiscoverServiceInternalUri : https://vl-srv1.internal.ru/Autodiscover/Autodiscover.xml

    AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596

    AutoDiscoverSiteScope           : {Vladivostok-Gogolya}

    IsValid                        : True

    OriginatingServer              : server.internal.ru

    ExchangeVersion                : 0.1 (8.0.535.0)

    DistinguishedName              : CN=VL-SRV1,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=internal,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=ru

    Identity                       : VL-SRV1

    Guid                           : 89a19437-e4d9-4d3d-95ce-b9b01fe88e0d

    ObjectCategory                 : internal.ru/Configuration/Schema/ms-Exch-Exchange-Server

    ObjectClass                    : {top, server, msExchExchangeServer}

    WhenChanged                    : 08.05.2009 17:50:46

    WhenCreated                    : 08.05.2009 17:41:57

     

    [PS] C:\Windows\system32>Get-AutodiscoverVirtualDirectory |fl

     

    Name                          : Autodiscover (Default Web Site)

    InternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated}

    ExternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated}

    BasicAuthentication           : True

    DigestAuthentication          : False

    WindowsAuthentication         : True

    MetabasePath                  : IIS://vl-srv1.internal.ru/W3SVC/1/ROOT/Autodiscover

    Path                          : C:\Program Files\Microsoft\Exchange Server\ClientAccess\Autodiscover

    Server                        : VL-SRV1

    InternalUrl                   : https://vl-srv1.internal.ru/Autodiscover/Autodiscover.xml

    ExternalUrl                   :

    AdminDisplayName              :

    ExchangeVersion               : 0.1 (8.0.535.0)

    DistinguishedName             : CN=Autodiscover (Default Web Site),CN=HTTP,CN=Protocols,CN=VL-SRV1,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=internal,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=ru

    Identity                      : VL-SRV1\Autodiscover (Default Web Site)

    Guid                          : e276ee96-9f7a-470c-be0d-1bd8ed76275d

    ObjectCategory                : internal.ru/Configuration/Schema/ms-Exch-Auto-Discover-Virtual-Directory

    ObjectClass                   : {top, msExchVirtualDirectory, msExchAutoDiscoverVirtualDirectory}

    WhenChanged                    : 25.06.2009 19:10:13

    WhenCreated                   : 08.05.2009 17:47:33

    OriginatingServer             : server.internal.ru

    IsValid                       : True

     

     

    [PS] C:\Windows\system32>Get-OutlookProvider |fl

     

     

    CertPrincipalName :

    Server             : vl-srv1.internal.ru

    TTL               : 1

    AdminDisplayName  :

    ExchangeVersion   : 0.1 (8.0.535.0)

    Name              : EXCH

    DistinguishedName : CN=EXCH,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=internal,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=ru

    Identity          : EXCH

    Guid              : 2168bf74-0006-4adf-baad-0aaefc8d3015

    ObjectCategory    : internal.ru/Configuration/Schema/ms-Exch-Auto-Discover-Config

    ObjectClass       : {top, msExchAutoDiscoverConfig}

    WhenChanged       : 25.06.2009 17:51:38

    WhenCreated       : 08.05.2009 17:47:33

    OriginatingServer : server.internal.ru

    IsValid           : True

     

    CertPrincipalName :

    Server            : vl-srv1.internal.ru

    TTL               : 1

    AdminDisplayName  :

    ExchangeVersion   : 0.1 (8.0.535.0)

    Name              : EXPR

    DistinguishedName : CN=EXPR,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=internal,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=ru

    Identity          : EXPR

    Guid              : b7dea364-235b-4b14-aff3-824fd502813d

    ObjectCategory    : internal.ru/Configuration/Schema/ms-Exch-Auto-Discover-Config

    ObjectClass       : {top, msExchAutoDiscoverConfig}

    WhenChanged       : 25.06.2009 17:52:03

    WhenCreated       : 08.05.2009 17:47:33

    OriginatingServer : server.internal.ru

    IsValid           : True

     

    CertPrincipalName :

    Server            : vl-srv1.internal.ru

    TTL               : 1

    AdminDisplayName  :

    ExchangeVersion   : 0.1 (8.0.535.0)

    Name              : WEB

    DistinguishedName : CN=WEB,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=internal,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=internal,DC=ru

    Identity          : WEB

    Guid              : bc455805-adb1-4859-b4b6-d1a0ef747f44

    ObjectCategory    : internal.ru/Configuration/Schema/ms-Exch-Auto-Discover-Config

    ObjectClass       : {top, msExchAutoDiscoverConfig}

    WhenChanged       : 25.06.2009 17:52:12

    WhenCreated       : 08.05.2009 17:47:34

    OriginatingServer : server.internal.ru

    IsValid           : True

     

    При попытке зайти на https://vl-srv1/ Autodiscover/ Autodiscover. xml получаем 

      <?xml version="1.0" encoding="utf-8" ?>

    - <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">

    - <Response>

    - <Error Time="19:37:14.2504823" Id="2168208473">

      <ErrorCode>600 </ErrorCode>

      <Message>Недопустимый запрос </Message>

      <DebugData />

      </Error>

      </Response>

      </Autodiscover>

     

    Если на машине где Аутлук уже настроен и работает проверяем настройку сервиса Autodiscover через Ctrl + правый клик мыши на иконке Аутлука   получаем

    <?xml version="1.0" encoding="utf-8"?>

    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">

      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">

        <User>

          <DisplayName>Petr Ivanov</DisplayName>

          <LegacyDN>/o=internal/ou=First Administrative Group/cn=Recipients/cn=vereschagin</LegacyDN>

          <DeploymentId>87aa7369-bb01-4e78-9196-396fccbbbef3</DeploymentId>

        </User>

        <Account>

          <AccountType>email</AccountType>

          <Action>settings</Action>

          <Protocol>

            <Type>EXCH</Type>

            <Server>vl-srv1.internal.ru</Server>

            <ServerDN>/o=internal/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=VL-SRV1</ServerDN>

            <ServerVersion>720180F0</ServerVersion>

            <MdbDN>/o=internal/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=VL-SRV1/cn=Microsoft Private MDB</MdbDN>

            <PublicFolderServer>server.internal.ru</PublicFolderServer>

            <AD>vl-srv3.internal.ru</AD>

            <ASUrl>https://vl-srv1.internal.ru/EWS/Exchange.asmx</ASUrl>

            <EwsUrl>https://vl-srv1.internal.ru/EWS/Exchange.asmx</EwsUrl>

            <OOFUrl>https://vl-srv1.internal.ru/EWS/Exchange.asmx</OOFUrl>

            <UMUrl>https://vl-srv1.internal.ru/UnifiedMessaging/Service.asmx</UMUrl>

            <OABUrl>http://vl-srv1.internal.ru/OAB/df785aaa-87e7-42c0-850e-c93dc74bfc8c/</OABUrl>

          </Protocol>

          <Protocol>

            <Type>EXPR</Type>

            <Server>vl-srv1.internal.ru</Server>

          </Protocol>

          <Protocol>

            <Type>WEB</Type>

            <Internal>

              <OWAUrl AuthenticationMethod="Basic, Fba">https://vl-srv1.internal.ru/owa</OWAUrl>

              <Protocol>

                <Type>EXCH</Type>

                <ASUrl>https://vl-srv1.internal.ru/EWS/Exchange.asmx</ASUrl>

              </Protocol>

            </Internal>

          </Protocol>

        </Account>

      </Response>

    </Autodiscover>

     

    • Изменено Kirill Vereschagin 25 июня 2009 г. 9:12
    • Перемещено Hengzhe Li 12 марта 2012 г. 9:32 forum merge (От:Exchange Server 2007)
    25 июня 2009 г. 9:11

Ответы

  • Большое спасибо всем попытавшимся помочь.
    Проблема наконец-то решена.
    Причина, симптомы и решение  абсолютно идентичные описанным в этом посте http://social.technet.microsoft.com/forums/ru-RU/ocses2007ru/thread/a15c8de6-f506-4e14-a6ef-0028bed1f7c9/

    Так же проблема описана в статье http://support.microsoft.com/default.aspx/kb/927612
    • Помечено в качестве ответа Kirill Vereschagin 17 июля 2009 г. 4:31
    17 июля 2009 г. 4:31

Все ответы

  • Что в логах Exchange 2007 и контроллера домена ?

    Если включить anyware проблема останется ?

    Есть ли на сервере/клиентах firewall/antivirus ?

    Первое правило Windows - делай резервную копию. Коды ошибок смотрите по адресу http://support.microsoft.com и http://eventid.net/
    26 июня 2009 г. 5:12
    1.  В логах контролерров домена (в сайте где находитьяс Exch 2007 их два) никакого криминала/ошибок не наблюдается. В логе ПРиложения сервера Exchange только мелочи не относящиеся к этой проблеме, остальные логи вообще не содержат ничего плохого.
    2. Файрволов на ни на сервере ни на тестовой машине нет, антивирус стоит только на сервере - McAfee VirusScan 8.5. Никакого функционала блокирующего/фильтрующего HTTP не включено.
    3. Только сегодня эксприментировал с Outlook Anywhere (External URL задавал адресом внутренного сервера, авторизация NTLM). Результата не дало. Вывод теста следующий, по ошибке информацию еще не копал:
    [PS] C:\Windows\system32>Test-OutlookWebServices -identity tset@dns.vl.ru |fl
    
    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address tset@dns.vl.ru.
    
    Id      : 1006
    Type    : Information
    Message : The Autodiscover service was contacted at https://vl-srv1/Autodiscover/Autodiscover.xml.
    
    Id      : 1016
    Type    : Success
    Message : [EXCH]-Successfully contacted the AS service at https://vl-srv1/ews/Exchange.asmx. The elapsed time was 180 milliseconds.
    
    Id      : 1015
    Type    : Success
    Message : [EXCH]-Successfully contacted the OAB service at https://vl-srv1/ews/Exchange.asmx. The elapsed time was 0 milliseconds.
    
    Id      : 1014
    Type    : Success
    Message : [EXCH]-Successfully contacted the UM service at https://vl-srv1.internal.ru/UnifiedMessaging/Service.asmx. The elapsed time was 17 milliseconds.
    
    Id      : 1016
    Type    : Information
    Message : [EXPR]-The AS is not configured for this user.
    
    Id      : 1015
    Type    : Information
    Message : [EXPR]-The OAB is not configured for this user.
    
    Id      : 1014
    Type    : Information
    Message : [EXPR]-The UM is not configured for this user.
    
    Id      : 1013
    Type    : Error
    Message : When contacting https://vl-srv1.internal.ru/Rpc received the error The server committed a protocol violation. Section=ResponseStatusLine
    
    Id      : 1017
    Type    : Error
    Message : [EXPR]-Error when contacting the RPC/HTTP service at https://vl-srv1.internal.ru/Rpc. The elapsed time was 102 milliseconds.
    
    Id      : 1006
    Type    : Success
    Message : The Autodiscover service was tested successfully.
    
    Id      : 1021
    Type    : Information
    Message : The following web services generated errors.
                  Contacting server in EXPR
              Please use the prior output to diagnose and correct the errors.


    26 июня 2009 г. 9:27
  • IIS на Exchange естественно установлен ?

    О каких "мелочах" идёт речь ?

    Если временно удалить rollup проблема останется ?

    ipv6 отключать пробовали ?
    Первое правило Windows - делай резервную копию. Коды ошибок смотрите по адресу http://support.microsoft.com и http://eventid.net/
    26 июня 2009 г. 10:08
  • дело скорее всего не в Exchange а в клиенте.
    попробуйте зайти на клиенте под другим пользователем и настроить почту.
    проверьте, не просроченна ли учетная запись пользователя/компьютера.
    не работает ли брандмауэр.
    удалите лишние сохраненные пароли на клиенте (пуск-панель управления-ключи и пароли)
    29 июня 2009 г. 6:44
  • IIS на Exchange естественно установлен ?

    О каких "мелочах" идёт речь ?

    Если временно удалить rollup проблема останется ?

    ipv6 отключать пробовали ?
    Первое правило Windows - делай резервную копию. Коды ошибок смотрите по адресу http://support.microsoft.com и http://eventid.net/
    1. IIS конечно установлен. Я же писал что например получаю содержание файла autodiscover.xml
    2. Мелочи - это напоминания рейд-контроллера что батарейка заряжается, изредка сообщения, что не может достучаться до ДК дочернего домена когда связи с ним нет и т.п. не относящиеся к проблеме.
    3. Удалить rollup не пробовал
    4. ipv6 пробовал удалить, результат тот же
    5. Не может ли быть причиной самоподписанный сертификат которым "заверяются" https соединения с веб-сервисами Exchange???

    29 июня 2009 г. 23:21
  • дело скорее всего не в Exchange а в клиенте.
    попробуйте зайти на клиенте под другим пользователем и настроить почту.
    проверьте, не просроченна ли учетная запись пользователя/компьютера.
    не работает ли брандмауэр.
    удалите лишние сохраненные пароли на клиенте (пуск-панель управления-ключи и пароли)
    Не согласен. Дело точно не в клиенте. Описанный симптом наблюдается на разных станциях (WinXP SP3). Учетные записи пользователей и машин в порядке. Брэндмауэры изначально отключены групповой политикой. Антивирусного ПО на тестируемых станциях для чистоты эксперимента не установлено.
    29 июня 2009 г. 23:25
  • Кажется нашел потенциальную причину проблемы!
    [PS] C:\Windows\System32>Get-ExchangeCertificate |fl
    AccessRules : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl
    .CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {vl-srv1, vl-srv1.internal.ru}
    HasPrivateKey : True
    IsSelfSigned : True
    Issuer : CN=vl-srv1
    NotAfter : 08.05.2010 17:43:57
    NotBefore : 08.05.2009 17:43:57
    PublicKeySize : 2048
    RootCAType : None
    SerialNumber : 28FA339FF8FE0FB141641EA0A8789DD0
    Services : IMAP, POP, IIS, SMTP
    Status : Valid
    Subject : CN=vl-srv1
    Thumbprint : D88D95390FB6BED7B78363F0B0F5C56C36D0F635
    AccessRules : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
    CertificateDomains : {vl-dc1 .internal.ru}
    HasPrivateKey : True
    IsSelfSigned : False
    Issuer : CN=server, DC=internal, DC=ru
    NotAfter : 06.05.2010 17:12:54
    NotBefore : 06.05.2009 17:12:54
    PublicKeySize : 1024
    RootCAType : Enterprise
    SerialNumber : 1AB527E6000000000050
    Services : None
    Status : Valid
    Subject : CN=vl-dc1 .internal.ru
    Thumbprint : 6016BEE3941144A6E4183B9F248FFE43C72F51FE
    То есть на сервере используются два сертификата.
    Один на настоящее имя сервера: vl-srv1 и vl-srv1.internal.ru. Это самоподписанный сертификат сгенерированный при установке Exchange.
    А второй на имя vl-dc1 (так сервер назывался до того как на него начали устанавливать Exchange) выдан сервером server.internal.ru (экспериментальный сервер PKI установленный в домене).

    Не может ли это быть причиной описанных мною проблем?
    30 июня 2009 г. 3:43
  • Проблему удалось решить? А то мигрировал пользователей из одно домена в другой, поставил эксченж, у большенства людей ящики настроились нормально, а у некоторых такая же фигна, вначале просит ввести логин для доступа на комп где эксченж стоит, потом после длительных попыток discavere выводит.
    9 июля 2009 г. 13:52
  • Кстати доверие self-signed сертификату есть?
    http://technet.microsoft.com/en-us/library/bb400931.aspx

    Как насчет настроек прокси в IE?

    10 июля 2009 г. 4:51
  • Пробую сделать по ссылке, пишет ошибку:
    Export-ExchangeCertificate : Ошибка экспорта в формате PKCS-12: не удается полу
    чить доступ к закрытому ключу, либо этот ключ не экспортируется.
    Parameter name: Thumbprint
    At line:1 char:27
    + Export-ExchangeCertificate  <<<< -Thumbprint AA15D0501B7E8D88EDBB348EB4FE36C7
    5E293C6B -BinaryEncoded:$true -Path c:\export.pfx -Password:(Get-Credential).pa
    ssword

    А разве настроки в браузере и настройки почты, как-то влияют друг на друга?

    Попробывал убрать в браузере настройки к прокси, все заработало. Тогда вопрос, какое это отношение имеет к почте и у меня на некоторых компах идет авторизация по пользователям в инет (на ИЕ), как тогда настроить почту?
    • Изменено Samodelkin 10 июля 2009 г. 5:58
    10 июля 2009 г. 5:19
  • Очень даже влияют, Outlook 2007 при подключении по https использует настройки прокси в IE
    Как настроить почту - вопрос отдельный. А вот как настроить прокси - вопрос другой. Как минимум не использовать прокси для локальных серверов, прописать ваш внутренний домен в исключения


    ПС. Сертификат по умолчанию не экспортируется. Однако если у вас не развернута инфраструктура PKI и вы не хотите платить денег за внешний сертификат, мы можете самостоятельно создать свой самоподписанный сертификат и провести указанную процедуру. Подробнее об Exchange и сертификатах тут http://technet.microsoft.com/en-us/library/bb851505.aspx
    • Предложено в качестве ответа Vinokurov Yuriy 10 июля 2009 г. 9:56
    10 июля 2009 г. 6:13
  • Большое спасибо всем попытавшимся помочь.
    Проблема наконец-то решена.
    Причина, симптомы и решение  абсолютно идентичные описанным в этом посте http://social.technet.microsoft.com/forums/ru-RU/ocses2007ru/thread/a15c8de6-f506-4e14-a6ef-0028bed1f7c9/

    Так же проблема описана в статье http://support.microsoft.com/default.aspx/kb/927612
    • Помечено в качестве ответа Kirill Vereschagin 17 июля 2009 г. 4:31
    17 июля 2009 г. 4:31