locked
RPC фильтр блокирует DCOM-трафик, ошибка 0x800706BF RRS feed

  • Вопрос

  • Здравствуйте.

    Ситуация следующая. Есть standalone-массив из двух TMG-серверов. На одном из них установлено COM-приложение серверная часть, на втором клиентская часть, которая должна взаимодействовать с серверной. При отключенном RPC-фильтре все работает без проблем, однако, если фильтр включен, то возникают проблемы: сначала клиентское приложение подключается к серверной части (CoCreateInstanceEx), это происходит без проблем, далее вызывается метод COM-объекта, который завершается с ошибкой 0x800706BF ("The remote procedure call failed and did not execute").

     

    Ничего из перепробованного мною не помогло:

    - создал access rule "Allow All", разрешающее весь outbound traffic (from: internal; to: internal; all outbound traffic; all users)

    - снял галочку "Enforce strict RPC compliance" (запрещающую DCOM трафик) в двух местах - в системных политиках (Active Directory group) и правиле "Allow all".

    - удалил оба сервера из группы Remote Management Computers, это рекомендовалось в здесь

    - смотрел лог TMG, никаких заблокированных соединений не указано не было.

     

    В чем еще может быть дело? Как можно разрешить взаимодействие не выключая RPC-фильтр?

     

    P.S. На обоих серверах установлен TMG 2010 EE 7.0.7734.100, Windows Server 2008.

    13 августа 2011 г. 5:41

Ответы

  • попробуйте так

    Enabling DCOM traffic

     

    When the Microsoft Management Console (MMC) rules are enabled, remote procedure call (RPC) traffic is allowed to the Local Host network. However, by default, DCOM traffic is blocked. If you want to allow DCOM traffic, disable the “Allow remote management from selected computers using MMC” system policy rule. Then, create a rule allowing RPC traffic. After creating the rule, in the rule properties, configure the RPC protocol and clear the Enforce strict RPC compliance setting.

     

    отсюда http://technet.microsoft.com/en-us/library/bb794729.aspx


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    • Помечено в качестве ответа Vinokurov Yuriy 30 августа 2011 г. 12:54
    22 августа 2011 г. 11:25

Все ответы

  • У вас трафик на Local Host - поэтому смотрите системные правила, в которых есть RPC протокол на Local Host, и выключите их.


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    15 августа 2011 г. 2:50
  • Спасибо за ответ!

     

    Действительно нашлись три системных правила, которые блокируют DCOM-трафик:

     

     

    #2  Allow remote management from selected computers using MMC

    #22 Allow RPC from Forefront TMG to trusted servers

    #36 Allow intra-array communication


     

    У правила "Allow RPC from Forefront TMG to trusted servers" есть возможность разрешить DCOM, отключив галочку "Enforce strict RPC compliance" в редакторе системной политики.

    Однако у двух других такой галочки нет, приходится их отключать, что нежелательно. Есть ли возможность как-то разрешить DCOM, не отключая системные правила?


    18 августа 2011 г. 7:56
  • попробуйте так

    Enabling DCOM traffic

     

    When the Microsoft Management Console (MMC) rules are enabled, remote procedure call (RPC) traffic is allowed to the Local Host network. However, by default, DCOM traffic is blocked. If you want to allow DCOM traffic, disable the “Allow remote management from selected computers using MMC” system policy rule. Then, create a rule allowing RPC traffic. After creating the rule, in the rule properties, configure the RPC protocol and clear the Enforce strict RPC compliance setting.

     

    отсюда http://technet.microsoft.com/en-us/library/bb794729.aspx


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    • Помечено в качестве ответа Vinokurov Yuriy 30 августа 2011 г. 12:54
    22 августа 2011 г. 11:25