none
Ошибка установки обновлений Framework 3 RRS feed

  • Вопрос

  • Стоит WSUS 3. 50 машин в сети, WinXP sp2 and sp3, вчера начали появляться сообшения об ошибках установки, с таким текстом:

    mst2
    Microsoft .NET Framework 3.0: x86 (KB928416)
    Событие зарегистрировано 25.09.2008 16:47:
    Ошибка установки: не удается установить следующее обновление из-за ошибки 0x80070643: Microsoft .NET Framework 3.0: x86 (KB928416).
    Подскажите может кто сталкивался, часть машин приняла его и нормально работает

    25 сентября 2008 г. 11:33

Ответы

Все ответы

  • Было такое. Не устанавливалось по тому что на машинах небыло MSXML 6.0. В пакете с WSUS его нет, а в пакете скаченом с сайта загрузки он есть. Таких компов было мало, поставил ручками.

     

    Имеется подобная проблемма но с Microsoft .NET Framework 3.0: языковой пакет для систем x86 (KB928416). Выдает:

    Ошибка установки: не удается установить следующее обновление из-за ошибки 0x80070643: Microsoft .NET Framework 3.0: языковой пакет для систем x86 (KB928416).

     

    При ручной установке выдает, что более новая версия пакета уже установлена, а WSUS все равно упорно хочет его ставить. Ничего пока сделать не могу.

     

    26 сентября 2008 г. 10:27
  • 26 сентября 2008 г. 12:10
    Модератор
  • У меня установлено это обновление, но при этом на некоторых компах Framework3 не ставится, а WSUS при этом рапортует, что на этих компьютерах установлено 100% обновлений и они больше не нуждаются. Кому верить?

    3 октября 2008 г. 7:06
  • WSUS ставит обновления, а на этих компьютерах вообще есть Framework?

    3 октября 2008 г. 9:52
    Модератор
  • Вообще, как я понимаю, WSUS ставит не только обновления, но и "пакеты новых функций", к коим и относится Framework. На большинстве компьютеров Framework'и 2&3 со всеми причиндалами установились без шума и пыли. Но на 6-7 компьютерах возникли какие-то проблемы с Framework3, хотя после выхода в пятницу новой редакции Framework3, на некоторых из проблемных компьютеров необходимость в F3 почему-то отпала- сообщения о том, что "обновление загружено и готово к установке" пропали.

    P.S. На один из компьютеров WSUS в течение 2-х недель упорно пытался поставиить обновление для F1.1., хотя сам F1.1 там установлен не был, но стояли F2&F3.

    P.P.S. Та же петрушка на нескольких компах и с Silverlight 1.0

    5 октября 2008 г. 19:58
  •  

    Framework 3.0 не устанавливался на XP SP3

    http://blogs.technet.com/sus/archive/2008/09/16/net-framework-updates-not-being-offered-to-windows-xp-sp3-computers.aspx

    С версией от 23 сентября возникли проблемы, 2 октября появился новый релиз и проблема разрешена.

     

    По Silverlight 1.0 У меня были циклические установки на некоторых компьютерах. После decline перекрытого обновления Silverlight (январь 2008 года) проблема пропала.

     

    По обновлению F1.1 ничего сказать не могу: мало информации.

    6 октября 2008 г. 4:53
    Модератор
  • По silverlight'у оказалось: попытался установить вручную- он ругнулся на  то, что процессор (AMD 900MHz) не соответствует минимальным требованиям. Странно, на сайте написано не менее 500, т.е. вроде бы условие выполнено, памяти 256, а не ставится.

    6 октября 2008 г. 13:59
  • Есть такое. Нужна поддержка SSE, а не все процессоры AMD поддерживают SSE или возможно неправильно сообщают об этом. Покрайней мере так пишут в Интернете.

     

    7 октября 2008 г. 5:52
    Модератор
  • Нужно удалить  обновление Microsoft .NET Framework 3.0 Service Pack 1 (KB929300), потом установить Microsoft .NET Framework 3.0 версия 3.0.4506.30 из пакета Microsoft .NET Framework 3.0- x86 (KB928416), затем языковой пакет для ситем X86 (KB928416) 6,50 мб, а после этого опять установить обновление Microsoft .NET Framework 3.0 Service Pack 1 (KB929300)

    9 октября 2008 г. 21:18
  • Это откуда такая методика?

    10 октября 2008 г. 16:15
    Модератор
  • Столкнулся с означенной проблемой. Ошибка установки: не удается установить следующее обновление из-за ошибки 0x80070643: Microsoft .NET Framework 3.0: языковой пакет для систем x86 (KB928416).
    MSXML 6.0 на машинах установлен.
    Проблема появилась после установки MS Visual Studio C# Express Edition Rus.
    Пробовал метод с удалением Framework и установкой в указанной выше последовательности - не помогает.
    Есть ли другая методика устраниения проблемы?
    17 декабря 2008 г. 12:07
  •  Yazev Yura написано:

    Имеется подобная проблемма но с Microsoft .NET Framework 3.0: языковой пакет для систем x86 (KB928416). Выдает:

    Ошибка установки: не удается установить следующее обновление из-за ошибки 0x80070643: Microsoft .NET Framework 3.0: языковой пакет для систем x86 (KB928416).

     

    При ручной установке выдает, что более новая версия пакета уже установлена, а WSUS все равно упорно хочет его ставить. Ничего пока сделать не могу.

     


    Тоже такая же проблема - упорно хочет ставить KB928416 и дает ошибки. на машинах уже стоит .NET 3.0 SP1.

    Что делать? Сносить руками .NET 3.0 SP1, ставить .NET 3.0, ставить языковой пакет, потом ставить .NET 3.0 SP1 ???

    Или просто отклонить KB928416, в надежде, что SP1 все в себя включает и WSUS просто не разобрался в версиях?


    15 января 2009 г. 7:19
  • Ответ был выше:

     

     Michael 1 написано:

    Нужно удалить  обновление Microsoft .NET Framework 3.0 Service Pack 1 (KB929300), потом установить Microsoft .NET Framework 3.0 версия 3.0.4506.30 из пакета Microsoft .NET Framework 3.0- x86 (KB928416), затем языковой пакет для ситем X86 (KB928416) 6,50 мб, а после этого опять установить обновление Microsoft .NET Framework 3.0 Service Pack 1 (KB929300)

    15 января 2009 г. 11:26
    Модератор
  • На отдельно стоящем компьютере я бы так и сделал, НО представляете какая это нагрузка на службу техподдержки 200 компов обработать таким способом?
    И зачем тогда мне WSUS?

    Поставлю вопрос так: нужно ли обновление KB 928416, при уже установленном .NET SP1 ?
    15 января 2009 г. 13:00
  • Это вопрос к вам: а вам нужно это обновление? :-) Изучите описание обновления и примите решение.

    16 января 2009 г. 9:58
    Модератор
  • Это обновление чувствительно к ситуации, когда .NET Framework 3.0 кем-то используется (не моя мысль, где-то прочитал).
    Получилось установить сразу после перезагрузки. В моём случае - через автоматическое обновление (не через сайт).
    • Предложено в качестве ответа holyglory 17 марта 2009 г. 14:03
    4 марта 2009 г. 22:41
  • Нужно удалить  обновление Microsoft .NET Framework 3.0 Service Pack 1 (KB929300), потом установить Microsoft .NET Framework 3.0 версия 3.0.4506.30 из пакета Microsoft .NET Framework 3.0- x86 (KB928416), затем языковой пакет для ситем X86 (KB928416) 6,50 мб, а после этого опять установить обновление Microsoft .NET Framework 3.0 Service Pack 1 (KB929300)

    Этот вариант не катит т.к. нужные файлы отсутствуют в установке и удалении программ.
    Больше ни у кого нету никаких идей?
    2 сентября 2009 г. 5:11
  • Может быть поможет это http://forum.oszone.net/post-927068-781.html.
    Мне помогло.

    5 сентября 2009 г. 2:46
  • Может быть поможет это http://forum.oszone.net/post-927068-781.html .
    Мне помогло.

    это просто тупо добавить в реестр? а если просто его забанить в всусе?
    8 октября 2009 г. 23:36
  •  

    Framework 3.0 не устанавливался на XP SP3

    http://blogs.technet.com/sus/archive/2008/09/16/net-framework-updates-not-being-offered-to-windows-xp-sp3-computers.aspx

    С версией от 23 сентября возникли проблемы, 2 октября появился новый релиз и проблема разрешена.

    то есть есть новый релиз обновления и нужно как то убить старый с сервера всуса и при синхронизации будет новый доступен для скачивания,так?
    8 октября 2009 г. 23:37
  •  

    Framework 3.0 не устанавливался на XP SP3

    http://blogs.technet.com/sus/archive/2008/09/16/net-framework-updates-not-being-offered-to-windows-xp-sp3-computers.aspx

    С версией от 23 сентября возникли проблемы, 2 октября появился новый релиз и проблема разрешена.

    то есть есть новый релиз обновления и нужно как то убить старый с сервера всуса и при синхронизации будет новый доступен для скачивания,так?


    Здравствуйте, Gloomy nort.

    У Вас такая же проблема? Просто, ей уже больше года, новые обновления, вроде, совместимы с xp sp3.
    9 октября 2009 г. 5:56