none
Found duplicate physical address RRS feed

  • Общие обсуждения

  • Есть кластер на HyperV из двух узлов (win2008r2)
    на каждом из узлов по две сетевые карты, которые объединены в team
    затем на этот team наверчены vlan, соответственно для каждого vlan имею сетевой интерфейс в системе.
    затем в hyperv, настраивая сети, создаю external и у меня еще появляются сетевые интерфейсы в системе для hyperv

    При проверке конфигурации кластреа говорят:
    Found duplicate physical address 00-1E-68-57-70-F3 on node node1.domain.local adapter HV_VLAN403 and node node1.domain.local adapter HV_VLAN6.
    Found duplicate physical address 00-1E-68-57-70-F3 on node node1.domain.local adapter HV_VLAN403 and node node1.domain.local adapter HV_VLAN3.
    Found duplicate physical address 00-1E-68-57-70-F3 on node node1.domain.local adapter HV_VLAN403 and node node1.domain.local adapter HV_VLAN1.
    Found duplicate physical address 00-1E-68-57-70-F3 on node node1 .domain.local adapter HV_VLAN6 and node node1.domain.local adapter HV_VLAN3.
    Found duplicate physical address 00-1E-68-57-70-F3 on node node1 .domain.local adapter HV_VLAN6 and node node1.domain.local adapter HV_VLAN1.
    Found duplicate physical address 00-1E-68-57-70-F3 on node node1.domain.local adapter HV_VLAN3 and node node1.domain.local adapter HV_VLAN1.

    И точно такая же беда на втором node, только mac другой.
    Как можно решить проблему? Почему возникает такая проблема?
    11 января 2010 г. 5:47

Все ответы

  • Насколько я знаю объединение сетевых интерфейсов не поддерживаемое решение.
    Посмотрите статью
    http://blogs.technet.com/vm/archive/2008/10/12/network-teaming-hyper-v.aspx
    11 января 2010 г. 6:22
  • Насколько я знаю объединение сетевых интерфейсов не поддерживаемое решение.
    Посмотрите статью
    http://blogs.technet.com/vm/archive/2008/10/12/network-teaming-hyper-v.aspx
    Хм, агрегировать интерфейсы мне удалось, как на стороне windows 2008 r2, так и на стороне коммутатора Cisco.
    Причем все работало до недавнего момента ("новый год").

    Ну давайте предположим что не работает из-за агрегации, смотрим:

    Имеем одну сетевую карту (у нее также 1 mac адрес), навинчиваем на нее виртуальные сети, вроде как ситуация такая же.
    Кто-нить может посмотреть у себя конфигурацию, на все vlan интерфейсах одинаковые mac адреса?
    11 января 2010 г. 6:35
  • Разные, проверено на виртуальном ISA. Попробуйте вручную указать маки на виртуальных сетях.
    11 января 2010 г. 6:42
    Модератор
  • Разные, проверено на виртуальном ISA. Попробуйте вручную указать маки на виртуальных сетях.
    У вирт. сетей один общий интерфейс, изменить мак можно только на нем :(

    Далее, в настройках сети в HyperV, где создаю external адаптеры есть Global network settings - MAC Address range, так прописан пул мак адресов, которые будут назначаться адаптерам.

    (На текущий момент, все вирт. интерфейсы имеют один mac адрес)

    Написано чтобы применить настройки, надо пересоздать адаптер.

    Ну я удалил и добавил заново один интрефейс.
    (Все вирт. интерфейсы имеют изменили адрес на новый, опять один у всех)
    Причем этот новый mac адрес не из пула, про который говорилось выше.

    Ну я удалил второй вирт.интерфейс и добавил заново.
    (mac адрес нигде не изменился)

    11 января 2010 г. 7:54
  • Может Teredo глючит у Вас?
    http://blogs.msdn.com/clustering/archive/2008/07/26/8773796.aspx
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    13 января 2010 г. 10:01
    Модератор
  • Может Teredo глючит у Вас?
    http://blogs.msdn.com/clustering/archive/2008/07/26/8773796.aspx
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    Отключил Teredo на обоих узлах, перегрузился, попробовал удалять виртуальные сети и создавать заново, не помогает - mac адрес все равно один у всех :(
    13 января 2010 г. 16:31
  • Вы отключали таким образом?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    14 января 2010 г. 10:18
    Модератор
  • Вы отключали таким образом?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    На одном узле отключил через netsh, на втором отключил через диспетчер задач.
    Потом ребут обоих узлов, результата нет.
    14 января 2010 г. 18:29
  • А способом, указанным в статье, пробовали?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    15 января 2010 г. 6:13
    Модератор
  • А способом, указанным в статье, пробовали?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    Сори, описа'лся, на втором узле отключил через диспетчер устройств (как описано в статье)
    16 января 2010 г. 8:27
  • А почему на обоих узлах не отключили через диспетчер устройств?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    18 января 2010 г. 10:50
    Модератор