none
После установки SP3 перестал работать поиск обновлений RRS feed

  • Вопрос

  • После замены винчестера, переустанавливаю с оригинального дистрибутива 2002 года Windows XP with SP2.

    Обновления ожидаемым образом не грузятся - поэтому, ставлю вручную новый агент (WindowsUpdateAgent30-x86.exe) - не самую последнюю версию, а последнюю из тех, что доступны standalone - после чего уже самостоятельно подгружается новейшая версия, и без проблем скачиваются и устанавливаются порядка 180 разных обновлений.

    Затем - ставится Srvice Pack 3, после чего - снова "обновляется" агент обновлений, и... перестаёт работать. То есть, запускается, даёт нажать кнопку, чтобы начать поиск новых придложений, показывает зелёный "бегунок", мол ищет - но бегунок бежит себе часами и сутками, однако списка доступных обновлений не даёт.

    Попытка снова установить WindowsUpdateAgent30-x86 результата не приносит.

    И так три раза с самого начала.

    Автоматический апдейт в ночи также не срабатывает.

    Помогите!

    23 сентября 2013 г. 12:39

Ответы

  • Диск, конечно, переформатировал.

    А совет по Вашей ссылке также оказался бесполезен (проверено на копии).

    Случилось чудо - неожиданно жевавшая сопли двое суток машина "развисла" и - в совершенно неурочное время - загрузила автоматически в фоновом режиме сотню обновлений, после чего агент обновлений заработал - и успешно позволил мне установить ещё три десятка бюллетеней.

    Теперь всё работает - и ничего не тормозит.

    К сожалению, среди автоматически загруженных обновлений был без спросу установленный восьмой эксплорер. Однако, я его снёс - и теперь всё как надо.

    Непонятно только, почему всё стало так сложно...




    • Изменено SVA1968 23 сентября 2013 г. 23:06
    • Помечено в качестве ответа Elina Lebedeva 24 сентября 2013 г. 11:48
    23 сентября 2013 г. 22:10

Все ответы

  • После переустановки Windows XP with SP2 сразу установите SP3, а затем (после перезагрузки) включите поиск и установку обновлений.
    23 сентября 2013 г. 13:57
    Модератор
  • Бесполезно :(

    Именно так я и поступил первый раз - с тем же результатом: установил XP, затем сразу SP3 - и - не смог после этого скачать вообще ни одного обновления...

    На второй раз, решил сначала установить систему - и сделать резервную копию, затем установить всё что возможно без сервиспака - и снова сделать резервную копию, затем установить сервиспак.

    На третий раз начал с первой резервной копии и установил до сервиспака не все обновления, а только важные (то есть без сервелада и прочих деликатесов), затем накатил сервиспак - и результат тот же.

    То есть, обновление перестаёт работать строго после сервиспака - на каком бы этапе он ни ставился.

    И ещё - снести сервиспак не удаётся: при попытке сноса установщик подвисает, даёт стапроцентную загрузку процессора, которая сохраняется и после убийства установщика, и даже после перезагрузки.

    Сервиспак ставил разными способами: и с диска, и онлайн.

    FixIt сначала требует установить .Net (что нетрудно и ручками) - а затем всё равно "не видит проблемы".


    • Изменено SVA1968 23 сентября 2013 г. 14:25
    23 сентября 2013 г. 14:19
  • Вы этот FixIt запускали ?

    http://support.microsoft.com/kb/971058

    Вручную установите последнее обновление часовых поясов для Windows XP:

    http://support.microsoft.com/kb/2779562

    Проверьте, что дата, время и часовой пояс на вашем компьютере установлены правильные. Установите Internet Explorer 8 и затем (после перезагрузки) снова попробуйте загрузить обновления с Windows Update.


    23 сентября 2013 г. 15:02
    Модератор
  • Этот FixIt.

    Часовой пояс правильный, установка рекомендованного апдейта не помогла.

    Что я успел за это время: скачал с технета дистрибутив ХР с интегрированным третьим сервиспаком, переустановился с нуля - результат тот же самый: сначала вообще не запускается агент обновлений, после ручной установки агента - запускается, "самообновляется" и... уходит в бесконечный поиск.

    Вариант с установкой Internet Explorer 8 крайне неудобен - потому что на этой машине мне позарез нужен Internet Explorer 6...

    Я бы вообще предпочёл Windows 2000, но она вообще не ставится.


    • Изменено SVA1968 23 сентября 2013 г. 15:37
    23 сентября 2013 г. 15:36
  • Выложите где-нибудь ваш файл C:\Windows\WindowsUpdate.log а здесь разместите ссылку. 

    23 сентября 2013 г. 15:45
    Модератор
  • Ссылка: http://webfile.ru/6684382

    Да, и восьмой эксплорер - не помог.

    Спасибо за возню с чайником :)

    Апдейт: попробовал 64-битную версию - эффект тот же, но после установки ВТОРОГО сервиспака (то есть последнего по счёту).

    Чудеса, да и только. Похоже, Микрософт решил исподтишка добить ХР досрочно.

    • Изменено SVA1968 23 сентября 2013 г. 18:49
    23 сентября 2013 г. 16:48
  • А почему не установить XP уже с SP3?
    23 сентября 2013 г. 19:42
  • Когда вы переустанавливаете операционную систему, вы форматируете загрузочный раздел (диск C:)? Если нет, то посмотрите рекомендацию статьи

    http://support.microsoft.com/kb/958040/en-us


    23 сентября 2013 г. 20:59
    Модератор
  • Дык пробовал - писал же выше...
    23 сентября 2013 г. 22:05
  • Диск, конечно, переформатировал.

    А совет по Вашей ссылке также оказался бесполезен (проверено на копии).

    Случилось чудо - неожиданно жевавшая сопли двое суток машина "развисла" и - в совершенно неурочное время - загрузила автоматически в фоновом режиме сотню обновлений, после чего агент обновлений заработал - и успешно позволил мне установить ещё три десятка бюллетеней.

    Теперь всё работает - и ничего не тормозит.

    К сожалению, среди автоматически загруженных обновлений был без спросу установленный восьмой эксплорер. Однако, я его снёс - и теперь всё как надо.

    Непонятно только, почему всё стало так сложно...




    • Изменено SVA1968 23 сентября 2013 г. 23:06
    • Помечено в качестве ответа Elina Lebedeva 24 сентября 2013 г. 11:48
    23 сентября 2013 г. 22:10