none
Перенос формул из книги в книгу без ссылок RRS feed

  • Вопрос

  • Имеется условный файл Книга1.xls и Лист1 в нём.

    1 3
    2 4
    3 5
    =СУММ(A1:A3)  
    =СУММ(B1:B3)

    Т.е. два столбика и сумма по ним. Имеется Лист2 где берутся данные суммированных столбцов из лист1 и суммируются

    =Лист1!A4 
     =Лист1!B4
    =A1+B1

    Имеется файл Лист3.xls где имеется таблица аналогичная Книга1 из Лист1, но Лист2 пустой.

    При попытке копировать в него данные из Книга1 Лист2 происходит не только копирование формул, но и копирование ссылки на Книга1.

    =[Книга1.xlsx]Лист1!A4  =[Книга1.xlsx]Лист2!$B$1

    =[Книга1.xlsx]Лист2!$B$2+[Книга1.xlsx]Лист2!$B$2

    Можно ли скопировать из книги в книгу только формулы без ссылок?

    Единственный вариант вижу в том, что б скопировать, затем убрать исходный файл, вручную изменить файл подставив самого себя. Или какой-то макрос писать.

    Образовалось несколько десятков Таблиц и несколькими десятками листов. Необходимо ко всем добавить ещё один лист с доп. расчётами из этих листов. Образовалась проблема упрощённо описанная выше.

    Ссылку на файлы прилагаю.

    https://cloud.mail.ru/public/5JUf/3N8gqVhFJ

    13 ноября 2019 г. 13:01

Все ответы

  • Как вариант, можно используя инструмент Найти и заменить преобразовать нужные формулы в текст (например, добавить апостроф ' до знака =), скопировать и вставить в другую книгу, и затем так же при помощи Найти и заменить преобразовать текст в формулы.
    30 ноября 2019 г. 6:01