none
Compliance settings не отрабатываются задания RRS feed

  • Вопрос

  • Проблема в следующем. Создаю любой Configuration Baseline c Configuration Item, деплою его на 800 машин. 300 машин присылают результаты (совместимо не совместимо), а 500 остаются в статусе Unknown. Причем если запустить другой Baseline, все те же машины отработают, и те же не отработают. Все машины в одном домене, в одной подсети, с одной и той же ОС. Переустановка клиента SCCM проблемы не решает. Опытным путем пришел к выводу, что проблема видимо не с выполнением задания, а с отправкой результата. Во всех логах связанных с Compliance ошибок нет и они не отличаются от машин на которых все отрабатывается. Ошибки нашел в StateMessage.log:

    State message with TopicType 401 and TopicId ScopeId_BCA132DE-6D9E-4F52-9715-BF2BAE3C4D6F/Baseline_c86e7820-9284-4587-a9c6-bc249a7faa18/1 has been updated StateMessage 15.03.2017 11:56:48 4824 (0x12D8)
    State message with TopicType 401 and TopicId ScopeId_BCA132DE-6D9E-4F52-9715-BF2BAE3C4D6F/OperatingSystem_965d51dd-0f95-44d7-ae1a-0bb194d3d207/1 has been updated StateMessage 15.03.2017 11:56:48 4824 (0x12D8)
    State message(State ID : 2) with TopicType 302 and TopicId {195EFBF8-3622-4383-AC8E-B5D86E775832} has been recorded for SYSTEM StateMessage 15.03.2017 11:56:48 4824 (0x12D8)
    State message with TopicType 401 and TopicId ScopeId_BCA132DE-6D9E-4F52-9715-BF2BAE3C4D6F/Baseline_9f3e84f4-043f-4431-89a6-65765af8dd2d/1 has been updated StateMessage 15.03.2017 11:58:22 5100 (0x13EC)
    State message with TopicType 401 and TopicId ScopeId_BCA132DE-6D9E-4F52-9715-BF2BAE3C4D6F/OperatingSystem_289b5e07-af04-4b4a-a20c-4e15c03e55f3/2 has been updated StateMessage 15.03.2017 11:58:22 5100 (0x13EC)
    State message(State ID : 2) with TopicType 302 and TopicId {2D10ACCB-7F4D-4871-9CA2-1578B479947B} has been recorded for SYSTEM StateMessage 15.03.2017 11:58:22 1596 (0x063C)
    Error while opening state file. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    Loading the client state failed. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    CStateMsgManager::SetLastSerialNumberInClientState: Failed to load ClientState StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    CStateMsgManager::GetNextSerialNumber - Failed to set the last serial number in ClientState. Error 0x80070057 StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    Error while opening state file. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    Loading the client state failed. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    CStateMsgManager::SetLastSerialNumberInClientState: Failed to load ClientState StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    CStateMsgManager::GetNextSerialNumber - Failed to set the last serial number in ClientState. Error 0x80070057 StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    Error while opening state file. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    Loading the client state failed. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    CStateMsgManager::SetLastSerialNumberInClientState: Failed to load ClientState StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    CStateMsgManager::GetNextSerialNumber - Failed to set the last serial number in ClientState. Error 0x80070057 StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    Error while opening state file. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    Loading the client state failed. StateMessage 15.03.2017 11:58:29 5100 (0x13EC)
    CStateMsgManager::SetLastSerialNumberInClientState: Failed to load ClientState StateMessage 15.03.2017 11:58:29 5100 (0x13EC)

    WMI root\ccm\statemsg\ccm_StateMsg_SerialNum показывает "0"

    все StateMsg в WMI root\ccm\statemsg\ccm_StateMsg со статусом MessageSent = False

    Есть предположения?




    15 марта 2017 г. 9:36

Ответы

  • Отвечаю сам на свой вопрос. Проблема оказалось в установленной на компьютерах программе в CryptoPro версии 3.6 R3. Как удалось выяснить, этой проблемой страдают все версии 3.6 до R4. Обновление до R4 решило проблему.
    28 марта 2017 г. 6:41