none
Переадресация RRS feed

  • Вопрос

  • В сети есть сайт вида https://elma.mysyte.net, нужно на iis настроить. чтобы все запросы перенаправлялись на другой сайт https://elma.mysite.ru, оба сайта находятся в локальной сети.

    Как настроить это в IIS 10 ?

    17 января 2019 г. 7:26

Ответы

  • Вот рабочий вариант конфига

    <rule name="Route the requests for API" stopProcessing="true"> <match url=".*" /> <conditions> <add input="{CACHE_URL}" pattern="^(https?)://" /> <add input="{HTTP_HOST}" pattern="YOur old server Address" </conditions> //or use redrect <action type="Rewrite" url="{C:1}://Newserveraddress/application/{R:0}" /> <serverVariables> <set name="HTTP_ACCEPT_ENCODING" value="" /> </serverVariables> </rule>


    только у меня строка {C:1}://Newserveraddress/application/{R:0}"выглядит так

    "https://://Newserveraddress/"

    Найдено здесь

    https://forums.iis.net/post/2070585.aspx

    • Помечено в качестве ответа AlexeyIschenko 24 января 2019 г. 2:48
    24 января 2019 г. 2:48

Все ответы

  • В помощь:

    https://support.microsoft.com/en-za/help/324000/how-to-redirect-urls-to-different-web-sites

    https://docs.microsoft.com/en-us/iis/extensions/configuring-application-request-routing-arr/creating-a-forward-proxy-using-application-request-routing

    17 января 2019 г. 7:38
  • В помощь:

    https://support.microsoft.com/en-za/help/324000/how-to-redirect-urls-to-different-web-sites

    https://docs.microsoft.com/en-us/iis/extensions/configuring-application-request-routing-arr/creating-a-forward-proxy-using-application-request-routing

    Но я не вижу там перенаправления с одного https на другой https, я пытаюсь изменить в web.config но не получается, если набираем http то все нормально. запрос уходит на https, но если я сразу набираю адрес с https, ничего не происходит.

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <security>
                <requestFiltering>
                    <requestLimits maxQueryString="2000000" />
                </requestFiltering>
            </security>
            <rewrite>
                <rewriteMaps>
                    <rewriteMap name="ELMA" />
                </rewriteMaps>
            </rewrite>
            <httpRedirect enabled="true" destination="https://elma-test.contoso.com/" />
        <rewrite>
      <rules>
        <rule name="Rewrite to https://elma-k-01n.contoso.com" enabled="true" stopProcessing="true">
          <match url="(.*)" />
          <conditions logicalGrouping="MatchAll">
                            <add input="{HTTP_HOST}" pattern="^10\.52\.5\.55$" />
                            <add input="{HTTPS}" pattern="^ON$" />
          </conditions>
          <action type="Redirect" url="https://elma-test.contoso.com/{R:0}" />
         </rule>
      </rules>
    </rewrite>
        </system.webServer>
    </configuration>

    21 января 2019 г. 4:48
  • Вот рабочий вариант конфига

    <rule name="Route the requests for API" stopProcessing="true"> <match url=".*" /> <conditions> <add input="{CACHE_URL}" pattern="^(https?)://" /> <add input="{HTTP_HOST}" pattern="YOur old server Address" </conditions> //or use redrect <action type="Rewrite" url="{C:1}://Newserveraddress/application/{R:0}" /> <serverVariables> <set name="HTTP_ACCEPT_ENCODING" value="" /> </serverVariables> </rule>


    только у меня строка {C:1}://Newserveraddress/application/{R:0}"выглядит так

    "https://://Newserveraddress/"

    Найдено здесь

    https://forums.iis.net/post/2070585.aspx

    • Помечено в качестве ответа AlexeyIschenko 24 января 2019 г. 2:48
    24 января 2019 г. 2:48