none
Проблема при создании веб-приложения в SharePoint 2010 RRS feed

  • Вопрос

  • Windows Server 2008 R2, SharePoint 2010, SQL 2008 R2.

     

    Ранее (месяца 2-а назад) было создано основное веб-приложение (естествненно на нем создано семейство сайтов) для организации электронного документооборота, а также веб-приложение для личных сайтов.

    Сейчас возникла потребность в создании дополнительных отдельных веб-приложений. При создании - никаких ошибок не вылазит. В iis создаются пул и сайт, в sql создается БД, при создании семества сайтов на основе шаблона sharepoint никаких ошибок нет - т.е. вроде как все гуд.

    Но при открытии в браузере IE8 сообщает:

    "Internet Explorer не может отобразить эту веб-страницу."

    причем ошибку никакую не пишет, сообщение выдается моментально.

    Предположил что проблема в проверке замыкания на себя на сервере. Отключил ее. (http://support.microsoft.com/kb/896861 первый способ)

    Не помогло.

    Причем ранее созданные веб-приложения грузятся в браузере.

    В логах SharePoint2010 ошибок нет.

     

    Может кто сталкивался? или хотябы кто-нить подскажет куда смотреть, что проверять?

    16 августа 2011 г. 12:29

Ответы

  • Спасибо за содействие,

    проблему решил, имя приложения и адрес url отличались от имени сервака, и порт был не 80. Мне подсказали, что в таком случае надо, еще помимо устранения замыкания на себя сервака, перенаправление делать в IISе. Пересоздал приложение с именем и адресом совпадающим с именем сервака - порт взял не 80 - и все заработало.

    • Помечено в качестве ответа Denis KichinEditor 19 августа 2011 г. 8:19
    18 августа 2011 г. 12:29

Все ответы

  • А в логах шарепоинта вообще отображаются запросы к новым сайтам? Может до самого шарепоинта запрос и не доходит (проблема в DNS)?

     

    Дополнительно надо проверить логи IIS, возможно они что-нибудь покажут.

    16 августа 2011 г. 14:43
  • надо глядеть в конфигурацию веб приложения: хост, порт.

    И чтобы этот хост нормально разрешался на клиентской машине.

    17 августа 2011 г. 4:48
  • Спасибо за содействие,

    проблему решил, имя приложения и адрес url отличались от имени сервака, и порт был не 80. Мне подсказали, что в таком случае надо, еще помимо устранения замыкания на себя сервака, перенаправление делать в IISе. Пересоздал приложение с именем и адресом совпадающим с именем сервака - порт взял не 80 - и все заработало.

    • Помечено в качестве ответа Denis KichinEditor 19 августа 2011 г. 8:19
    18 августа 2011 г. 12:29
  • Спасибо за содействие,

    проблему решил, имя приложения и адрес url отличались от имени сервака, и порт был не 80. Мне подсказали, что в таком случае надо, еще помимо устранения замыкания на себя сервака, перенаправление делать в IISе. Пересоздал приложение с именем и адресом совпадающим с именем сервака - порт взял не 80 - и все заработало.


    Чтобы не было подобный проблем, возьмите за правило создавать веб-приложения только с именем сервера (на других портах), а потом через Alternate Access Mapping и DNS делайте "красивые имена"
    MCTS, MCITP:EPM (2007)
    19 августа 2011 г. 8:20
    Отвечающий