none
Linux Integration Services 3.5 и Ubuntu 13.10 RRS feed

  • Вопрос

  • Добрый день,

    Необходимо ли обновление компонентов LIS до версии 3.5. в Ubuntu Server 13.10? Несмотря на заявленное в анонсе, наличие последней версии интеграционных сервисов в ядре, в системе по умолчанию стоят модули версии 3.1. В связи с этим, в логах VMMS Worker, периодически мелкают сообщения с ошибкой, указывающие на устаревшую версию LIS. Это критично в данном случае? Если обновление таки требуется, то интересно было бы узнать как его осуществить - в iso образе LIS 3.5 содержатся только .rpm пакеты.

    Заранее спасибо.

    17 марта 2014 г. 15:21

Ответы

  • 13.10 описан в оф.статье technet :

    http://technet.microsoft.com/en-US/library/dn531029.aspx

    Про LIS 3.5 всё описано в прилагаемом PDF Linux Integration Services v35.pdf

    For certain older Linux distributions, Microsoft provides an ISO file containing installable LIS 
    drivers for Linux virtual machines. For newer Linux distributions, LIS is built into the Linux 
    operating system, and no separate download or installation is required

    This version of LIS supports the following guest operating systems: 

    •   Red Hat Enterprise Linux (RHEL) 5.5-5.8, 6.0-6.3 x86 and x64 
        CentOS 5.5-5.8, 6.0-6.3 x86 and x64


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com


    17 марта 2014 г. 19:51
  • На данный момент какие-либо проблемы есть в эксплуатации? Если ссылки смотрели, то всё поддерживается Вашей версией Ubuntu с некоторыми "заметками" + в Апреле 2014 выйдет новая версия Ubuntu (https://wiki.ubuntu.com/TrustyTahr/ReleaseSchedule). Я отталкиваюсь от официальных данных. LIS 3.5 нужно ставить только на те ОС, к-ые указаны выше. В новых релизах ubuntu и т.д. они встроены и не не нуждаются в обновлении.


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    18 марта 2014 г. 6:06

Все ответы

  • 13.10 описан в оф.статье technet :

    http://technet.microsoft.com/en-US/library/dn531029.aspx

    Про LIS 3.5 всё описано в прилагаемом PDF Linux Integration Services v35.pdf

    For certain older Linux distributions, Microsoft provides an ISO file containing installable LIS 
    drivers for Linux virtual machines. For newer Linux distributions, LIS is built into the Linux 
    operating system, and no separate download or installation is required

    This version of LIS supports the following guest operating systems: 

    •   Red Hat Enterprise Linux (RHEL) 5.5-5.8, 6.0-6.3 x86 and x64 
        CentOS 5.5-5.8, 6.0-6.3 x86 and x64


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com


    17 марта 2014 г. 19:51
  • Тогда почему в 13.10 вывод modinfo по модулям LIS имеет следующий вид (версия 3.1. а не 3.5 :

    find /lib/modules/3.11.0-12-generic/kernel/ -name "hv_*" | xargs modinfo

    filename:       /lib/modules/3.11.0-12-generic/kernel/drivers/scsi/hv_storvsc.ko
    description:    Microsoft Hyper-V virtual storage driver
    version:        3.1
    license:        GPL
    srcversion:     777D11200E6336EAD9D5F39
    alias:          vmbus:4acc9b2f6900f34ab76b6fd0be528cda
    alias:          vmbus:32264132cb86a2449b5c50d1417354f5
    alias:          vmbus:d96361baa104294db60572e2ffb1dc7f
    depends:        hv_vmbus
    intree:         Y
    vermagic:       3.11.0-12-generic SMP mod_unload modversions
    parm:           storvsc_ringbuffer_size:Ring buffer size (bytes) (int)
    filename:       /lib/modules/3.11.0-12-generic/kernel/drivers/net/hyperv/hv_netvsc.ko
    description:    Microsoft Hyper-V network driver
    version:        3.1
    license:        GPL
    srcversion:     CC3DD43471B69246E040BF4
    alias:          vmbus:635161f83edfc546913ff2d2f965ed0e
    depends:        hv_vmbus
    intree:         Y
    vermagic:       3.11.0-12-generic SMP mod_unload modversions
    parm:           ring_size:Ring buffer size (# of pages) (int)
    filename:       /lib/modules/3.11.0-12-generic/kernel/drivers/hv/hv_utils.ko
    license:        GPL
    version:        3.1
    description:    Hyper-V Utilities
    srcversion:     CF5D65028975B1FEC0171E6
    alias:          vmbus:292efa3523ea364296ae3a6ebacba440
    alias:          vmbus:e7f4a0a9455a964db8278a841e8c03e6
    alias:          vmbus:394f16571591784eab55382f3bd5422d
    alias:          vmbus:30e62795aed07b49adcee80ab0175caf
    alias:          vmbus:31600b0e13523449818b38d90ced39db
    depends:        hv_vmbus
    intree:         Y
    vermagic:       3.11.0-12-generic SMP mod_unload modversions
    filename:       /lib/modules/3.11.0-12-generic/kernel/drivers/hv/hv_vmbus.ko
    version:        3.1
    license:        GPL
    srcversion:     2B4F042DBBF6DCA143DEE4A
    alias:          acpi*:VMBus:*
    alias:          acpi*:VMBUS:*
    depends:
    intree:         Y
    vermagic:       3.11.0-12-generic SMP mod_unload modversions
    filename:       /lib/modules/3.11.0-12-generic/kernel/drivers/hv/hv_balloon.ko
    license:        GPL
    version:        3.1
    description:    Hyper-V Balloon
    srcversion:     D368DFE57545C154EC84E6C
    alias:          vmbus:dc7450528589e2468057a307dc18a502
    depends:        hv_vmbus
    intree:         Y
    vermagic:       3.11.0-12-generic SMP mod_unload modversions
    parm:           hot_add:If set attempt memory hot_add (bool)
    parm:           pressure_report_delay:Delay in secs in reporting pressure (uint)
    


    • Изменено Powerthrash 17 марта 2014 г. 20:21
    17 марта 2014 г. 20:14
  • Доп.информация:

    uname -r 3.11.0-12-generic

    arch x86_64

    lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 13.10
    Release:        13.10


    • Изменено Powerthrash 17 марта 2014 г. 22:54
    17 марта 2014 г. 20:24
  • На данный момент какие-либо проблемы есть в эксплуатации? Если ссылки смотрели, то всё поддерживается Вашей версией Ubuntu с некоторыми "заметками" + в Апреле 2014 выйдет новая версия Ubuntu (https://wiki.ubuntu.com/TrustyTahr/ReleaseSchedule). Я отталкиваюсь от официальных данных. LIS 3.5 нужно ставить только на те ОС, к-ые указаны выше. В новых релизах ubuntu и т.д. они встроены и не не нуждаются в обновлении.


    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    18 марта 2014 г. 6:06
  • Powerthrash, как успехи? есть ещё вопросы?

    Roman Levchenko, MCITP, MCTS http://www.rlevchenko.com

    19 марта 2014 г. 5:22
  • Сейчас тестирую ВМ... Если не смотреть на сообщения в логах, то вроде все нормально работает.
    19 марта 2014 г. 20:24