none
Проблема с доступом по FTP через TMG RRS feed

  • Вопрос

  • Добрый день.

    Возникает проблема при доступе к фтп серверам через тмг. Клиент настроен как веб-прокси, создано правило: разрешать, внутренняя сеть -> набор доменных имен, протоколы: http, https, ftp,  ftp через http, Все пользователи. При попытке доступа появляются ошибки типа (yyy.yyy.yyy.yyy - ip тмг):

    Forefront TMG: расширенное сообщение об ошибке :
    200 TYPE is now ASCII
    500 I won't open a connection to yyy.yyy.yyy.yyy (only to xxx.xxx.xxx.xxx)


    Forefront TMG: расширенное сообщение об ошибке :
    200 Type set to A.
    500 Illegal address rejected.

    при этом в логах тмг пишет следующее:

    Разрешенное соединение xxxxxxxxxxxxx 25.01.2011 17:26:18
    Тип журнала: Веб-прокси (прямой)
    Состояние: 200 ОК.
    Правило: Все пользователи (как прокси)
    Источник: Внутренняя (xxx.xxx.xxx.xxx:17012)
    Назначение: Внешняя (xxxxxxxxxxxxxxxxxxxxxxxx xxx.xxx.xxx.xxx:21)
    Запрос: GET ftp://xxx.xxx.xxx.xxx/
    Информация фильтра: Req ID: 0b9cb394; Compression: client=No, server=No, compress rate=0% decompress rate=0%
    Протокол: FTP чере
    Пользователь: anonymous
     Дополнительные сведения
    Агент клиента: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E; InfoPath.2)
    Источник объекта: Интернет (Объект получен из Интернета, а его копия размещена в кэше.)
    Данные кэша: 0x5 (Запрос не должен обслуживаться из кэша. Запрос содержит один из следующих заголовков: CACHE-CONTROL:NO-CACHE или PRAGMA:NO-CACHE.)
    Время обработки: 578 MIME-тип:  

    В чем проблема? Вообще помогите разобраться когда нужно использовать протокол  ftp, а когда ftp через http???

    25 января 2011 г. 11:46

Ответы

  • дело в том, что если добавить в исключения, то IE полезет прямым доступом к ftp (т.е. через шлюз). А в данном случае шлюз - не ТМГ.

    В общем удалось решить проблему: ТМГ коннектился в активном режиме к фтп, хотя здесь: http://support.microsoft.com/kb/300641/en-us/ написано: "For TMG 2010, the default FTP is already passive. To enable active, you must select an option on the GUI". В свойствах ФТП фильтра активный режим отключен.... ТАк и не понял в чем проблема, но пришлось лезть в реест и добавлять параметр NonPassiveFTPTransfer=0 и это помогло!

    • Помечено в качестве ответа _ivan_ 31 января 2011 г. 2:50
    26 января 2011 г. 9:22

Все ответы

  • Если клиент WebProxy, то между ним и службой web-proxy задействуется т.н. "FTP over HTTP", т.е. между proxy-сервером (в Вашем случае - это TMG) протокол FTP "обертывается" в HTTP, а далее proxy устанавливает соединение с сервером FTP с помощью "нативного" протокола FTP. Этот механизм имеет некоторые ограничения: не поддерживается передача данных на сервер FTP ("upload") и режим работы (active/passive) может быть задан лишь на уровне службы web-proxy сервера ISA.

    Я Вам рекомендую доступаться до FTP-серверов минуя службу прокси, и лучше, чтобы на клиенте был клиент TMG, а на сервере TMG был задействован фильтр протокола FTP.

    25 января 2011 г. 20:16
    Отвечающий
  • вбей в свойствах обозревателя, в подключениях есть рамка исключения, вбей ip адрес ftp сервера к которому хочешь подрубиться. Отпишись заработало или нет.
    26 января 2011 г. 8:59
  • дело в том, что если добавить в исключения, то IE полезет прямым доступом к ftp (т.е. через шлюз). А в данном случае шлюз - не ТМГ.

    В общем удалось решить проблему: ТМГ коннектился в активном режиме к фтп, хотя здесь: http://support.microsoft.com/kb/300641/en-us/ написано: "For TMG 2010, the default FTP is already passive. To enable active, you must select an option on the GUI". В свойствах ФТП фильтра активный режим отключен.... ТАк и не понял в чем проблема, но пришлось лезть в реест и добавлять параметр NonPassiveFTPTransfer=0 и это помогло!

    • Помечено в качестве ответа _ivan_ 31 января 2011 г. 2:50
    26 января 2011 г. 9:22
  • дело в том, что если добавить в исключения, то IE полезет прямым доступом к ftp (т.е. через шлюз). А в данном случае шлюз - не ТМГ.

    В общем удалось решить проблему: ТМГ коннектился в активном режиме к фтп, хотя здесь: http://support.microsoft.com/kb/300641/en-us/ написано: "For TMG 2010, the default FTP is already passive. To enable active, you must select an option on the GUI". В свойствах ФТП фильтра активный режим отключен.... ТАк и не понял в чем проблема, но пришлось лезть в реест и добавлять параметр NonPassiveFTPTransfer=0 и это помогло!

    Проблема с фтп, в браузере пишет:

    Forefront TMG: расширенное сообщение об ошибке : 
    200 Switching to ASCII mode.
    200 PORT command successful. Consider using PASV.
    425 Failed to establish connection.

    Спасибо за пост. Сначала этот KB не воспринял, так как было написано, что в TMG2010 уже и так пассивный режим. Ключ выставил в =0 и проблема решилась.

    28 марта 2016 г. 6:44