none
Не работает eToken - RemoteApp - RD Gateway RRS feed

  • Вопрос

  • Мы располагаем электронными ключами eToken PRO Java 72K, и  до сих пор пребываем в убеждении, что их можно использовать для авторизации удалённых пользователей на сервере RDS (RemoutApp).

    Интересует связка правильных настроек : TMG-> RD Gateway-> NPS(Radius) -> RemoutApp(и IIS если это важно).

    Выпущен сертификат пользователя, записан на eToken, туда же записаны корневой сертификат и сертификат выпущенный для фермы RD. С помощью ключа, внутри сети можно авторизоваться на рабочей станции, также авторизация проходит с ключом через RemoutApp, но при включенной галке обхода RD Gateway (в настройках RemoutApp). Если её выключить - не работает.

    Если подключаться снаружи (через TMG) авторизация не работает при любых вариантах настроек (

    Без использования eToken RemoutApp работает как снаружи так и внутри.

    Спасибо.


    • Изменено serj001 22 марта 2013 г. 12:20
    22 марта 2013 г. 12:13

Ответы

  • На стороне клиента:

    1) с использованием mstsc
    авторизация работает если на клиенте установен крыжик - не использовать сервер шлюза (RDG)

    Если крыжик обхода снять - ошибки:

    - не удаётся установить соединение за отведённый период времени ...

    - не удаётся подключиться к удал. комп., т.к. на нём произошла ошибка.

    С такой настройкой подключение должно быть.

    25 марта 2013 г. 16:17
    Отвечающий
  • Посмотрите эту статью, в таблице есть необходимые комбинации.

    • Помечено в качестве ответа serj001 27 марта 2013 г. 5:16
    26 марта 2013 г. 18:50
    Отвечающий
  • В общем вопрос решился довольно просто. я не правильно указывал имена серверов в параметрах "Подключения к удалённому рабочему столу".  на закладках Общие - Компьютер и Дополнительно - Параметры - Имя сервера. Всё работает с любыми методами входа.

    • Помечено в качестве ответа serj001 31 марта 2013 г. 14:27
    31 марта 2013 г. 14:27

Все ответы

  • На сервере RDS драйверы eToken установлены?

    22 марта 2013 г. 12:44
    Отвечающий
  • На сервере RDS драйверы eToken установлены?

    Да, конечно установлены. некто даже посоветовал установить их на TMG, но мне кажется это уже лишнее.
    Излагаю подробно:
    eToken внутри сети работает!
    На стороне сервера:
    1. Настройка политики авторизации на RDG

    RD Gateway Manager -> Policies -> Connection Autorization-> "RD_CAP_Tocken" Properties-> метод авторизации -> Smart cart

    2. Настройка режима работы RemoteApp с RDG

    RemoteAPP Manager -> RemoteApp Deployment Settings -> Использовать RDG с Logon metod - Smart cart

    На стороне клиента:

    1) с использованием mstsc
    авторизация работает если на клиенте установен крыжик - не использовать сервер шлюза (RDG)

    Если крыжик обхода снять - ошибки:

    - не удаётся установить соединение за отведённый период времени ...

    - не удаётся подключиться к удал. комп., т.к. на нём произошла ошибка.

    2) с использованием RemoutApp

    появляется окошко "Безопасность Windows" с запросом пин кода eTocken.
    после ввода, таже история, если установлен крыжик обхода (в RemoteApp Deployment Settings) - работает, не установлен- не работает

    Вот собственно и всё. а Ведь получается, что с "наружи" клиенты идут через TMG именно на RDG.
    Разумеется во всей этой цепочке есть ещё и RADIUS, через который авторизуются пользователи на
    RDG.
    Но там никакие настройки не изменял. (Хотя и безрезультатно экспериментировал).

    Коллеги, если есть у кого опыт в этой штуке, подскажите. Во всех приведённых (и найденных мной) ссылках или нет конкретики по моей проблеме или обсуждение брошено на самом интересном месте))).

    P.S. )) а ещё, как здесь скриншёты размещать, кто должен проверить учётку?

    25 марта 2013 г. 6:48
  • На стороне клиента:

    1) с использованием mstsc
    авторизация работает если на клиенте установен крыжик - не использовать сервер шлюза (RDG)

    Если крыжик обхода снять - ошибки:

    - не удаётся установить соединение за отведённый период времени ...

    - не удаётся подключиться к удал. комп., т.к. на нём произошла ошибка.

    С такой настройкой подключение должно быть.

    25 марта 2013 г. 16:17
    Отвечающий
  • Спасибо, только всё равно не работает (((
    Я полагаю так, что если снять галку ByPass RDG ..., то мы подключаемся к RDS именно через RDG, так? Так же как если б устанавливалось соединение инициализированное снаружи (из-за TMG). т.е., думаю я, добившись подключения внутри сети я удостоверюсь что авторизация через eToken - работает (и TMG никак не влияет, а то не ясно где проблема вообще).

    Так вот, если на кртинке снять галку ByPass RDG ..., явно указать Logon metod - SmartCart, оставить галку Use my RDG ... - не работает!

    26 марта 2013 г. 10:01
  • >Я полагаю так, что если снять галку ByPass RDG ..., то мы подключаемся к RDS именно через RDG, так?

    Да.

    Думаю следует проверить способы авторизации: пользователь -> NPS -> RDG


    26 марта 2013 г. 10:37
    Отвечающий
  • Отлично!

    в RD Gateway Manager в политиках авторизации я создал новую, назначил группу юзеров, оставил только галку Smart Cart. Здесь собственно всё. Есть ещё оснастка NPS (Radius), где собстенно и находится эта политика, но видимо нужно точно знать правильную комбинацию настоек (чтение интернетов и логика не помогли).

    Коллеги, помогите правильно настроить RADIUS!

    26 марта 2013 г. 12:55
  • Посмотрите эту статью, в таблице есть необходимые комбинации.

    • Помечено в качестве ответа serj001 27 марта 2013 г. 5:16
    26 марта 2013 г. 18:50
    Отвечающий
  • Спасибо за статью, осмыслю содержимое, отпишусь.

    27 марта 2013 г. 5:17
  • В общем вопрос решился довольно просто. я не правильно указывал имена серверов в параметрах "Подключения к удалённому рабочему столу".  на закладках Общие - Компьютер и Дополнительно - Параметры - Имя сервера. Всё работает с любыми методами входа.

    • Помечено в качестве ответа serj001 31 марта 2013 г. 14:27
    31 марта 2013 г. 14:27