none
Проблема при установке SP1 на Exchange 2010 RRS feed

  • Вопрос

  • Добрый день!

    Пытаюсь установить SP1 на Exchange 2010 на этапе подготовки файлов ошибка:

    Подготовка файлов

    Ошибка:

    При выполнении "$error.Clear(); 

              & $RoleBinPath\ServiceControl.ps1 EnableServices Critical

            " произошла следующая ошибка: "Ошибка при проверке AuthorizationManager.".

     

    Ошибка при проверке AuthorizationManager.

    Щелкните здесь для справки... http://technet.microsoft.com/ru-RU/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp

     

    Как исправить?

     

    30 августа 2010 г. 6:05

Ответы

  • Наконец-то я нашел решение с политикой выполнения.

    После переноса сервера в контейнер с неопределенной политикой выполнения скриптов, на данном компьютере продолжают действовать последние политики. 

    В результате получаем проблемы с установкой сервиспаков на Exch 2010. 

    На Exch 2013 первый сервиспак вообще не проходит проверку, пока machinepolicy и userpolicy имеют какое-либо значение. 

    Проблему решил только очисткой ключей реестра:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\PowerShell\ExecutionPolicy и 

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\PowerShell\ExecutionPolicy

    После этого выполняем Set-ExecutionPolicy Unrestricted

    и если Get-executionPolicy -list дает список:


                                                         Scope                                             ExecutionPolicy
                                                         -----                                             ---------------
                                                 MachinePolicy                                                   Undefined
                                                    UserPolicy                                                   Undefined
                                                       Process                                                   Undefined
                                                   CurrentUser                                                   Undefined
                                                  LocalMachine                                                Unrestricted

    Начинаем установку обновления.


    3 марта 2014 г. 5:15

Все ответы

  • Посмотри те вот это:
    http://www.spad.co.uk/blog/?p=385

    Проблема возникает в случае запуска установки без предварительной установки политики PS в unrestricted.
    PS: Get-ExecutionPolicy


    Regards, Dmitriy Ilyin
    30 августа 2010 г. 8:47
  • Установлена в Unrestricted через GPO.
    30 августа 2010 г. 8:54
  • поробуйте шаги описанные в статье по ссылке выше... а там видно будет.


    Regards, Dmitriy Ilyin
    30 августа 2010 г. 8:56
  • recoverserver удалось только сегодня успешно завершить после первой попытки, попробовал еще раз sp1 накатить - результат тотже.

    Сейчас опять сижу с рековером маюсь. 

     

    30 августа 2010 г. 9:03
  • можно результат увидеть
    get-executionpolicy –list


    Regards, Dmitriy Ilyin
    30 августа 2010 г. 10:21
  •  MachinePolicy                                                Unrestricted
        UserPolicy                                                RemoteSigned
           Process                                                   Undefined
       CurrentUser                                                   Undefined
      LocalMachine                                                RemoteSigned
    30 августа 2010 г. 10:36
  • 1. Перенесите эту машинку в контейнер куда ваши политики по PS не расспространяются
    2. с помощью
    Set-ExecutionPolicy -Scope LocalMachine -ExecutionPolicy Undefined
    и gpupdate
    добейтесь чтобы команда get-executionpolicy –list выдавала подобный результат:

    PS C:\Windows\system32> Get-ExecutionPolicy -list

                                                          Scope                                             ExecutionPolicy
                                                          -----                                             ---------------
                                                  MachinePolicy                                                   Undefined
                                                     UserPolicy                                                   Undefined
                                                        Process                                                   Undefined
                                                    CurrentUser                                                   Undefined
                                                   LocalMachine                                                   Undefined
    3. попробуйте перезапустить установку


    Regards, Dmitriy Ilyin
    30 августа 2010 г. 10:56
  • Сделал все политики Undefined. 

    При этом Get-ExecutionPolicy становится Restricted и скрипты на машине перестают выполняться. 

    Сейчас выставил все политики в Unrestricted.

    Пробую установить sp1

    2 сентября 2010 г. 4:21
  • Результат тот же.
    2 сентября 2010 г. 4:30
  • Т.е., вы делали все по данной KB ?

    Опишите , пожалуйста , вашу структуру организации Exchange.



    Daniil Khabarov, MSFT  Follow MSTechnetForum on Twitter
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Посетите Блог Инженеров
    3 сентября 2010 г. 11:07
    Модератор
  • Добрый день!

    SP1 я поставил, запустив службы удаленного реестра и чего-то там еще. (кажется WMI)

    RU не ставил.

    А вот SP2 ставил по приведенной статье.

    перенес сервер Exchange в контейнер, на котором не назначается политика выполнения PS, вручную прописал политику выполнения в Undefined, но все равно (на всякий случай), пока службы стопарились восстановил состояние служб удаленного реестра.

    Поэтому SP2 установился без проблем с первого раза.

    15 марта 2012 г. 10:06
  • Наконец-то я нашел решение с политикой выполнения.

    После переноса сервера в контейнер с неопределенной политикой выполнения скриптов, на данном компьютере продолжают действовать последние политики. 

    В результате получаем проблемы с установкой сервиспаков на Exch 2010. 

    На Exch 2013 первый сервиспак вообще не проходит проверку, пока machinepolicy и userpolicy имеют какое-либо значение. 

    Проблему решил только очисткой ключей реестра:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\PowerShell\ExecutionPolicy и 

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\PowerShell\ExecutionPolicy

    После этого выполняем Set-ExecutionPolicy Unrestricted

    и если Get-executionPolicy -list дает список:


                                                         Scope                                             ExecutionPolicy
                                                         -----                                             ---------------
                                                 MachinePolicy                                                   Undefined
                                                    UserPolicy                                                   Undefined
                                                       Process                                                   Undefined
                                                   CurrentUser                                                   Undefined
                                                  LocalMachine                                                Unrestricted

    Начинаем установку обновления.


    3 марта 2014 г. 5:15