none
удаленное приложение remoteapp отключено не удалось подключиться к удаленному компьютеру т.к. сервер шлюза удаленных рабочих столов временно недоступен RRS feed

  • Вопрос

  • Добрый день,

    Все службы RDS установлены на одном сервере W2012.

    Все работает в пределах домена, есть пользователи в удаленной сети (другая подсеть+VPN до офиса).

    Через Rdp-сессию сидят без проблем.

    Куда копать?

    22 сентября 2014 г. 8:27

Ответы

  • Ну, вообще, должен быть указан тип лицензирования, на пользователя или на устройство, но не об этом речь, я имел ввиду в настройках шлюза указана ли галка:



    • Изменено Alexander Shestakov 22 сентября 2014 г. 9:22
    • Помечено в качестве ответа NotGift 22 сентября 2014 г. 9:43
    22 сентября 2014 г. 9:17
  • Машина по прежнему пытается подключиться через шлюз.

    Если вы поставили галки, то этого происходить не должно.

    Зарегистрируйте сервера в Active Directory через NPS консоль ("Win+Q - набрать "nps")

    Если не получится, то в качестве теста, попробуйте отключить шлюз.

    • Помечено в качестве ответа NotGift 22 сентября 2014 г. 12:42
    22 сентября 2014 г. 12:13

Все ответы

  • Добрый день.

    На машинках в какой сети возникает ошибка?

    Какая версия клиентских ОС?

    Используется ли у вас шлюз для внутренних сетей?

    Get-RDDeploymentGatewayConfiguration | fl BypassLocal

          BypassLocal : True

    Если True, то авторизация для пользователей внутри сети на шлюзе не происходит.

    22 сентября 2014 г. 8:43
  • На машинах из внешки.

    в основном 7х64. и та с корой надо заставить работать тоже.

    насчет шлюза не понял? филиал выходит в инет через другого провайдера. между роутерами впн-канал(ходят на файл шару, 1с.) впринципе именно 1с в remoteapp и не работает. 

    развернуты службы удаленных рабочих столов.

    сейчас залез в свойства развертывания 

    так должно быть?

    22 сентября 2014 г. 9:12
  • Ну, вообще, должен быть указан тип лицензирования, на пользователя или на устройство, но не об этом речь, я имел ввиду в настройках шлюза указана ли галка:



    • Изменено Alexander Shestakov 22 сентября 2014 г. 9:22
    • Помечено в качестве ответа NotGift 22 сентября 2014 г. 9:43
    22 сентября 2014 г. 9:17
  • пробовал и  сгалками и без - не работает

    22 сентября 2014 г. 9:25
  • Попробуйте с включенной галкой обновить подключение RemoteApp



    22 сентября 2014 г. 9:31
  • в общем да с галками надо. Но ответ в том что в хостах должно быть указано полное fqdn имя сервера иначе отбой по сертификату. СПС. благодоря вам нашел в чем дело.
    22 сентября 2014 г. 9:43
  • теперб с одной машины 7х32 подключение идет ругаеться на сертификат, но запускает приложение а вот 7х64 ругаеться и не разрешает...
    22 сентября 2014 г. 10:11
  • Какой сертификат у вас используется?

    22 сентября 2014 г. 10:33
  • у меня вообще вот так причем с одной машины запускается норм так как есть опция продолжить а  на другой ругается на сертификат и не пускает дальше

    22 сентября 2014 г. 11:14
  • Значит у вас используется дефолтный самоподписный сертификат.

    Когда вы подключаете RemoteApp вы прописываете путь подключения к серверу в виде


    Соединение по https, соответственно нужен сертификат.

    Если у вас есть доменный центр сертификации рекомендую выдать сертификат для вашего сервера.

    Пришлите, пожалуйста, ошибку сертификата с той машины где не запускается.

    22 сентября 2014 г. 11:27
  • Почему тогда другая машина без проблем подключается? 

    22 сентября 2014 г. 11:32
  • Похоже, что машинка пытается подключиться через шлюз. Поэтому при недоверии сертификату, подключение не пройдет. Обновите свойства подключения RemoteApp на этой машине.

    Если результат не изменится, то попробуйте установить сертификат в корневой доверенный центр на этой машине.

    22 сентября 2014 г. 11:41
  • вообще я заходил через rdweb и там качал файлик. если делаю как вы говорите то 
    22 сентября 2014 г. 11:42
  • Сохраните сертификат, который используется в rdweb, и установите его в корневой доверенный центр сертификации на локальной машине. Тогда локальная машина начнет доверять этому сертификату, соединение можно будет установить.
    22 сентября 2014 г. 11:45
  • глупый вопрос но не могу понять где выгрузить сертификат
    22 сентября 2014 г. 11:53
  • загрузил. теперь вот что 
    22 сентября 2014 г. 11:58
  • Машина по прежнему пытается подключиться через шлюз.

    Если вы поставили галки, то этого происходить не должно.

    Зарегистрируйте сервера в Active Directory через NPS консоль ("Win+Q - набрать "nps")

    Если не получится, то в качестве теста, попробуйте отключить шлюз.

    • Помечено в качестве ответа NotGift 22 сентября 2014 г. 12:42
    22 сентября 2014 г. 12:13
  • Спасибо все заработало. видимо действительно св-ва подключения не обновлялись.

    как их принудительно обновлять?

    22 сентября 2014 г. 12:42