none
DAG Сеть RRS feed

  • Общие обсуждения

  • Добрый день, коллеги, мучаюсь уже несколько дней.

    Как правильно настроить сеть для DAG?

    Есть сеть MAPI 10.0.12.0/24 и repl 172.16.0.0/24

    Гайд прочитан https://docs.microsoft.com/en-us/exchange/high-availability/plan-ha#general-requirements

    Делаю MAPI

    Client for Microsoft Networks Enabled 
    QoS Packet Scheduler Enabled 
    File and Printer Sharing for Microsoft Networks Enabled 
    Internet Protocol version 6 (TCP/IP v6) Enabled 
    Internet Protocol version 4 (TCP/IP v4) Disabled 
    Link-Layer Topology Discovery Mapper I/O Driver Enabled 
    Link-Layer Topology Discovery Responder Enabled

    10.0.12.53

    255.255.255.0

    10.0.12.1

    repl:

    Client for Microsoft Networks Disabled 
    QoS Packet Scheduler Enabled 
    File and Printer Sharing for Microsoft Networks Disabled 
    Internet Protocol version 6 (TCP/IP v6) Enabled 
    Internet Protocol version 4 (TCP/IP v4) Disabled 
    Link-Layer Topology Discovery Mapper I/O Driver Enabled 
    Link-Layer Topology Discovery Responder Enabled

    172.16.0.21

    255.255.255.0

    no gw

    Без регистрации в DNS и с метрикой 10

    Согласно гайду изолирую hearbeat трафик от MAPI:

    В файрволе есть правила Failover Clusters (UDP....), там убрал доменный профиль, ибо сеть MAPI доменная.

    И получаем:

    Но на самом деле если убирать шлюз и сеть репликации, то всё норм.

    4 июля 2018 г. 13:41

Все ответы

  • 4 июля 2018 г. 14:35
  • А Вам точно нужно отделять? Сейчас MS рекомендует не заниматься этим усложнением, если сетевые порты гиг и больше.
    4 июля 2018 г. 14:59
  • Даг создать - элементарно. С этим проблем нет.

    Отделять? - рекомендация MS, черным по белому.

    Да даже делал и без сети репликации - тоже самое.

    Были в какие-либо моменты во ремя перенастроек и экспериментов и положительные моменты, с одного в ecp всё ок, со второго ошибка.

    Но сразу замечу, что если пошиком смотреть, то и сдагом и сетью всё ок. Активные копии пепеезжают и всё такое.

    Меня же вымораживает обстоятельство того, что в web ошибка...

    4 июля 2018 г. 19:45
  • Если речь про чангу 16, то текущие рекомендации ms эти сети совмещать, хотя многие продолжают делать как и раньше. И ничего страшного в этом нет.

    Может у вас проблема в  ecp? Пробовали пересоздавать виртуальную директорию , накатить последние cu и framework? Ошибка только в dag, больше ecp ничего подозрительного не выдает?

    4 июля 2018 г. 19:52
  • Чанга конечно 16, проблема была и на cu9, сейчас cu10, Framework 4.7.1

    В организации ещё два xch13 cu17, там всё ок.

    ecp сейчас попробую сброшу.

    Повторюсь - именно с dag проблем нет. Проблема только в web, что не отображает членов, витнес и сети. Через PoSH всё видно.

  • оставил щас в хром web sniffer и вижу, что при обращении к дагу идет такая инфа:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1251"/>
    <title>404 - Файл или каталог не найден.</title>
    <style type="text/css">
    <!--
    body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
    fieldset{padding:0 15px 10px 15px;}
    h1{font-size:2.4em;margin:0;color:#FFF;}
    h2{font-size:1.7em;margin:0;color:#CC0000;}
    h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
    #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
    background-color:#555555;}
    #content{margin:0 0 0 2%;}
    .content-container{background:#FFF;width:96%;margin-padding:10px;}
    -->
    </style>
    </head>
    <body>
    <div id="header"><h1>Ошибка сервера</h1></div>
    <div id="content">
    <div class="content-container"><fieldset>
    <h2>404 - файл или каталог не найден.</h2>
    <h3>Запрашиваемый ресурс перемещен, переименован либо временно недоступен.</h3>
    </fieldset></div>
    </div>
    </body>
    </html>
    5 июля 2018 г. 12:42
  • xch01 -это XCH2013
    5 июля 2018 г. 12:43
  • Без отдельной сети репликации всё тоже самое
    5 июля 2018 г. 14:53
  • Такая же проблема. Только у меня сети dag exch2010 через gui не выводит после добавления серверов Exch2016. 
    30 июля 2018 г. 5:43