none
IIS7 в Vista Ultimate (сервер недоступен из сети) RRS feed

  • Вопрос

  • В общем такая пробелма. Создал веб сервер средствами IIS7 в Vista Ultimate. На локальной машине все работает отлично, с различными вариантами привязки (127.0.0.1, localhost, 192.168.3.9 (внутренний айпи), striker (имя компа) и т.п.), но из локальной сети сервер недоступен.

     

    Локальная сеть организована под управлением роутера, но проблема 100% не в его настройках, т.к. все необходимые настройки сделаны и другие веб-серверы вроде Apache и Денвера работают "без проблем" (в ковычках потому что, есть проблемы с совместимостью с x64/Vista).

     

    В общем, такие дела. Надеюсь на вашу помощь. Заранее спасибо.

    16 июня 2008 г. 14:11

Ответы

  • Либо фаервол не настроен (добавить исключение для IIS), либо IIS настроен только на локальные соединения (что скорее всеgо настройка по умолчанию). Менять настройки.

    16 июня 2008 г. 16:32
    Модератор
  •  Ilya Tumanov написано:

    Либо фаервол не настроен (добавить исключение для IIS), либо IIS настроен только на локальные соединения (что скорее всеgо настройка по умолчанию). Менять настройки.

    Спасибо именно из-за файрвола Vistы были проблемы - добавил в исключения HTTP - все заработало.

     

     Vladimir Deneko написано:
    апач и иис стоят на одной машине? и как сделан проброс портов на роутере? на обе машины по 80 порту если иис и апач разные машины?


    если правильно понял схема такая
    локальный какой-то провайдер---их роутер на дом например--твой роутер--твоя локальная сеть
    не заходят из какой локальной сети на сайт? твоей или провайдера?
    заходят ли по адресу? http://внейший_ип_на_твоем_роутере  и попадают на сервер апача?

    Раньше ставил апач, щас стоит только IIS на свежеустановленной ОС.

    Проброс портов сделан нормально, щас уже проблема решена, спасибо за помощь)

    18 июня 2008 г. 19:55

Все ответы

  • Либо фаервол не настроен (добавить исключение для IIS), либо IIS настроен только на локальные соединения (что скорее всеgо настройка по умолчанию). Менять настройки.

    16 июня 2008 г. 16:32
    Модератор
  • Локальная сеть организована под управлением роутера, но проблема 100% не в его настройках, т.к. все необходимые настройки сделаны и другие веб-серверы вроде Apache и Денвера работают "без проблем" (в ковычках потому что, есть проблемы с совместимостью с x64/Vista).

    апач и иис стоят на одной машине? и как сделан проброс портов на роутере? на обе машины по 80 порту если иис и апач разные машины?


    если правильно понял схема такая
    локальный какой-то провайдер---их роутер на дом например--твой роутер--твоя локальная сеть
    не заходят из какой локальной сети на сайт? твоей или провайдера?
    заходят ли по адресу? http://внейший_ип_на_твоем_роутере  и попадают на сервер апача?


    17 июня 2008 г. 6:37
  •  Ilya Tumanov написано:

    Либо фаервол не настроен (добавить исключение для IIS), либо IIS настроен только на локальные соединения (что скорее всеgо настройка по умолчанию). Менять настройки.

    Спасибо именно из-за файрвола Vistы были проблемы - добавил в исключения HTTP - все заработало.

     

     Vladimir Deneko написано:
    апач и иис стоят на одной машине? и как сделан проброс портов на роутере? на обе машины по 80 порту если иис и апач разные машины?


    если правильно понял схема такая
    локальный какой-то провайдер---их роутер на дом например--твой роутер--твоя локальная сеть
    не заходят из какой локальной сети на сайт? твоей или провайдера?
    заходят ли по адресу? http://внейший_ип_на_твоем_роутере  и попадают на сервер апача?

    Раньше ставил апач, щас стоит только IIS на свежеустановленной ОС.

    Проброс портов сделан нормально, щас уже проблема решена, спасибо за помощь)

    18 июня 2008 г. 19:55