none
SharePoint Foundation 2010 - не работает поиск RRS feed

  • Вопрос

  • Всем привет. Помогите разобраться с неработающим поиском на узле SharePoint Foundation 2010.
    Исходные данные такие:
    Windows Server 2008 R2 Standard En + SQL Server 2008 R2 Express En + SharePoint Foundation 2010 Ru
    Всё установилось и заработало с полпинка без особых проблем. Но на созданом вэбузле при попытке выполнить поиск не возвращается ни одного результата.

    В "Центре администрирования" служба Поиск SharePoint Foundation находится в состоянии Запущено
    Задание таймера Обновление поиска SharePoint Foundation настроено на запуск каждые 5 минут и отрабатывает без ошибок. Правда время длительности его отрабатывания несколько смущает - 0:00:00

    В свойствах созданного вэб-сайта включена опция Всегда индексировать все веб-страницы на этом сайте 

    В логах Система и Приложения не фиксируется никаких ошибок.

    И при этом при всём поиск не возвращает ни одного результата. Подскажите в какую сторону можно покопать.

    • Перемещено Denis DyagilevEditor 16 декабря 2010 г. 11:49 (От:Серверные приложения)

Ответы

Все ответы

  • Добрый день

    Во первых Вы должны настроить источник обхода в центре администрирования и указать когда и как запускать обходчик.

    Вот статья по этому поводу - http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=39


    Sergey A Belskiy - Team Leader of developers, DEV-pro || My blog || My twitter || My space || My video
    Модератор
  • У меня не  SharePoint Server 2010 а SharePoint Foundation 2010. В Foundation в центре администрирования попросту нет таких настроек поэтому вопрос и возник.

  • У меня не  SharePoint Server 2010 а SharePoint Foundation 2010. В Foundation в центре администрирования попросту нет таких настроек поэтому вопрос и возник.


    Извините протупил :).

    Вот Вам статья по настройке - http://stsadm.blogspot.com/2010/04/starting-sharepoint-2010-foundation.html

    Надеюсь Вы РТМ используете, а не бету


    Sergey A Belskiy - Team Leader of developers, DEV-pro || My blog || My twitter || My space || My video
    Модератор
  • Спасибо за ссылку, но возникло такое впечатление что там описан (алтернативный) метод настройки службы поиска Foundation через PowerShell (начиная с задания её параметров и заканчивая запуском)... У меня служба настроена и запущена с параметрами по умолчанию...то есть, если я правильно понимаю, то что описано в статье уже сделано, и следовательно поиск должен работать...Или я всё таки чтото не так понял? Вообще есть на этом форуме люди у кого поиск в Foundation заработал без каких-то дополнительных извратных манипуляций?

  • Должен работать, но он не работает :)

    Попробуйте сделать всё как написано. Потому как по умолчанию не всегда всё работает :)


    Sergey A Belskiy - Team Leader of developers, DEV-pro || My blog || My twitter || My space || My video
    Модератор
  • Алексей, здравствуйте. Ваша проблема сохраняется?
    Данный форум является бесплатным сервисом Microsoft с целью оказания посильной помощи пользователям и повышения уровня знаний о продуктах Microsoft. Информация, представленная на форуме, распространяется "как есть" без официальной ответственности компании Microsoft.
    30 августа 2010 г. 9:41
  • Вам нужно настроить поиск - http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=39
    Sergey A Belskiy - Team Leader of developers, DEV-pro || My blog || My twitter || My space || My video
    • Предложено в качестве ответа Sergii BielskyiMVP, Moderator 31 августа 2010 г. 4:15
    • Помечено в качестве ответа Nikita Panov 31 августа 2010 г. 7:45
    31 августа 2010 г. 4:15
    Модератор
  • И посмотрите ещё решение - http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=92
    Sergey A Belskiy - Team Leader of developers, DEV-pro || My blog || My twitter || My space || My video
    31 августа 2010 г. 7:56
    Модератор
  • Была подобная проблема, решение оказалось очень простым, может это ваш случай

    Проверьте в Центр администрирования - параметры системы - настройка сопоставлений альтернативного доступа 

    для веб прилижения, зона по умолчанию должна быть адрес без https. 

    31 августа 2010 г. 9:35
  • "Сообщение пользователя Sergey Belskiy помечено как ответ в обсуждении, на которое вы подписаны"

    Весьма занятная история получается...Я задаю вопрос про конкретный продукт - SharePoint Foundation 2010, некто Sergey Belskiy отсылает меня на настройку обходчика в SharePoint Server 2010, я ему отвечаю что у меня вопрос по другому продукту и в SharePoint Foundation 2010 нет таких настроек обходчика как в SharePoint Server 2010...мне отвечают "Извините протупил :)."...затем этот же товарищ дает ссылку опять на настройку поиска в SharePoint Server 2010 ... да ещё и за меня помечают (видимо модеры) это как ответ....я просто в восторге...very helpful %)))

    По поводу http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=92 ... хм..кхкм....
    Разумеется я не стал бы задавать вопрос в технический форум если бы как минимум не проделал все процедуры предварительной настройки в ферме...Мультик из разряда "если у вас на мониторе не отображается виндавс - включите вилку монитора в розетку".
    Без обид :)

    Как бы там ни было вопрос для себя считаю закрытым, так как полностью заново установил ферму и поиск чудесным образом заработал. Из изменений в отличие от прошлой конфигурации можно отметить то, что для установки выбрал английскую версию SPF с последующим прикручиванием LP. Инстанс SQL Server 2008 R2 установил с Collation - Latin1_General_CI_AS_KS_WS

    31 августа 2010 г. 10:17
  • https у меня в конфигурации вообще не используется

    31 августа 2010 г. 10:18
  • "Сообщение пользователя Sergey Belskiy помечено как ответ в обсуждении, на которое вы подписаны"

    Весьма занятная история получается...Я задаю вопрос про конкретный продукт - SharePoint Foundation 2010, некто Sergey Belskiy отсылает меня на настройку обходчика в SharePoint Server 2010, я ему отвечаю что у меня вопрос по другому продукту и в SharePoint Foundation 2010 нет таких настроек обходчика как в SharePoint Server 2010...мне отвечают "Извините протупил :)."...затем этот же товарищ дает ссылку опять на настройку поиска в SharePoint Server 2010 ... да ещё и за меня помечают (видимо модеры) это как ответ....я просто в восторге...very helpful %)))

    По поводу http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=92 ... хм..кхкм....
    Разумеется я не стал бы задавать вопрос в технический форум если бы как минимум не проделал все процедуры предварительной настройки в ферме...Мультик из разряда "если у вас на мониторе не отображается виндавс - включите вилку монитора в розетку".
    Без обид :)

    Как бы там ни было вопрос для себя считаю закрытым, так как полностью заново установил ферму и поиск чудесным образом заработал. Из изменений в отличие от прошлой конфигурации можно отметить то, что для установки выбрал английскую версию SPF с последующим прикручиванием LP. Инстанс SQL Server 2008 R2 установил с Collation - Latin1_General_CI_AS_KS_WS


    Могли бы просто снять отметку с ответа вместо критики самих ответов, - всякое бывает, люди помогают бесплатно в свое рабочее время и могут иногда ошибиться и ссылкой, и продуктом :)

    А совет, "переставьте ферму", который может дать каждый, думаю вам бы понравился еще меньше в начале обсуждения, хотя именно он в результате и помог бы :)


    MCTS, MCITP:EPM
    31 августа 2010 г. 13:50
    Отвечающий
  • И посмотрите ещё решение - http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=92
    Sergey A Belskiy - Team Leader of developers, DEV-pro || My blog || My twitter || My space || My video


    http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=39

    предложенные ссылки недоступны. переложите ответ сюда пожалуйста.

    8 января 2011 г. 14:11
  • И посмотрите ещё решение - http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=92
    Sergey A Belskiy - Team Leader of developers, DEV-pro || My blog || My twitter || My space || My video


    http://blogs.it-club.in.ua/sbelskiy/Lists/Posts/Post.aspx?ID=39

    предложенные ссылки недоступны. переложите ответ сюда пожалуйста.


    Вот Вам новые ссылки - http://it-club.in.ua/personal/sbelskiy/blog/Lists/Posts/Post.aspx?ID=92

    и - http://it-club.in.ua/personal/sbelskiy/blog/Lists/Posts/Post.aspx?ID=39


    Sergey A Belskiy - Microsoft® Most Valuable Professional, Sharepoint Server || My blog || My Twitter || My Facebook || My Video
    • Предложено в качестве ответа DenPro 22 января 2011 г. 9:32
    8 января 2011 г. 14:38
    Модератор