none
Не запускается RRAS и удаленный доступ 8007042a RRS feed

  • Общие обсуждения

  • Пытался установить Tmeter 9,2 - ничего не получилось, при установке система сначала потеряла сеть, потом намертво зависла. После ресета был почищен реестр на предмет остатков Tmeter'а, поднята сеть, но потом начались проблемы.. При установке RRAS с удаленным доступом и нат, RRAS не запускается с ошибкой 8007042a, в журнале ошибок -  "не удается загрузить C:\Windows\System32\iprtrmgr.dll" EventID 20103.
    Физически библиотека есть, в реестре HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RemoteAccess\RouterManagers\<protocol>\DLLPath она тоже прописана. Если настраивать RRAS без удаленного доступа, то все работает.
    Помогите разобраться что к чему.
    15 сентября 2009 г. 7:13

Все ответы

  • Никто не знает как такое решить?
    16 сентября 2009 г. 14:23
  • Я полагаю, что проблема не с RRAS, а с сетевыми интерфейсами: либо остались какие-то скрытые, либо на рабочие что-то прописалось лишнее.
    Попробуйте удалить/запретить сетевые устройства в списке оборудования, почистить реестр от прописанных сетевых подключений.
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    17 сентября 2009 г. 4:24
    Модератор
  • Здравствуйте, Евгений. Разрешите Вам помочь.
    Мои рекомендации таковы:

    1. С помощью regsrv32 перерегестрируйте библиотеки msjet40.dll, msjetoledb40.dll, msjtes40.dll, oledb32r.dll
    2. Проверьте, чтобы в реестре были следующие значения:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13]
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25]
    и чтобы в этих значениях был указан для всех .dll правильный путь %systemroot%\system32
    3. Попробуйте сбросить настройки ip "netsh int ip reset"

    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    17 сентября 2009 г. 7:41
    Модератор
    • Сбрасывать настройки пробовал - не помогло..
    • При перерегистрации oledb32r.dll возникла проблема: Модуль "oledb32r.dll" загружен, но точка входа DllRegisterServer не найдена. Проверьте, что "oledb32r.dll" является правильным файлом DLL или OCX и повторите попытку. Остальные библиотеки перерегистрировались без проблем.
    • В реестре все все правильно указано.
    Не помогает ничего..
    17 сентября 2009 г. 11:13
  • После ресета сеть удалось поднять как раз только после удалении сетевых устройств из списка оборудования и чистки сетевых подключений. Также пробовал сбрасывать настройки IP.
    17 сентября 2009 г. 11:15
  • Пробовали утилиту rarepair?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    17 сентября 2009 г. 11:38
    Модератор
  • Попробовал. Не помогло, но теперь кроме EventID 20103 выдает еще и "Служба "Маршрутизация и удаленный доступ" завершена из-за внутренней ошибки Присоединенное к системе устройство не работает.." EventID 7024
    • Изменено Evgeniy Samok 17 сентября 2009 г. 14:39
    17 сентября 2009 г. 14:15
  • Что-то мне подсказывает, что без переустановки не обойтись... К этому собственно такой вопрос. Если переустановку запустить с работающей на данный момент системы может ли это исправить то, что натворил Tmeter и останется ли другой установленный софт нетронутым в рабочем состоянии со всеми настройками? И еще один вопрос - какой шейпер посоветуете для 2008 r2?
    17 сентября 2009 г. 14:33
  • Евгений, может для начала просто попробуете откатить систему до того момента как Вы установили Tmeter?
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    18 сентября 2009 г. 8:27
    Модератор
  • К сожалению это невозможно, ввиду отсутствия точек восстановления..
    20 сентября 2009 г. 5:27
  • Евгений, попробуйте запустить восстановление с помощью диска с дистрибутивом.
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    21 сентября 2009 г. 5:42
    Модератор
  • Восстановления не нашел.. нашел обновление, попробовал, не помогло..
    21 сентября 2009 г. 14:35
  • Окей, теперь это делается немного иначе, чем раньше, что связано с новым способом установки. Если нет проблем с английским, то можете посмотреть тут http://social.technet.microsoft.com/Forums/en-US/winserversetup/thread/cd3d665f-3d95-4617-946d-55d8c03448fe
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    22 сентября 2009 г. 7:36
    Модератор
  • По ссылке описан только способ восстановления загрузки.. У меня система загружается нормально и проблем с этим нет.
    22 сентября 2009 г. 10:09
  • Тогда Вам только переустановка поможет, имхо.
    p.s. Я почему-то подумал, что у Вас она даже не грузится ;-)
    Поможем друг другу стать лучше! Отметим правильные ответы и полезные сообщения!
    22 сентября 2009 г. 10:12
    Модератор
  • Вообщем была та же самая ситуация из-за TrafficShaperXP - установил, потом при удалении оно выкинуло BSOD и все - RRAS не стартовал.

     

    не знаю что из этого всего помогло, но после всех этих действий RRAS запустился и заработал как раньше

    1. Сделал Disable RRAS в оснастке RRAS, и заново Enable но не запускал

    2. Удалил все сетевые интерфейсы в Диспетчере устройств

    3. Сделал в дисп.устройств обновить - заново установились сетевые интерфейсы

    4. Сделал как сказал Nikita Panov

    -------

    Здравствуйте, Евгений. Разрешите Вам помочь.
    Мои рекомендации таковы:

    1. С помощью regsrv32 перерегестрируйте библиотеки msjet40.dll, msjetoledb40.dll, msjtes40.dll, oledb32r.dll
    2. Проверьте, чтобы в реестре были следующие значения:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13]
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\25]
    и чтобы в этих значениях был указан для всех .dll правильный путь %systemroot%\system32
    3. Попробуйте сбросить настройки ip "netsh int ip reset"

    -----------

    5. Возможно в этом всё решение - заново установил TrafficShaperXP со всеми драйверами и сразу же удалил (в этот раз без BSOD'а)

    6. После перезагрузки ЗАРАБОТАЛО!

     

    25 января 2011 г. 22:36
  • Решил аналогичную проблему без перезагрузки сервера:

    1) Зашел в свойства маршрутизации и удаленного доступа

    2) на вкладке Ipv6 все отключил (две верхние галочки)

    3) Удалил ветку из регистра (она отвечает за протокол IPv6):

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RemoteAccess\RouterManagers\Ipv6

    4) Вернулся в роли сервера

    5) Правой кнопкой по" маршрутизация и удаленный доступ", все задачи, запустить

    Все заработало. Естественно протокол Ipv6 работать не будет. В моем случае он не нужен.


    • Изменено cgistalker 23 марта 2012 г. 10:28
    23 марта 2012 г. 10:28
  • Спасибо огромное! Мне помог пункт 3.

    14 марта 2014 г. 5:10
  • Также помог пункт 3, большое спасибо за подсказку.

    В моем случае после установки системных обновлений винда заново создала этот раздел реестра, и из-за этого на запускалась "Маршрутизация и удаленный доступ" с кодом 7024.

    18 октября 2017 г. 7:50
  • Помог пункт 3.

    Спасибо!

    19 июля 2018 г. 7:54