none
проблема с входом в мобильный Lync 2013 RRS feed

  • Вопрос

  • Коллеги, добрый день.

    Есть у меня домен - systeminvest.local и sip домен - systeminvest.ru - FQDN имя сервера lync-1.systeminvest.local

    Есть пользователь в AD - test2, которому создана учетная запись в Lync с sip именем - test2@systeminvest.ru

    Внутри все работает

    Пытаюсь коннектиться из вне...не пускает. Хотя на TMG все пакеты проходят.

    Запускаю Microsoft Lync Connectivity Analyzer, вбиваю все свои данные и вижу:

    [19/01/2015 11:04:05] Cleared the log file
    [19/01/2015 11:04:06] [DEBUG] Logging test parameters:
    [19/01/2015 11:04:06] [DEBUG] SIP Uri: test2@systeminvest.ru
    [19/01/2015 11:04:06] [DEBUG] User Name: test2@systeminvest.local
    [19/01/2015 11:04:06] [DEBUG] Discovery Type: Manual Discovery
    [19/01/2015 11:04:06] [DEBUG] Server FQDN: sip.systeminvest.ru
    [19/01/2015 11:04:06] [DEBUG] Network access: NetworkAccessExternal
    [19/01/2015 11:04:06] [DEBUG] Selected client: ApplicationLyncMobile2013
    [19/01/2015 11:04:06] [SUBHEADING] Starting manual Lync server discovery
    [19/01/2015 11:04:06] [INFO] Please wait; this test may take several minutes to complete...
    [19/01/2015 11:04:06] [SUBHEADING] Starting server discovery for secure (HTTPS) channel
    [19/01/2015 11:04:06] [INFO] Server discovery started for https://sip.systeminvest.ru/Autodiscover/AutodiscoverService.svc/root
    [19/01/2015 11:04:06] [DEBUG] Sending HTTP request to https://sip.systeminvest.ru/Autodiscover/AutodiscoverService.svc/root?sipuri=test2@systeminvest.ru
    [19/01/2015 11:04:07] [DEBUG] Cookie  found in autodiscover response: StatusCode: 200, ReasonPhrase: 'OK', Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
    {
      Pragma: no-cache
      X-MS-Server-Fqdn: lync-1.systeminvest.local
      Strict-Transport-Security: max-age=31536000; includeSubDomains
      X-Content-Type-Options: nosniff
      Cache-Control: no-cache
      Date: Mon, 19 Jan 2015 07:02:08 GMT
      Server: Microsoft-IIS/8.5
      X-AspNet-Version: 4.0.30319
      X-Powered-By: ASP.NET
      Content-Length: 972
      Content-Type: application/vnd.microsoft.rtc.autodiscover+xml; v=1
      Expires: -1
    }
    [19/01/2015 11:04:07] [DEBUG] Parsing the response for URL https://sip.systeminvest.ru/Autodiscover/AutodiscoverService.svc/root?sipuri=test2@systeminvest.ru.  Full response: <?xml version="1.0" encoding="utf-8"?><AutodiscoverResponse xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" AccessLocation="Internal"><Root><Link token="Domain" href="https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/domain" /><Link token="User" href="https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/user" /><Link token="Self" href="https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root" /><Link token="OAuth" href="https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/oauth/user" /><Link token="External/XFrame" href="https://lync-1.systeminvest.local/Autodiscover/XFrame/XFrame.html" /><Link token="Internal/XFrame" href="https://lync-1.systeminvest.local/Autodiscover/XFrame/XFrame.html" /><Link token="XFrame" href="https://lync-1.systeminvest.local/Autodiscover/XFrame/XFrame.html" /></Root></AutodiscoverResponse>
    [19/01/2015 11:04:07] [DEBUG] Autodiscover URL https://sip.systeminvest.ru/Autodiscover/AutodiscoverService.svc/root?sipuri=test2@systeminvest.ru redirected to https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/user
    [19/01/2015 11:04:07] [DEBUG] Sending HTTP request to https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/user?sipuri=test2@systeminvest.ru
    [19/01/2015 11:04:07] [DEBUG] Exception encountered while sending an HTTP request to https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/user?sipuri=test2@systeminvest.ru: An error occurred while sending the request.. Complete Exception: \r\nSystem.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: The remote name could not be resolved: 'lync-1.systeminvest.local'
       at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
       at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)


    если я перехожу по - https://sip.systeminvest.ru/Autodiscover/AutodiscoverService.svc/root?sipuri то вижу:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <resource xmlns="http://schemas.microsoft.com/rtc/2012/03/ucwa" rel="root" href="https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root">
    <link rel="user" href="https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/oauth/user"/>
    <link rel="xframe" href="https://lync-1.systeminvest.local/Autodiscover/XFrame/XFrame.html"/>
    </resource>

    При том, если я внутри, лезу на - https://lync-1.systeminvest.local/Autodiscover/AutodiscoverService.svc/root/user?sipuri=test2@systeminvest.ru - то вижу

    По идее, это проблема с IIS, но я в нем не силен....куда копать, подскажите плз.

    19 января 2015 г. 7:08

Ответы