none
Sharepoint 2007 - пересохраняет всё в UTF-8. Как победить? RRS feed

  • Вопрос

  • Если в SharePoint Designer 2007 открыть html файл, который был сохранён в ANSI и в коде которого не указана кодировка, т.е. charset=, то при пересохранении этого документа в SharePoint, он становится utf-8 и так со всеми документами, которые открываются как html.

    Как можно отменить сохранение в utf-8 ?

    ------------------------------------------------------------

    Пример, где и почему возникает проблема.
    Есть cms которая использует <meta http-equiv="Content-Type" content="text/html; charset=windows-1251" />
    Все подгружаемые в страницу модули не содержат в коде <meta http-equiv="Content-Type" content="text/html; charset=windows-1251" /> т.к. из этих модулей собирается основная страница. Т.е. я открываю, пралю модули, они сохраняются в utf-8 и на главной странице отображаются крякозябры.

     

     

    • Перемещено Vinokurov Yuriy 21 апреля 2011 г. 15:40 (От:Клиентские приложения)
    20 апреля 2011 г. 13:14

Ответы

  • Здравствуйте,

    попробовали менять кодировку в Sharepoint Designer 2007 через Site - Site Settings - Language?

    Roman Zhukov, спасибо, что откликнулись.
    Да, параметры узла я пробовал править, но эти настройки влияют только на изменение
    <meta http-equiv="content-type" content="text/html; charset=" />  для новых страниц, а как я писал выше проблема именно при редактировании страниц, где нет метатега с charset и эти страницы, не зависимо от их начальной кодировки, все пересохраняются в utf-8

    Как только я удаляю эту строчку (с кодировкой) страница автоматом становиться utf-8, это видно даже наглядно (когда меняю размер шрифта для utf-8 по умолчанию для редактора) 

    Я перерыл весь рунет и иностранные форумы, такую проблему упоминали, но решения никто не написал.
    В Expression Web, такая же проблема. (и в последнем)

    Очень надеюсь, что кто-то из microsoft подскажет, как отменить перекодирование файлов или возьмут на вооружение и сделают пакет исправлений.
    За темой буду следить. Спасибо.

    -------------------------------------------------------------

    Из собственных экспериментов (Может кому-то поможет):

    Пробовал автоматом заменять все utf-8 на windows-1251 во всех служебных файлах SharePoint - не помогает (значит, это в SPDESIGN.EXE задано)
    Если просто открыть файл (ничего не меняя) и повторно его сохранить - то кодировка не меняется.
    Если открыть файл в ANSI и сделать исправления в визуальном редакторе (в Конструкторе) - то при сохранении кодировка файла не меняется, т.е. меняется если вносить любые правки (даже удаление одного символа) в редакторе кода (в представлении Код).

    Ну и нашёл решение (способ работает, но очень не удобный, особенно, когда вносишь множество исправлений в коде и смотришь результат в браузере)

    Нужно сделать все нужные изменения в коде, далее открыть Свойства страницы --> Язык --> Выбрать нужную кодировку --> Ok --> Сохранить страницу --> Потом вновь открыть Свойства страницы --> Язык --> и выбрать  кодировку <отсутствует> --> Ok --> Сохранить страницу

    При такой манипуляции сначала  добавляется  
    <meta http-equiv="content-type" content="text/html; charset=windows-1251" /> (и задаётся кодировка для страницы)
    далее, через свойства мы удалеем метатег кодировки и пересохраняем.



    • Помечено в качестве ответа Roman Zhukov 27 апреля 2011 г. 10:55
    22 апреля 2011 г. 22:40

Все ответы

  • Здравствуйте,

    попробовали менять кодировку в Sharepoint Designer 2007 через Site - Site Settings - Language?

     


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий.
    22 апреля 2011 г. 13:12
  • Здравствуйте,

    попробовали менять кодировку в Sharepoint Designer 2007 через Site - Site Settings - Language?

    Roman Zhukov, спасибо, что откликнулись.
    Да, параметры узла я пробовал править, но эти настройки влияют только на изменение
    <meta http-equiv="content-type" content="text/html; charset=" />  для новых страниц, а как я писал выше проблема именно при редактировании страниц, где нет метатега с charset и эти страницы, не зависимо от их начальной кодировки, все пересохраняются в utf-8

    Как только я удаляю эту строчку (с кодировкой) страница автоматом становиться utf-8, это видно даже наглядно (когда меняю размер шрифта для utf-8 по умолчанию для редактора) 

    Я перерыл весь рунет и иностранные форумы, такую проблему упоминали, но решения никто не написал.
    В Expression Web, такая же проблема. (и в последнем)

    Очень надеюсь, что кто-то из microsoft подскажет, как отменить перекодирование файлов или возьмут на вооружение и сделают пакет исправлений.
    За темой буду следить. Спасибо.

    -------------------------------------------------------------

    Из собственных экспериментов (Может кому-то поможет):

    Пробовал автоматом заменять все utf-8 на windows-1251 во всех служебных файлах SharePoint - не помогает (значит, это в SPDESIGN.EXE задано)
    Если просто открыть файл (ничего не меняя) и повторно его сохранить - то кодировка не меняется.
    Если открыть файл в ANSI и сделать исправления в визуальном редакторе (в Конструкторе) - то при сохранении кодировка файла не меняется, т.е. меняется если вносить любые правки (даже удаление одного символа) в редакторе кода (в представлении Код).

    Ну и нашёл решение (способ работает, но очень не удобный, особенно, когда вносишь множество исправлений в коде и смотришь результат в браузере)

    Нужно сделать все нужные изменения в коде, далее открыть Свойства страницы --> Язык --> Выбрать нужную кодировку --> Ok --> Сохранить страницу --> Потом вновь открыть Свойства страницы --> Язык --> и выбрать  кодировку <отсутствует> --> Ok --> Сохранить страницу

    При такой манипуляции сначала  добавляется  
    <meta http-equiv="content-type" content="text/html; charset=windows-1251" /> (и задаётся кодировка для страницы)
    далее, через свойства мы удалеем метатег кодировки и пересохраняем.



    • Помечено в качестве ответа Roman Zhukov 27 апреля 2011 г. 10:55
    22 апреля 2011 г. 22:40