none
Данная установка запрещена политикой,заданной системным администратором. RRS feed

  • Вопрос

  • Эта ошибка не дает мне спать спокойно.

    1)Пол интернета  перекопал кто говорит ковыряйтесь в "политике ограниченного использования программ" другие твердят у вас установлен с++ пакет, еще были советы по удалению ключа из  HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer но все это не помогает!

    2)Как я понял это точно политики!!!!!!!!!!!!!!!!!!, т.к недавно умер резервный контроллер он был успешно поднят на новом сервере с новым именем.Ни одной KB,ни одного обновления не ставил пытаются поставить msi пакет на этот успешно поднятый рез контроллер и тут вылетает ошибка!

    3) Восстанавливал доменную политику до дефолтных! Но это тоже не помогло!

    4)Это точно не локальная политика! Реплицируется политика на все сервера домена! Только на  сервера,на локальных машинах под доменной учеткой с группой "администраторы домена" или "Администратор" все msi пакеты ставятся на ура!!!!

    Перед тем как создать тему откатил  на дефолтовые политики домена и контроллеров домена ! командой 


    Ниже даю 2 отчета по политикам домена и контроллера домена

    Default Domain Controllers Policy.

     Default Domain Policy

    Если логически подумать то как эта ошибка появляется на других серверах? наверно только по средствам доменных групповых политик.

    Заранее все кто откликнулся на проблему Огромное спасибо!!!!!!!!!!!

    30 января 2014 г. 12:30

Ответы

  • http://sgww.livejournal.com/15903.html - Эта статья помогла мне решить проблему,странно почему так себя ведут групповые политики =( Ну зато теперь устанавливается!

    • Помечено в качестве ответа AlexDarkk1 26 марта 2014 г. 12:44
    26 марта 2014 г. 12:44

Все ответы

  • UPD.

    Сделал на себя Rsop и увидел 

    Далее на себя gpresult и 

    Самое интересное что в gpmc посмотрел результаты 3  политик и Политик Ограниченного использования нету!!!! Их просто нету !! Откуда он берет эту политику ?????

    Вот отчеты всех 3 политик с контроллера домена!

    Internet Explorer Default Site __TERM2

    disk Q VBS - WINXP WIN7

    Default Domain Polic

    ====

    В назначенных форматах файлов не выбрано не одного! 

    Сможет ли такая политика отрабатываться? Может у меня изза этого не работает установка msi пакетов? 

    Есть у кого еще какие идеи почему так ведет себя система!? 

    Заранее огромное спасибо!!!!!!!


    • Изменено AlexDarkk1 31 января 2014 г. 5:13
    30 января 2014 г. 16:26
  • выкладывайте лучше 

    gpresult -h тут написать путь и имя файла, для сохранения отчета

    с машины на которой проблема
    • Изменено kruzhka 31 января 2014 г. 4:37
    31 января 2014 г. 4:36
  • C:\Windows\system32>gpresult /H c://GPReport.html

    Вот вывод команды gpresult /H

    GPReport.html




    • Изменено AlexDarkk1 31 января 2014 г. 5:11
    31 января 2014 г. 5:10
  • удалите политики ограниченного использования программ, там где они настроены (в локальной политике и т.п.), естественно если они не используются.


    • Изменено kruzhka 31 января 2014 г. 6:05
    31 января 2014 г. 5:58
  • Самое интересное что в gpmc посмотрел результаты 3  политик и Политик Ограниченного использования нету!!!! Их просто нету !! Откуда он берет эту политику ?????

    Аналогично смотрел на этомже сервере где делал rsop на себя,глядел secpol(Локальную политику безопасности) и тут тоже ничего нету.

    Есть еще варианты? куда глянуть


    • Изменено AlexDarkk1 31 января 2014 г. 6:45
    31 января 2014 г. 6:38
  • локальная политика безопасности например
    • Изменено kruzhka 31 января 2014 г. 6:43 например
    31 января 2014 г. 6:42
  • Мне кажется вы не читая,отвечаете мне =(

    Перед вами скриншот и описание что глядел secpol(Локальную политику безопасности) и тут тоже ничего нету.

    • Изменено AlexDarkk1 31 января 2014 г. 7:04
    31 января 2014 г. 7:03
  • да, поспешил

    настройте в одной из применяемых политик эту политику ограничения программ, просто нажмите создать политику и оставьте все по умолчанию. Обновите политику на том компьютере с которым проблемы

    gpupdate /force

    после чего попробуйте запустит ваш установщик


    эта настройка политики, будучи примененной лишь раз, остается, и не отменяется после того как вы удалили настройку из политики.
    • Изменено kruzhka 31 января 2014 г. 7:39
    31 января 2014 г. 7:36
  • Проделанные работы

    !

    Завершил свой процесс,вошел обратно!

    Сделал gpresult

      Примененные объекты групповой политики

      ---------------------------------------

          Default Domain Policy

          Morena_disk Q VBS - WINXP + WIN7

          Internet Explorer Default Site //TERM2

     

    Будем менять default domain policy

    Создал политику

    gpupdate /force 

    Сделал logoff,ошибка не изменилась и не исправилась!

    Опять же вспомнил что именно при блокировке приложений через эту политику (Политик Ограниченного использования) ошибка выводится по другому!

    Жду с нетерпеньем новых советов.


    • Изменено AlexDarkk1 31 января 2014 г. 8:57
    31 января 2014 г. 8:54
  • http://s018.radikal.ru/i518/1401/18/083a8f997e11.png

    там уровни безопасности - на каком уровне галка через rsop?


    • Изменено kruzhka 31 января 2014 г. 9:05
    31 января 2014 г. 9:05
  • Пробовал для "Всех пользователей" + gpupdate /force

    Пробовал для "Всех пользователей,кроме локальных администраторов" + gpupdate /force

    Установка так и проходит с ошибкой.

    31 января 2014 г. 9:44
  • уровни безопасности, при просмотре через rsop какой показан? 
    31 января 2014 г. 10:47
  • Я выставил Неограниченный,но это тоже не помогает +gpupdate /force
    • Изменено AlexDarkk1 31 января 2014 г. 10:58
    31 января 2014 г. 10:58
  • а в результирующей политике какой уровень?
    31 января 2014 г. 11:15
  • Вывод rsop после gpupdate + logoff

    Уровень показан неограниченный!


    • Изменено AlexDarkk1 31 января 2014 г. 11:26
    31 января 2014 г. 11:23
  • в конфигурации компьютера надо полагать тоже?

    и applocker посмотрите. 
    • Изменено kruzhka 31 января 2014 г. 11:51
    31 января 2014 г. 11:50
  • Да,на скрине видно что "Конфигурация компьютера" + "Конфигурация пользователя" Настройки одинаковые .

    По поводу "Политик ограниченного использования программ" он же APPlocker,ни одной политики на него не настроена. Это можно увидеть в отчетах политик которые я выше скинул! =(

    Что за ошибка та такая???

    31 января 2014 г. 12:12
  • давайте целиком ключи

    • HKEY_LOCAL_MACHINE\SOFTWARE\Policies
    • HKEY_CURRENT_USER\Software\Policies
    1 февраля 2014 г. 15:15
  • да...

    ну тогда давайте по другому, запускайте process monitor, запускайте файл который блокируется, сохраняйте данные собранные process monitor и присылайте.

    3 февраля 2014 г. 11:01
  • UAC отключен?

    Если да, то включите его и попробуйте запустить файл.

    4 февраля 2014 г. 9:44
  • Пробовал включить на всю UAC,также выключить! + перезагрузки,не помагает
    4 февраля 2014 г. 12:20
  • Пробовал включить на всю UAC,также выключить! + перезагрузки,не помогает

    что значит на всю? Включаете uac и запускаете файл не через командную строку а 2 щелчком. Он должен запросить повышение прав.

    Либо через командную строку открытую от имени администратора.

    Вообщем смысл то в том что прав у пользователя нету для продолжения установки, ГП на это вообще не влияют, там другое сообщение выдается, а при отключенном UAC-е именно такое сообщение. 


    • Изменено kruzhka 4 февраля 2014 г. 13:17
    4 февраля 2014 г. 12:48
  • Включен на всю это - "Всегда уведомлять с следующих случаях"

    Выключен - это "Не уведомлять меня"

    ===

    Запуск msi пакета производился 2-мя кликами,также запуска из командной строки + Runas,опять ничего не помагает!

    =====

    Обновил пакеты групповых политик для сервера server 2008r2! То есть заменил все adm файлы, Обновил политику везде gpupdate перезагружал сервера,опять ничего не помагает!

    6 февраля 2014 г. 4:24
  • ну в том дампе из PM который вы прислали, нету ни чего кроме установщика, политики он проходит, установка начинается а куда дальше вызов передается я не вижу, потому что там нету ни чего больше, возможно требуются права администратора предприятия, так как установщик не может получить доступ к некоторым ключам реестра.

    Попробуйте дать доп. права, пришлите установочный файл и дамп без фильтрации.

    6 февраля 2014 г. 6:38
  • Есть еще варианты? Вопрос очень актуален
    25 марта 2014 г. 13:17
  • http://sgww.livejournal.com/15903.html - Эта статья помогла мне решить проблему,странно почему так себя ведут групповые политики =( Ну зато теперь устанавливается!

    • Помечено в качестве ответа AlexDarkk1 26 марта 2014 г. 12:44
    26 марта 2014 г. 12:44
  • Такой метод показался мне опасным. Надо, или вернуть, как было, или разбираться в настройках политики ограниченного доступа. Решил поискать ещё и нашёл такой метод: http://serverfault.com/a/581117 - работает.
    29 октября 2015 г. 7:22
  • Наши админы говорят попробовать запустить установку под ЛОКАЛЬНЫМ администратором сервера, такая ошибка возникает при неправильной настройке UAC.
    3 февраля 2016 г. 15:00