none
ISA 2006 Std + сертификаты win2008 RRS feed

  • Вопрос

  • Имеем:
    -ISA 2006, два правила публикации OWA(Exch2003 на win2003) и web TS(на 2008)
    -доменный ЦС на 2003, все сертификаты выдает он
    -win 2008. на нем сайт ts, роли IIS,TS,TSG,LicensingTS,веб-доступ TS

    Проблема:
    Скажу сразу с OWA нет проблем, правило проверяется, все сертификаты проверяются.
    У правила публикации webTS жму кнопку "проверить правило" получаю "нет доверия ЦС"
    http://img42.imageshack.us/img42/2116/40564059.png 
    сертификат самого ЦС есть в:
    -хранилище ISA(комп-личные)
    -хранилище ISA(комп-доверенные ЦС)
    -хранилище ISA(юзер-личные)
    -хранилище ISA(юзер-доверенные ЦС)
    -хранилище 2008(комп-личные)
    -хранилище 2008(комп-доверенные ЦС)
    -хранилище 2008(юзер-личные)
    -хранилище 2008(юзер-доверенные ЦС)
    -на 2008 в IIS сертификаты сервера.
    сертификат сайта ts тоже везде накидан. чего еще надо?

    т.к. в IIS 2008 не запросишь сертификат через веб как это было у 2003, делался сертификат так:
    -в IIS 2008  в сертификаты сервера создавался запрос как расширенный Web-сайту и сохранялся в файл
    -на сервере ЦС 2003 открывась веб-морда ЦС и делался еще раз расширенный запрос, которому в окно копировалось содержимое сделанного файла, результат-выданный сертификат сохранялся в файл
    - в IIS 2008 делался запрос на установ сертификата из файла
    - сертификат самого ЦС сто раз импортировался во все хранилища и с закрытым кодом и без - все без толку!

    спасибо за ответы

    22 октября 2009 г. 11:55

Ответы

  • отвечу самостоятельно. надо было поставить "сертификат для шлюза служб терминалов"
    делается в диспетчер_шлюза_служб_терминалов-политики_авторизации_подключений - справа настроить_центральную_политику_TS_CAP

    правда проблема сменилась на другую. теперь получаю 404 ошибку, если глядеть с ISA. или 401, если открывать с самого 2008.
    открываю доменным админом, разрешения есть :)
    самое прикольное, что из локальной сети сайт https://2008.domain.ru\ts открывается и работает :) а с сервера 2008 - 401 ошибка!

    22 октября 2009 г. 12:34
  • опять себе отвечу: когда публикуем правило для OWA, на вкладке Пути надо указывать /exhange* (со звездой)
    а при публикации ts заводим две строчки без звезды и со звездой
    • Изменено www_tank 23 октября 2009 г. 6:23 неточность
    • Помечено в качестве ответа Vinokurov YuriyModerator 26 октября 2009 г. 11:02
    22 октября 2009 г. 12:42

Все ответы

  • отвечу самостоятельно. надо было поставить "сертификат для шлюза служб терминалов"
    делается в диспетчер_шлюза_служб_терминалов-политики_авторизации_подключений - справа настроить_центральную_политику_TS_CAP

    правда проблема сменилась на другую. теперь получаю 404 ошибку, если глядеть с ISA. или 401, если открывать с самого 2008.
    открываю доменным админом, разрешения есть :)
    самое прикольное, что из локальной сети сайт https://2008.domain.ru\ts открывается и работает :) а с сервера 2008 - 401 ошибка!

    22 октября 2009 г. 12:34
  • опять себе отвечу: когда публикуем правило для OWA, на вкладке Пути надо указывать /exhange* (со звездой)
    а при публикации ts заводим две строчки без звезды и со звездой
    • Изменено www_tank 23 октября 2009 г. 6:23 неточность
    • Помечено в качестве ответа Vinokurov YuriyModerator 26 октября 2009 г. 11:02
    22 октября 2009 г. 12:42