none
Код ошибки 19 и Canon PowerShot A430 RRS feed

  • Общие обсуждения

  •  

    Здравствуйте! Есть машинка с Windows XP SP2 Pro к ней цепляется цифровик Canon PowerShot A430 (при помощи USB шнурка) недавно пользователь каким-то твикером похоже снёс драйвера на это устройство и теперь при подключении система говорит мол "Windows не удалось запустить это устройство, поскольку информация о его конфигурации в реестре неполна или повреждена. (Код 19)" Возможно ли как-то решить эту проблему без переустановки системы?
    18 декабря 2007 г. 10:29

Все ответы

  • Попробуйте так:

    Загрузите систему в безопасном режиме. В диспетчере устройств найдите и удалите драйвер к вашему фотоаппарату. Если не нашли - попробуйте включить отображение скрытых устройств. Если снова не нашли - откройте редактор реестра и поищите ветки со ссылкой на драйвер там (если найдете - удалите соответствующие ключи). Внимание! Не забывайте делать резервную копию реестра!

    После данных манипуляций перезагрузите ПК и переустановите драйвер. Если драйвер не устанавливается, попробуйте установить его в безопасном режиме.

    18 декабря 2007 г. 11:23
  •  Undel написано:

    Попробуйте так:

    Загрузите систему в безопасном режиме. В диспетчере устройств найдите и удалите драйвер к вашему фотоаппарату. Если не нашли - попробуйте включить отображение скрытых устройств. Если снова не нашли - откройте редактор реестра и поищите ветки со ссылкой на драйвер там (если найдете - удалите соответствующие ключи). Внимание! Не забывайте делать резервную копию реестра!


    Ну по моему всесто всего етого можно попробовать откат драйверов это кокрастаки и равносильно всему тому что ты тут посоветовал
     Undel написано:

    После данных манипуляций перезагрузите ПК и переустановите драйвер. Если драйвер не устанавливается, попробуйте установить его в безопасном режиме.


    Ну помоему не все драйвера встают в безопастном режиме надо это тоже предусмотреть. А если не лень то можно попробовать восстановление системы из точки контроля. Может и поможет. Ну если нет то сделать поверхностное обновление системы.
    18 декабря 2007 г. 12:03
  • Вариант с удалением ветки реестра не помог..... Проблема актуальна....

     

    Откатывать драйвера некуда ибо идут они вместе с системой (на оффсайте производителя драйверов выше чем под Win 2k просто нет) Восстановление системы тоже не вариант потому как драйвера были убиты давным давно месяца 4 назад а потребовалось именно сейчас....

    19 декабря 2007 г. 4:51
  •  

    Какова ситуация теперь? Та же самая ошибка? Значит вычистили не все. Удалите все упоминания о данном драйвере. Попробуйте восстановить подпапку Drivercache в папке Windows - это должно восстановить идущие в комплекте драйверы(но не их работу, т.к. из нее они только устанавливаются). После этого найдите все файлы драйвера в системе и удалите. После удаления всех "следов" подключайте устройство и переустанавливайте драйвер.

    Вполне возможно, что с системой идут те же драйвера, что и на сайте производителя - часть драйверов Windows 2000 и Windows XP совместимы.

    19 декабря 2007 г. 9:10