none
Необъяснимое поведение процессора при использовании виртуальных машин Hyper-V RRS feed

  • Общие обсуждения

  • Доброго времени суток!

    Опишу суть проблемы - создали hyper-v failover cluster с CSV, первый физический сервер IBM system x3400, второй IBM system x3650. У обоих процессоры Intel Xeon E5420. В качестве сетевого хранилища используется QNAP Turbo NAS TS-1279U. В самом кластере используется две виртуальных машины. Обе виртуальных машины настроены на использование 4 виртуальных процессоров. На каждым физическом сервере 8 ядер. А проблема заключается в следующем - когда обе виртуальные машины крутится на IBM system x3650, периодически (примерно около 3-4 раз в сутки) на гостевых ОС в виртуалках вырастает загруженность процессора до 100% (показывает нагрузку на процессе system idle), одновременно на обеих виртуальных машинах. При этом, на физическом сервере в этот момент вырастает загруженность одного ядра до 100%, а остальные семь не используются. Спустя некоторое время (от 5 до 15 минут) это проходит, нагрузка на одно ядро падает, и начинают использоваться все ядра. Соответственно, в этот момент, нагрузка на виртуальных машинах тоже стабилизируется.

    При этом, когда виртуальные сервера находятся на IBM system x3400, ничего подобного не наблюдается.

    Я даже не представляю, в каком направлении начинать поиски решения проблемы, поэтому рассчитываю на вашу помощь!

    • Изменен тип Rotar MaksimModerator 9 января 2013 г. 5:42 Тема переведена в разряд обсуждений по причине отсутствия активности
    13 декабря 2012 г. 23:46

Все ответы

  • на гостевых ОС в виртуалках вырастает загруженность процессора до 100% (показывает нагрузку на процессе system idle)
    Просьба пояснить этот момент - что значит "нагрузка на процессе System Idle"? это не процесс как таковой, а сущность для учёта времени простоя процессора
    А начинать всегда с обновления прошивок и драйверов - проверяли актуальность?
    14 декабря 2012 г. 7:05
    Отвечающий
  • Ну в диспетчере задач так и показывает - system idle process, ЦП - от 70 до 90 скачет. Драйвера и прошивки проверю.
    16 декабря 2012 г. 23:09
  • Уважаемый пользователь!
    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.

    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий

    27 декабря 2012 г. 10:13
  • Тема переведена в разряд обсуждений по причине отсутствия активности

    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий

    9 января 2013 г. 5:42
    Модератор
  • Попробовать нужно, в первую очередь, применить данное обновление.

    9 января 2013 г. 5:46
    Модератор
  • the update is not applicable to your computer. Такая ошибка при попытке данное обновление поставить.

    Обновление биоса и драйверов не помогло. Проблема осталось. До сих пор, гостевые виртуальные машины периодически загружают процессор до 100%.

    24 января 2013 г. 1:11
  • В общем, если кому интересно, поставил в настройках виртуальной машины галочку, где указывается о том что, процессоры у точек кластера разные. Хотя они одинаковые, но вроде, как, помогло - уже почти 2 недели никаких проблем нет. Похоже, что уже и не появится.
    8 февраля 2013 г. 0:36
  • В общем, если кому интересно, поставил в настройках виртуальной машины галочку, где указывается о том что, процессоры у точек кластера разные. Хотя они одинаковые, но вроде, как, помогло - уже почти 2 недели никаких проблем нет. Похоже, что уже и не появится.
    Всё, что делает этот чекбокс - ограничивает набор доступных для использования инструкций CPU. Таким образом - производительность в ряде случаев может существенно снизиться, но если вас устраивает на текущей платформе - why not?
    8 февраля 2013 г. 6:46
    Отвечающий
  • да, у нас теперь всё хорошо, уже больше месяца. Никто никогда не жалуется на тормоза. :) Надеюсь кому то в похожей ситуации поможет.
    28 февраля 2013 г. 4:18