none
5.1.1 User unknown (in reply to RCPT TO command) RRS feed

  • Вопрос

  • Доброго дня!

    Домен на 400 пользователей, два DC на win2008. 

    Почта на Exchange 2007 - 1 EDGE  сервер + 1 HUB/Mailbox/ClientAccess сервер

    Раньше один из DC стоял на том же сервере, что и HUB-сервер. Был осуществлён перенос DC на отдельный сервер.

    После этого возникла проблема - старые пользователи работают корректно, а новые не могут получать почту с внешних адресов. Может быть мне нужно было что-то ещё сделать после переноса DC?

    24 июля 2012 г. 10:43

Ответы

    1. Удалите пограничную подписку в консоли управления Exchange.
    2. Удалите пограничную подпсику на Edge сервере.
    3. Переподпишите Edge сервер.

    Подробней об Edge подписке читайте тут

    Ваша проблема в том, что ваш Edge как бы до сих пор общается со старым Hub транспортом (в вопросах синхронизации пользователе) и соответвенно не получал новой информации со времени удаления старого сервера.

    • Помечено в качестве ответа sannyhome 24 июля 2012 г. 14:30
    24 июля 2012 г. 12:02
  • Решился вопрос.

    Почему-то после синхронизации отвалилась "служба учётных данных microsoft". Включил - всё заработало.

    • Помечено в качестве ответа sannyhome 24 июля 2012 г. 14:30
    24 июля 2012 г. 14:29

Все ответы

  • Опишите более подробней что куда идет и где затыкается ваша почта.

    Вы немного ошиблись веткой, все же здесь обсуждается Exchange 2010, а предыдущие версии в другой ветке.

    24 июля 2012 г. 10:52
  • Да, случайно перепутал ветки.

    Для старых пользователей всё работает корректно. Для новых - почта внутри организации работает нормально, наружу отправляется тоже нормально, а вот когда внешний отправитель пишет письмо на внутренний адрес, он получает в ответ: "5.1.1 User unknown (in reply to RCPT TO command)".  Затык, похоже, на EDGE, что тот, почему-то не видит новых пользователей.

    24 июля 2012 г. 11:12
  • 1. Включите подробное логирование на коннектора полоучение на Edge сервере чтобы удостовериться что это точно Edge отбрасывает письма.

    2. Посмотрите в сторону Edge синхронизации. Возможно Hub транспорт не передает данные о новых сотрудниках. Соответсвенно Edge ничего о них незнает и футболит письма.

    24 июля 2012 г. 11:25
  • Подписку оформите заново.

    Сазонов Илья http://isazonov.wordpress.com/

    24 июля 2012 г. 11:28
    Модератор
  • Логирование включил.

    Как проверить, передаёт ли Hub транспорт данные?


    В догонку - В логах есть такая запись в C:\Program Files\Microsoft\Exchange Server\TransportRoles\Logs\ProtocolLog\SmtpReceive:

    EDGE,08CF3175E8F41327,8,XXX.XXX.XXX.XXX:25,77.246.230.9:39989,<,RCPT TO: <name@domain.ru>,
    2012-07-24T07:15:53.552Z,EDGE\Default internal receive connector

    name - имя пользователя, который почту не получает
    • Изменено sannyhome 24 июля 2012 г. 11:59
    24 июля 2012 г. 11:46
  • Пограничную подписку? Оформлял
    24 июля 2012 г. 11:49
    1. Удалите пограничную подписку в консоли управления Exchange.
    2. Удалите пограничную подпсику на Edge сервере.
    3. Переподпишите Edge сервер.

    Подробней об Edge подписке читайте тут

    Ваша проблема в том, что ваш Edge как бы до сих пор общается со старым Hub транспортом (в вопросах синхронизации пользователе) и соответвенно не получал новой информации со времени удаления старого сервера.

    • Помечено в качестве ответа sannyhome 24 июля 2012 г. 14:30
    24 июля 2012 г. 12:02
  • Как долго обычно идёт репликация? После переподпиывания внешние адресаты, при отправке, как на старых, так и на новых пользователей, получают  5.7.1 Unable to relay (in reply to RCPT TO command)
    • Изменено sannyhome 24 июля 2012 г. 12:28
    24 июля 2012 г. 12:28
  • Запустите test-edgesyncronization и посмотрите есть ли ошибки

    24 июля 2012 г. 12:33

  • [PS] C:\windows\system32>Test-EdgeSynchronization


    Name                        : EDGE
    LeaseHolder                 :
    LeaseType                   : None
    ConnectionResult            : Succeeded
    FailureDetail               :
    LeaseExpiry                 : 01.01.0001 0:00:00
    LastSynchronized            : 01.01.0001 0:00:00
    CredentialStatus            : NotStarted
    TransportServerStatus       : NotStarted
    TransportConfigStatus       : NotStarted
    AcceptedDomainStatus        : NotStarted
    SendConnectorStatus         : NotStarted
    MessageClassificationStatus : NotStarted
    RecipientStatus             : NotStarted
    CredentialRecords           : Number of credentials 3
    24 июля 2012 г. 12:37
  • В догонку - сейчас, при тестирование конкретных пользователей, test-edgesyncronization пишет, что RecipientStatus - NotSynchronized
    • Изменено sannyhome 24 июля 2012 г. 12:43
    24 июля 2012 г. 12:42
  • Пользователя надо прописавать через smtp адрес

    Запустите Start-edgesynchronization и покажите результат.


    24 июля 2012 г. 12:51
  • Выдал ошибку

    [PS] C:\windows\system32>Start-EdgeSynchronization
    Start-EdgeSynchronization : не удается подключиться к службе синхронизации EdgeSync
    строка:1 знак:26
    + Start-EdgeSynchronization <<<<
        + CategoryInfo          : ReadError: (:) [Start-EdgeSynchronization], EndPointNotRegisteredException
        + FullyQualifiedErrorId : 7F9C6122,Microsoft.Exchange.Management.EdgeSync.SyncNowTask

    24 июля 2012 г. 12:56
  • После перезапуска службы такой результат

    [PS] C:\windows\system32>Start-EdgeSynchronization


    Result         : InProgress
    Type           : Recipients
    Name           : CN=EDGE,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Domain,CN=M
                     ,CN=Services,CN=Configuration,DC=Domain,DC=ru
    FailureDetails :
    StartUTC       : 24.07.2012 13:07:28
    EndUTC         : 24.07.2012 13:07:28
    Added          : 0
    Deleted        : 0
    Updated        : 0
    Scanned        : 0
    TargetScanned  : 0

    Result         : Success
    Type           : Configuration
    Name           : CN=EDGE,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Domain,CN=M
                     ,CN=Services,CN=Configuration,DC=Domain,DC=ru
    FailureDetails :
    StartUTC       : 24.07.2012 13:07:30
    EndUTC         : 24.07.2012 13:07:30
    Added          : 0
    Deleted        : 0
    Updated        : 0
    Scanned        : 353
    TargetScanned  : 0

    Общий результат таков - кто получал, так и получает, кто нет - по прежнему нет

    • Изменено sannyhome 24 июля 2012 г. 13:09
    24 июля 2012 г. 13:06
  • Решился вопрос.

    Почему-то после синхронизации отвалилась "служба учётных данных microsoft". Включил - всё заработало.

    • Помечено в качестве ответа sannyhome 24 июля 2012 г. 14:30
    24 июля 2012 г. 14:29