none
Изменилась тема/стиль сайта с 2010 версии на 2007 RRS feed

  • Вопрос

  • Господа, игрался с default.master через SPD. Доигрался до того что "испотилось" (изменилось) оформление в стиле 2010 на оформление в стиле 2007. Подскажите что делать? спросил бы у гугла но незнаю как сформулировать запрос.
    Aleksandr Shramko
    1 ноября 2011 г. 16:24

Ответы

Все ответы

  • Попробуйте так:

    SharePoint 2010 – Изменение версии интерфейса с помощью PowerShell - biogenez.wordpress.com/2011/09/08/sharepoint-2010-modifying-ui-version-in-powershell/

    Ещё вот это можно почитать:

    Understanding Visual Upgrade in SharePoint 2010 - msdn.microsoft.com/en-us/library/gg454789.aspx

    2 ноября 2011 г. 5:05
  • Применил на 4-ю версию интерфейса, но получаю ошибку. Если вернуть на 3-ю то интерфейс работает. Походу что-то с рибоном случилось((

    Value cannot be null.
    Parameter name: ribbon

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentNullException: Value cannot be null.
    Parameter name: ribbon

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace:

    [ArgumentNullException: Value cannot be null.
    Parameter name: ribbon]
       Microsoft.SharePoint.WebControls.RibbonTrimmer..ctor(SPRibbon ribbon) +21401702
       Microsoft.SharePoint.WebControls.SPPageStateControl.OnInit(EventArgs e) +288
       System.Web.UI.Control.InitRecursive(Control namingContainer) +143
       System.Web.UI.Control.AddedControl(Control control, Int32 index) +271
       Microsoft.SharePoint.WebPartPages.WikiEditPage.OnLoad(EventArgs e) +274
       System.Web.UI.Control.LoadRecursive() +66
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2428
    

    Aleksandr Shramko
    2 ноября 2011 г. 7:36
  • Попробуйте откатить страницы, которые меняли в SPD.
    2 ноября 2011 г. 7:40
  • Откатился до самой первой версии, но результат тот же


    Aleksandr Shramko
    2 ноября 2011 г. 8:03
  • Если вы ничего больше не меняли, кроме как default.master - то попробуйте нажать правой кнопкой по default.master и выберите Reset to Site Definition (так в англ. версии).
    2 ноября 2011 г. 8:11
  • Пробовал, таже история(( Впринеципе среда тестовая. Началось все с того что захотелось мне в мастерпэдж WebPart загнать, но не получилось, все время ругалось что мастерпэдж содержать вебпарт не может, но я был не умолим ))) вот и доигрался. Так что я думаю проще новый узел развернуть и в мастерпэдж вебпарты больше не засовывать.

    Спасибо за ответы!


    Aleksandr Shramko

    2 ноября 2011 г. 8:24
  • Что-нибудь ещё меняли кроме этого файла?
    2 ноября 2011 г. 8:27
  • Ничего не менял. Я в панель быстрого запуска хотел добавить возможность добавления веб-частей пытался встваить примерно такой код (скопировал на быструю руку)

    				<tr>
    					<td id="_invisibleIfEmpty" name="_invisibleIfEmpty" colspan="3" valign="top" width="100%"> 
    					<WebPartPages:WebPartZone runat="server" Title="loc:Footer" ID="Footer" FrameType="TitleBarOnly"><ZoneTemplate></ZoneTemplate></WebPartPages:WebPartZone> </td>
    				</tr>
    
    

    в это место

    				<asp:ContentPlaceHolder id="PlaceHolderLeftActions" runat="server">вот сюда пытался вставить</asp:ContentPlaceHolder>
    

    Но после сохранения и обновления появились траблы.

    Пытался даже с другого шарика мастерпэдж подкинуть - проблема не исчезла.

     


    Aleksandr Shramko
    2 ноября 2011 г. 9:39
  • Не работает только этот сайт? Другие коллекции? Подсайты? 
    2 ноября 2011 г. 9:59
  • http://sharepoint3:4000/ - рутовый сайт коллекции, на него зайти немогу, возникает ошибка

    http://sharepoint3:4000/tasks - дочерний сайт, тут все ОК, как в 10 стиле так и в 07.

    Дочерние сайты работаю нормально в стиле 2010 и другие коллекции тоже работают. Походу, ошибка возникает только на рутовом сайте одной коллекции, который я сообственно и пытался изменить


    Aleksandr Shramko
    2 ноября 2011 г. 10:10
  • Еще информация: есть у меня вебчасть которая мониторит изменеия на сайте так вот в ней выплыло что был изменен файлик Vint1011-65001.css и удален объект Vintage (в то время когда я эксперементировал). Может причина в них?
    Aleksandr Shramko
    2 ноября 2011 г. 10:18
  • Этот файл скорее всего относится к теvе Vintage для SharePoint. Причём эта тема для SharePoint 2010 с UIVersion = 3, т.е. когда у вас интерфейс для 2007. Темы эти хранятся в %Program Files%\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\THEMES.

    Вот что-то с темами видимо и намудрили. 

    Почитайте здесь -

    http://books.google.ru/books?id=rTBgroiWAesC&pg=PT211&lpg=PT211&dq=sharepoint+14%5CTEMPLATE%5CTHEMES+folder&source=bl&ots=mH1A7TJy4D&sig=GIfCPLOlJrongG5gpuYJhdItmsk&hl=ru&ei=gB-xTuXaEIWF8gOZ69XFAQ&sa=X&oi=book_result&ct=result&resnum=6&ved=0CE0Q6AEwBQ#v=onepage&q=sharepoint%2014%5CTEMPLATE%5CTHEMES%20folder&f=false

    2 ноября 2011 г. 10:51