none
Forefront TMG проблема с установкой NLB RRS feed

  • Вопрос

  • Уважаемые эксперты, помогите, пожалуйста, решить мою проблему.

    2 виртуальных сервера на 2-х площадках Hyper-v Windows 2008 R2. На виртуальных серверах установлена ОС Windows 2008 R2, Forefront TMG SP1. У каждого сервера 2 сетевых адаптера - "Internal", "External"; на каждом сетевом адаптере установлена настройка "Enable Spoofing".

    Пытаюсь настроить NLB на внутреннем интерфейсе одного из серверов:

    1. Устанавливаю службу NLB.

    2. В консоли TMG включаю "NLB Integration", прописываю адрес NLB для внутренней сети, режим работы Unicast.

    Все начинает работать - пингуется адрес NLB кластера, работает интернет, но после перезагрузки сервера "падают" все службы TMG, кроме "Microsoft Forefront TMG Storage" с ошибкой:

    "The Microsoft Forefront TMG Control service terminated with service-specific error The data is invalid.."

    Также в логах появляется следующая ошибка:

    "Failed to configure Network Load Balancing to work with Forefront TMG."

     

    2 ноября 2011 г. 4:42

Ответы

  • Нет, оба сервера входят в Enterprise.

    Проблема решилась интересным образом :).

    1. Отключил NLB в консоли TMG, удалил службу NLB.

    2. Обновил TMG на обоих серверах до SP2.

    3. Установил службу NLB.

    4. В консоли TMG включил NLB для внешней сети на одном сервере, потом на другом сервере. Проверил, работает.

    5. Включил NLB для внутренней сети на одном сервере, потом на другом.

    Итог: NLB заработала на обоих серверах, на обеих сетевых картах.

     



    • Помечено в качестве ответа mralexei 3 ноября 2011 г. 11:01
    • Изменено mralexei 3 ноября 2011 г. 11:02
    3 ноября 2011 г. 11:01
  • Столкнулся с данной проблемой при настройке нового сервера.

    Все сервисы Forefront не запускаются из-за сервиса "Microsoft Forefront TMG Control", который "падает" с ошибкой "The Microsoft Forefront TMG Control service terminated with service-specific error The data is invalid..".

    С помощью утилиты ProcMon выяснил, что сервис "падает" после обращения к параметру реестра

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WLBS\Parameters\Global]
    "EnableTcpNotification"

    В реестре такого параметра не было, после создания данного параметра "EnableTcpNotification"=dword:00000002, все сервисы заработали нормально.

    • Помечено в качестве ответа mralexei 13 марта 2012 г. 5:33
    13 марта 2012 г. 5:33

Все ответы