none
ARR 3.0 не перенаправляет на SharePoint2013 RRS feed

  • Вопрос

  • Здравствуйте, помогите пожалуйста с ARR 3.0, очень срочно нужна помощь.

    Имеется Windows Server 2012, 2 сетевые карты, IIS 8, ARR 3.0 (пробовал 2.0 и 2.5, одно и то же), SharePoint 2013.

    При перенаправлении с ARR 3.0 на сервер SharePoint (который находится в локальной сети с внутренним IP), ARR перенаправляет запросы (используется метод Rewrite) на SharePoint, открывается форма ввода Логина/Пароля, но при вводе правильной учетной записи с паролем и нажатии кнопки ОК, окно исчезает и открывается заново, так происходит бесконечно.

    Просьба помочь, вопрос очень срочный, близятся конечные сроки сдачи проекта и проблема остается без решения уже долгое время, в интернете ничего найти не удается.

    11 ноября 2013 г. 19:44

Ответы

Все ответы

  • Авторизация Kerberos или NTLM? Проблема изначально или началась после каких-то изменений?
    12 ноября 2013 г. 8:34
  • Авторизация NTLM. Изначально пытался настроить на ARR 2.5, выходила ошибка 502 ("сервер вернул недопустимый ответ"), нашел в интернете информацию что в ARR существует баг и для этого есть исправление, но я решил сразу обновить её до версии 3.0, а далее начала выходить эта проблема со входом.

    Поправка к моему предыдущему описанию с процедурой входа на сайт: окно ввода логина/пароля выходит только 3 раза, после этого окно исчезает, просто остается белая страница (ничего не зависает), при обновлении страницы, снова выходит окно авторизации и все повторяется сначала.

    Кстати, а может ли это быть из-за того что данные логина и пароля отправляются в зашифрованном виде и не проходят через прокси-сервер ARR?

    13 ноября 2013 г. 15:00
  • Есть ли какие-нибудь варианты или теории как это можно исправить?

    14 ноября 2013 г. 20:05
    • Предложено в качестве ответа Elina Lebedeva 19 ноября 2013 г. 7:33
    • Помечено в качестве ответа Elina Lebedeva 20 ноября 2013 г. 7:04
    15 ноября 2013 г. 7:24