none
Принтеры на терминальном сервере! RRS feed

  • Вопрос

  • Добрый день, уважаемые гуру =)

    AD режим - 2003, 2 DC - 2003 и 2008.

    Есть терминальный сервер на 2008 r2 standard вынесен в отдельный OU.  На этот OU слинкован GPO с включенным LoopBack  в режиме Replace. Подключаю принтеры через новые CSE для всех терминальных пользователей, Action выбираю Create.

    Принтеры добавляются - проблем никаких, но вот как удалить такой принтер? Если в Action выбрать Delete и выбрать принтер, удаление не происходит.

    Пробовал включать на вкладке Common опцию "Remove this item when is no longer applied", она тоже не удаляет принтер если убрать его из списка подключаемых.

    Подскажите что не так? :)


    13 сентября 2012 г. 12:47

Ответы

Все ответы

  • А что в логах? Ошибок исполнения CSE нет?

    Сазонов Илья http://isazonov.wordpress.com/

    14 сентября 2012 г. 4:40
    Модератор
  • Значит происходит так :

    Первый вход пользователя - создаются принтеры в "Устройства и принтеры" (В GPO стоит Create)

    Второй вход пользователя - все остается в том же виде (В GPO стоит Create), в Event (Application):

    Элемент предпочтения пользователь "PRN101-xxxxx" в объекте групповой политики "Terminal_Policies {B3ED0647-E2C0-4BC5-A540-893FD745D62D}" не применен по причине ошибки с кодом "0x8007000a Ошибка в среде." Эта ошибка была отключена.

    Элемент предпочтения пользователь "PRN102-xxxxx" в объекте групповой политики "Terminal_Policies {B3ED0647-E2C0-4BC5-A540-893FD745D62D}" не применен по причине ошибки с кодом "0x80070bc4 Не найдено ни одного принтера." Эта ошибка была отключена.

    Принтеры работают все нормально.

    Затем тестирую удаление - на DC в GPO меняю Create на Delete, захожу снова в учетку - в Евентах тишина, в System написано что GPO успешно применена. Принтеры как были так и есть. Может где-то в других местах смотреть надо?

    Пробовал включать Delete All Shared Printer Connections - тот же результат.


    14 сентября 2012 г. 5:29
  • Посмотрел логи в Applications & Services-Microsoft-Windows-Group Policy-Opertional

    Никаких ошибок или предупреждений нет...

    14 сентября 2012 г. 5:51
  • gpupdate /force  пробовали?

    Сазонов Илья http://isazonov.wordpress.com/

    • Помечено в качестве ответа Dmitry_Vasilyev 14 сентября 2012 г. 6:12
    14 сентября 2012 г. 5:59
    Модератор
  • В этом и была проблема, видимо я не учел что политика все-таки скорее компьютерная чем пользовательская. Огромное спасибо за помощь :)
    14 сентября 2012 г. 6:13