none
Периодически недоступен autodicover RRS feed

  • Общие обсуждения

  • Добрый день, коллеги!

    Проблема такая - в каких то пока не понятных случаях не работает autodicover, не получается автоматически сконфигурировать outlook. Выдает ошибку вида - необходимо постоянное подключение к серверу. При этом, если настроить вручную, то потом проверка автоконфигурации выдает ошибки. Сейчас объясню на примере:

    Вот я попытался настроить тестовую учетку в терминале, все прошло ок. Дальше, пробую сделать проверку автоконфигурации, и все проходит ОК

    Дальше, я даже не закрываю это окно и снова жму Проверка и уже ошибки(там просто в разных частях журнала записи - я последовательно несколько скринов приложу):

    Вижу что httpStatus=404, но почему? Если через IE зайти на https://autodiscover.domain.local/autodiscover/autodiscover.xml - я стабильно его открываю. Насколько я знаю - это страничка говорит о том, что все работает корректно.

    В event viewer на почтовом сервер записей об ошибках нет. Test-outlookconnectivity, test-outlookwebservices проходит без ошибок. Да, при запросе Get-AutodiscoverVirtualDirectory у меня в iternaluri пусто, но опятьтаки - для внутренних клиентов это ничего не должно решать, т.к. они всеравно обращаются к dns.

    Собственно, что еще можно посмотреть, чтобы определить в чем суть проблемы?

    Спасибо!

    31 июля 2018 г. 8:46

Все ответы

  • Это видел. У меня по пути

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoDiscover\Boot

    ключа Boot нет

    1 августа 2018 г. 14:49
  • Что у Вас выдает Get-AutodiscoverVirtualDirectory | fl

    У Вас не само подписанный сертификат?

    1 августа 2018 г. 14:55
  • На одном сервере сертификат самоподписанный, на втором - подписанный корпоративным СА.

    Вот вывод команды

    20 августа 2018 г. 8:27
  • Ну, раз серверов у вас два, а ошибка проявляется неустойчиво, то логично предположить, что ошибка - в конфигурации одного из двух серверов. Во-всяком случае, этот факт нужно проверить.

    Как я понял (к сожалению, первый скриншот малоинформативен), у вас автообнаружение настроено через имя autodiscover.вашдомен.ru, и это имя - общее для обоих серверов (либо разрешается в IP обоих серверов, либо в IP балансировщика - не важно).

    Для начала проверьте, что это имя разрешается только в нужный(ые) IP, и что для всех этих IP (или тех IP, которые настроены на балансировщике в качестве IP серверов) на сереверах Exchange есть привязка Default Web Site в IIS на 443 порт (привязка должна быть либо по самому этому IP, либо по всем неназначенным IP, и при этом нет другого сайта, у которого привязка - по этому IP).

    Если тут всё в порядке, то для дальнейшей проверки добавьте на клиенте это имя с адресом одного из серверов в файл hosts и выполните проверку автоообнаружения (столько раз, сколько сочтете нужным). Затем поменяйте имя в hosts на имя другого сервера и повторите проверку(и) автообнаружения. Если наткнетесь устойчиво возникающую ошибку только на одном из серверов, то ошибка локализована, и с ней можно разбираться более предметно.


    Слава России!

    20 августа 2018 г. 8:58