none
Не могу создать/отредактировать план обслуживания базы RRS feed

  • Вопрос

  • Здравствуйте!
    Вопрос, конечно, пару раз поднимался здесь, но ответ на него все-таки не нашел....
    Windows 2008 Enterprise Server x64 + Microsoft SQL Server Standard Edition (64-bit) SP3 (10.0.5500.0)
    В SQL Server Management Studio пытаюсь добавить новый план обслуживания:
    нажимаю "Создать план обслуживания" - никакой ответной реакции: ничего не открывается,
    ни ошибки, ни в логах записей, вообще никакого ответа....
    Через мастер планов обслуживания получается создать, но в итоге не могу его отредактировать:
    так же щелкаю два раза по созданному плану, а в ответ - тишина.

    Пробовал переустановить через восстановление установленного SQL,
    также  пробовал установить SQL Server Management Studio на другую машину и с неё
    попробовать открыть план - такой же нулевой эффект (хотя одному из соратников помогло)

    В чем дело? Может кто сталкивался?!

    8 июня 2012 г. 13:25

Ответы

  • А попробуйте посмотреть, стоят ли у вас компоненты BIDS и Integration Services на вашей машине. Но это я так, чисто догадка, т.к. по сути дела план обслуживание - это SSIS пакет. Может как раз вашему товарищу и помогла переустановка, при которой что-то установили, чего раньше не было.


    http://olontsev.ru/


    • Изменено Sergey OlontsevMVP 9 июня 2012 г. 6:24 орфографическая ошибка
    • Помечено в качестве ответа Dmitry Davydov 6 июля 2012 г. 9:05

Все ответы

  • В чем дело? Может кто сталкивался?!

    К сожалению слишком мало информации, что-то пишется в лог? какие-то ошибки при этом происходят?

    А вообще, план обслуживания - это "чёрный ящик", вас устраивает, что сервер будет что-то там делать, что вы не знаете (не понимаете)!?

    Лично я бы свои сервера обслуживал исключительно скриптами, которые я написал...ИМХО!!!


    http://www.t-sql.ru

    8 июня 2012 г. 19:45
    Отвечающий
  • Я ж говорю - вообще никакой реакции... Ни ошибок, ни в логах SQL, ни в системных логах...

    Ну а по поводу черного ящика... Что ж тама черного-то?! Всё понятно, и даже скрипты все можно посмотреть...

  • А попробуйте посмотреть, стоят ли у вас компоненты BIDS и Integration Services на вашей машине. Но это я так, чисто догадка, т.к. по сути дела план обслуживание - это SSIS пакет. Может как раз вашему товарищу и помогла переустановка, при которой что-то установили, чего раньше не было.


    http://olontsev.ru/


    • Изменено Sergey OlontsevMVP 9 июня 2012 г. 6:24 орфографическая ошибка
    • Помечено в качестве ответа Dmitry Davydov 6 июля 2012 г. 9:05
  • Установка BIDS и Integration Services помогает.
    6 ноября 2012 г. 16:27
  • Установка BIDS и Integration Services помогает.

    К сожалению, не помогло.

    Аналогичная ситуация: Sql 2014 на 2012 R2.

    При попытке открыть план обслуживания вылетело окошко с инфой о том, что чего то не хватает для открытия. По ошибке нажал "не показывать" и все - больше окошко не показывается, план обслуживания не открывается. Его можно удалить или создать через мастер, но существующий изменить нельзя. Нигде никаких ошибок нет. 

    Установил Integration Services и BIDS. Т.к. согласно инфе  BIDS теперь не входит в состав SQL2014 скачал русскую версию отсюда Microsoft SQL Server Data Tools ― Business Intelligence для Visual Studio 2013

    Установка + ребут = эффекта нет. Есть еще мысли как починить ?

    5 февраля 2016 г. 13:13
  • К сожалению, не помогло.

    Аналогичная ситуация: Sql 2014 на 2012 R2.

    Должны быть установлены "Средства управления - полный набор", а не только "Средства управления - основные". Это проверено. Если уже установлены "основные", удалите их и поставьте и "основные", и "полный набор" заново - этот совет присутствует где-то на англоязычных форумах, но я сам не проверял.

    Глеб Рошаль

    • Предложено в качестве ответа Павел Lipser 24 февраля 2016 г. 7:36
    23 февраля 2016 г. 23:13
  • Именно это и помогло. Спасибо!
    24 февраля 2016 г. 7:37
  • К сожалению, не помогло.

    Аналогичная ситуация: Sql 2014 на 2012 R2.

    Должны быть установлены "Средства управления - полный набор", а не только "Средства управления - основные". Это проверено. Если уже установлены "основные", удалите их и поставьте и "основные", и "полный набор" заново - этот совет присутствует где-то на англоязычных форумах, но я сам не проверял.

    Глеб Рошаль

    Спасибо, добрый человек - уже не знал куда копать.

    • Изменено on.Petr 10 декабря 2018 г. 20:03
    10 декабря 2018 г. 20:03