none
Проблема с правилами в Outlook 2013 RRS feed

  • Вопрос

  • Коллеги,

    недавно внедрили для пользователей Outlook 2013 и столкнулись с проблемой сохранения правил.

    Ситуация следующая: некоторым пользователям требуется большое количество правил в Outlook. Когда они достиагли предела объема для сохранения сообщений им выдавалось сообщение о том, что сохранить правило не удается. Для увеличения объема на Exchange 2010 выполнялась команда

    Get-Mailbox '<user>' | set-mailbox -rulesquota 256KB

    В результате новые правила у пользователей сохранялись и никаких проблем не проявлялось в Outlook 2010. После перехода на Outlook 2013 у всех пользователей, у которых правил больше, чем на 64КБ, при открытии меню "Управление правилами и оповещениями..." появляется сообщение: "Правила на этом компьютере противоречат правилам Microsoft Exchange. Сохранить можно только один набор правил. Как правило, сохраняются правила с сервера. Какие правила сохранить?".

    На тестовом пользователе проблема была воспроизведена, причем выяснилось, что если количество активных на текущий момент правил помещается в квоту в 64КБ, то сообщение выдаваться не будет. Для того, чтобы было понятнее о чем идет речь привожу ниже проведенное тестирование:

    1. Создан тестовый пользователь, ему создан почтовый ящик (rulesquota = 64KB);
    2. Тестовому пользователю созданы правила, таким образом, что больше правил он сохранить не может (достигнут предел квоты), при этом сообщение о том, что правила противоречат правилам Exchange не появляется;
    3. На сервере Exchange расширена квота (rulesquota = 256KB);
    4. Пользователю добавлено и активировано новое правило, меню "Управление правилами и оповещениями..." закрыто;
    5. При последующем открытии меню, сообщение о противоречиях между правилами появляется каждый раз, даже после перезапуска Outlook;
    6. После отключения правила (не удаления, а отключения — снята галочка напротив правила), последующего закрытия и открытия меню управления правилами, проблема не проявляется и сообщений о противоречиях не появляется.

    Вдобавок, если правил больше, чем при базовой квоте правил, то правила не применяются и обработка сообщений не происходит.

    Предположили, что это может быть исправлено в Exchange 2010 SP3, но установка SP3 не исправила ситуацию. Возможно это как-то связано с настройками Outlook 2013. Может быть кто-то сталкивался с подобной ситуацией?

    Как вариант, устроило бы решение, при котором в Outlook будут по умолчанию сохраняться правила клиента, а пользователь не будет получать сообщений о выборе набора правил. Ну и конечно же обработка сообщений должна происходить, куда же без этого.


    20 марта 2013 г. 9:52

Ответы

  • Что ж... Установил вчера обновление, предоставленное технической поддержкой, на наш рабочий сервер. У проблемных пользователей проблема исчезла. Требует дальнейшего мониторинга, конечно, но проблема не проявляется.

    Во время установки данное обновление именовалось как Exchange 2010 SP3 Interim Update (KB2840454), так что в случае подобных проблем рекомендую обратиться в техническую поддержку за этим обновлением.

    • Помечено в качестве ответа george.pozdnyakov 31 июля 2013 г. 12:40
    31 июля 2013 г. 12:40

Все ответы

  • В Outlook 2010 проблема не проявляется. Тестовый пользователь имеет возможность запускать Outlook 2010 с терминального сервера (Cirix XenApp). Outlook 2013 установлен у пользователя локально.

    Если запустить Outlook 2010 с терминального сервера и включить правила сверх лимита в 64КБ, никаких сообщений при открытии меню "Управление правилами и оповещениями..." не появляется.

    Если после этого закрыть Outlook 2010 и запустить Outlook 2013 — проблема проявляется вновь.
    3 апреля 2013 г. 6:23
  • На локально установленном Outlook 2010 проблема также не проявляется.

    8 апреля 2013 г. 6:19
  • Нет, не обратились. Вопрос в том, есть ли у кого-либо еще такая проблема или она есть только у нас.
    9 апреля 2013 г. 5:58
  • Инициировал кейс в техподдержке Microsoft. Собственно, по мере решения вопроса отпишусь в этой теме.
    22 апреля 2013 г. 8:40
  • Коллеги,

    убедительная просьба, не закрывайте данную тему и не отмечайте в качестве ответа сообщения, которые им не являются. В данный момент по этому вопросу я работаю с технической поддержкой Microsoft.

    Оказалось, что подобная проблема проявляется и при использовании Exchange 2013. Был получен Interim Update для Exchange Server 2010 SP3, которое, вероятно, решило проблему. Но появились другие, которые связаны с ней.

    Думаю, что результаты этой работы с технической поддержкой будет интересны не только мне, но и кому-нибудь другому.

    4 июня 2013 г. 12:28
  • Здравствуйте,

     Будем ждать результаты Вашей работы с технической поддержкой Microsoft- это будет полезно и для других пользователей!


    Уважаемые участники форума. У меня к Вам просьба: если какой-нибудь из ответов помог Вам решить Вашу проблему, пожалуйста, не забывайте отмечать его. Таким образом, Вы поможете и другим пользователям, у которых возникла схожая проблема! Спасибо!

    Модератор
  • Здравствуйте!

    Есть ли результат после Вашего обращения в службу поддержки, и если да не могли ли бы Вы поделиться решением?

     


    Уважаемые участники форума. У меня к Вам просьба: если какой-нибудь из ответов помог Вам решить Вашу проблему, пожалуйста, не забывайте отмечать его. Таким образом, Вы поможете и другим пользователям, у которых возникла схожая проблема! Спасибо!

    29 июля 2013 г. 14:02
    Модератор
  • На текущий момент с помощью Interim Update проблема устранена в тестовой сети. На этой неделе предполагаю внедрить в рабочую среду, чтобы проверить, что это обновление действительно устраняет проблему.
    29 июля 2013 г. 14:09
  • Спасибо за обновление!

    Будем ждать результатов внедрения!


    Уважаемые участники форума. У меня к Вам просьба: если какой-нибудь из ответов помог Вам решить Вашу проблему, пожалуйста, не забывайте отмечать его. Таким образом, Вы поможете и другим пользователям, у которых возникла схожая проблема! Спасибо!

    30 июля 2013 г. 6:07
    Модератор
  • Что ж... Установил вчера обновление, предоставленное технической поддержкой, на наш рабочий сервер. У проблемных пользователей проблема исчезла. Требует дальнейшего мониторинга, конечно, но проблема не проявляется.

    Во время установки данное обновление именовалось как Exchange 2010 SP3 Interim Update (KB2840454), так что в случае подобных проблем рекомендую обратиться в техническую поддержку за этим обновлением.

    • Помечено в качестве ответа george.pozdnyakov 31 июля 2013 г. 12:40
    31 июля 2013 г. 12:40