none
Не стартует Microsoft Exchange Service Host RRS feed

  • Вопрос

  • После установки апдейтов на Exchange Server 2007 Std, установленный на Windows Server 2003 R2 Std, перестали стартовать многие службы Exchange. Вручную запустить удалось все, за исключением Microsoft Exchange Service Host и Наблюдение Microsoft Exchange.

    В журнале - ошибки:

    Code Snippet

    Тип события: Ошибка
    Источник события: Service Control Manager
    Категория события: Отсутствует
    Код события: 7000
    Дата:  21.05.2008
    Время:  11:32:34
    Пользователь:  Н/Д
    Компьютер: MATRIX
    Описание:
    Сбой при запуске службы "Microsoft Exchange Service Host" из-за ошибки
    Служба не ответила на запрос своевременно.

    Дополнительные сведения можно найти в центре справки и поддержки, в "http://go.microsoft.com/fwlink/events.asp".


    Тип события: Ошибка
    Источник события: Service Control Manager
    Категория события: Отсутствует
    Код события: 7009
    Дата:  21.05.2008
    Время:  11:32:34
    Пользователь:  Н/Д
    Компьютер: MATRIX
    Описание:
    Таймаут (30000 мс) ожидания для подключения службы Microsoft Exchange Service Host.

    Дополнительные сведения можно найти в центре справки и поддержки, в "http://go.microsoft.com/fwlink/events.asp".

     

     

    В Интернете только нашел совет проверить связь с  http://crl.microsoft.com/pki/crl/products/CSPCA.crl - проходит нормально.
    • Перемещено Hengzhe Li 18 марта 2012 г. 6:14 forum merge (От:Exchange Server 2007)

Ответы

Все ответы

  • Пути, указанного во 2 методе, на моем сервере нет (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\OID\ EncodingType 0\CertDllCreateCertificateChainEngine\Config )

    И вообще не понятно - почему надо уменьшать тайм-ауты? (Configure the URL retrieval time-out values that are used by CryptoAPI to a lower value)

    То, что рекомендуют в 3 методе - не помогло.

  •  

    Открой NAT на Microsoft для сервера.
  •  Ilya Lushnikov написано:

    Пути, указанного во 2 методе, на моем сервере нет (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\OID\ EncodingType 0\CertDllCreateCertificateChainEngine\Config )


    Пути нужно создать. Я все сделал как написано, все заработало.
  •  kpmedia написано:

     

    Открой NAT на Microsoft для сервера.

    Читаю второй раз твой ответ и до сих пор не понял, о чем ты. Будь так добр, поясни подробнее.
  • Совет из KB помог, метод 2.

    По началу по невнимательности неправильно значения параметров вбил.

    Может кто-то пояснить, почему надо именно уменьшать таймауты по CryptoAPI?

  •  Denis_Urasov написано:
     kpmedia написано:

     

    Открой NAT на Microsoft для сервера.


    Читаю второй раз твой ответ и до сих пор не понял, о чем ты. Будь так добр, поясни подробнее.

     

    +1 .  Мне то же интересно. Явно этот способ проще, чем kb. :-)

  •  Denis_Urasov написано:
     kpmedia написано:

     

    Открой NAT на Microsoft для сервера.


    Читаю второй раз твой ответ и до сих пор не понял, о чем ты. Будь так добр, поясни подробнее.

     

     

    ProxyCfg.exe

    и

    ProxyCfg.exe -u

     

    на сервере Exchange дают разный результат. Сервис не запускается из-за того, что не может достучаться да Microsoft. Открыв NAT для сервера Exchange можно быстро решить проблему запуска сервиса.

     

    Ну а затем уже, спокойно, разбираться с причинами. Т.е. я написал быстрое "обходное решение".

  •  kpmedia написано:

    Сервис не запускается из-за того, что не может достучаться да Microsoft.

    Так это же самое прописано в kb944752

     

     kpmedia написано:

     Открыв NAT для сервера Exchange можно быстро решить проблему запуска сервиса.

    Ну во первых не обязательно NAT, не у всех же сеть за NAT'ом сидит. Во вторых, если даже разрешаешь серверу Exchange достучаться до сайта MS, то все равно служба не запускается, пока в реестре не поколдуешь.

  •  Denis_Urasov написано:
     kpmedia написано:

     Открыв NAT для сервера Exchange можно быстро решить проблему запуска сервиса.

    Ну во первых не обязательно NAT, не у всех же сеть за NAT'ом сидит. Во вторых, если даже разрешаешь серверу Exchange достучаться до сайта MS, то все равно служба не запускается, пока в реестре не поколдуешь.

     

    Хм, а как еще? Или за NAT, или на честном ip, или за прокси. Есть еще какие-то варианты для почтового сервера?

    Конечно, если еще и firewall что-то стреляет, то и его подправить нужно.

     

    В общем-то, нужно чтобы при запуске сервиса у него была возможность постучаться на Microsoft и произвести проверку. У меня запустился моментально после включения NAT для этого сервера, без всяких правок реестра и т.д. Проверено на 2-х разных серверах в разное время.

  •  kpmedia написано:

    У меня запустился моментально после включения NAT для этого сервера, без всяких правок реестра и т.д.

    У меня же и у господина Ilya Lushnikov иначе, пришлось ещё в реестре править.