none
Клиентские ОС на Hyper-V тормозят RRS feed

  • Общие обсуждения

  • День добрый!

     На сервере развернут контроллер домена, на Hyper-v установлены клиентские машины Windows XP Pro SP3, присоединенные к домену.

    Работает одна машина, в режиме тестирования, и проблемы начинаются, когда пользователь обращается к файлам по сети, и не важно расположены файлы на этом же сервере, либо на другом, - при листинге папок появляются серьёзные тормоза. Виртуальная машина снабжена оперативкой 4 ГБ 2 процессора Intel Xeon E5620 2.40 ГГц. Сам процессор от этой виртуалки грузится максимум на 6%.

      Что посоветуете для ускорения работы виртуалки?

    Заранее спасибо.

    • Изменен тип Yuriy Lenchenkov 12 октября 2011 г. 12:13 отсутствие активности
    20 сентября 2011 г. 11:32

Все ответы

  • Вопрос про компоненты интеграции считаем риторическим?

    Что счетчики производительности дисковой подсистемы говорят?

    20 сентября 2011 г. 12:02
    Модератор
  • Я правильно понял, на одном сервере поднято 2 роли: AD и Hyper-V?

    Если так, то при установки контроллера домена отключается режим кэширования записи на жестком диске. Соответственно отсюда могут и идти тормоза.

    Плюс, конечно, не плохо было бы выделить отдельную сетевую карту для виртуальных машин. 

    20 сентября 2011 г. 15:22
  • Скорее всего это отключенный режим кэширования из-за установки АД. При поднятии роли АД на том физическом диске, где расположена база АД, отключается кэш. Решение правильное, но играет плохую службу, если кроме АД там есть еще что-то. Включить можно в свойствах в диспетчере устройств. Но после перезагрузки опять отключится. Чтобы включить постоянно, нужно воспользоваться ключиком реестра.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Parameters] 

    "DSA Heuristics"="10000000"

    Но лучше следовать рекомендациям и хранить базы АД на отдельном физическом диске, или все остальное не на системном физическом диске.


    Все, указанное выше, является моим личным мнением. Если Вам помогли предложенные рекомендации, пожалуйста, помечайте их, как ответ. Это поможет другим пользователям быстрее найти решение.
    20 сентября 2011 г. 15:56
  • Уважаемый пользователь!
    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    26 сентября 2011 г. 9:35
  • Попробовать отключить все offload на виртуальных машинах (в свойствах сетевого адаптера)
    29 сентября 2011 г. 12:11
  • Коллеги, я извиняюсь, за запоздалую реакцию - по некоторым причинам не смог следить за развитием топика.

    Итак, что было сделано:

    1) На клиентах отключил в сетевых интерефейсах "Планировщик QoS" и "Ответчик обнаружения топологии уровня связи"

    2) Hyper-V пустил через отдельный физический гигабитный интерфейс.

    3) Включил кэширование жесткого диска.

    Пока наблюдаю за результатами.

    4 октября 2011 г. 8:41
  • чем дело кончилось?
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    10 октября 2011 г. 12:55
  • Значит, что сейчас наблюдаю. 

    Пока из одних очевидных тормозов - это тормоз графики интерфейса, т.е. зависает меню при открытии Пуска, переключение окон. При этом сам процессор виртуальной машины грузится не сильно. И да, никаких спецэффектов графики не делалось.

     Решение пока одно - перезагрузка виртуальной машины пользователя. 

    Окончательного решения, как это победить пока не нашли.

     

    P.S.: на всем маршруте от компьютера пользователя до сервера стоят гигабитные свитчи. Все дело происходит в локальной сети.  

    17 октября 2011 г. 7:45
  • В виртуалке на XP:

    Изменить значение параметра DWORD SeparateProcess с 0 на 1, ветка HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

    пробовали?

    4 ноября 2011 г. 15:07