none
Низкая скорость работы дисков vhdx или lun. RRS feed

  • Общие обсуждения

  • Добрый день! Имеется сервер supermicro x10-drli 2 процессора 32 гигабайта памяти. Установлена ОС windows server 2012(2012R2,2016 и эти пробовал и на разном железе даже на простом гигабайте). Есть локальные диски c и d уровень райд роли не играет.  Создаем на каждом диске по одному динамическому vhdx 200Гб и подключаем их в систему. Это пусть будут диски e и f.  Любым способом заливаем файл более 10~15Гб (хоть из сети хоть с локального диска) на диск е. Если после этого файл скопировать из е в f то скорость копирования ~20-40мб/с.  Если виртуальный диск источник отключить и подключить снова, то скорость возрастает до скорости диска на котором лежит виртуальный диск (sas 15k ~ 250мб/с). С lun тоже самое только скорости дисков там больше после переподключения. Полностью обновлял систему 2012 до последних обновлений через widows update. Результата нет. Образ скачан с официального сайта ибо лицензионный. Помогите разобраться.
    18 апреля 2016 г. 14:30

Все ответы

  • Проверьте на fixed vdhx

    Сазонов Илья

    https://isazonov.wordpress.com/

    18 апреля 2016 г. 14:32
    Модератор
  • Еще интересует размер блоков на диске, где хранятся VHDX. Если отформатировать в 64к (ntfs), ситуация меняется?
    18 апреля 2016 г. 19:53
  • На фиксированнных vhd если они лежат на локальных дисках скорость нормальная, если их переложить на луны то снова 20мб\с. Размер блоков на лунах 64к (делал 4к, без разницы). Вообщем проблема с буфером.

    Ситуация: На локальном диске С (SAS 15K RAID1) есть файл около 20 гигабайт допустим test.test, копируем его средствами xcopy на LUN (FC16 SAS 10K RAID10 4диска) - диск D, скорость копирования 250МБ/с. После завершения. Копируем xcopy этот же файл но уже с диска D на диск E - LUN (FC16 SAS 7K2 RAID10 4диска).

    Скорость низкая 20БМ/с. Если копируем xcopy /J  (c отключением буфера) то скорость нормальная ~400МБ/с.

    СХД подключен через HBA Avago Emulex 16002. Обновлены прошивки СХД(подключался производитель), мной обновлена прошивка HBA, драйверы, установлены все патчи на 2012. При любых комбинациях ситуация одна и та же.

    Если диски D E сделать динамическими то все нормально работает. 2012 скачана с сайта MS( см выше).

    Остается сменить контроллер поставщик выслал контроллер qlogic fc8.  Так же к проблеме подключились производители Avago (читай LSI). Ждем. У кого какие мысли по ситуации. 

    20 апреля 2016 г. 13:12
  • Размер страйпа 128К если важно. СХД подключена к серверу напрямую без SAN коммутатора.


    • Изменено Artem1313 20 апреля 2016 г. 13:34
    20 апреля 2016 г. 13:12