none
Неправильная кодировка при пересылке писем в Outlook 2010. RRS feed

  • Вопрос

  • Здравствуйте! Имеется следующая блуждающая проблема. Иногда при пересылке писем с вложениями, пришедших извне, сбивается кодировка. Установлен Exchange 2010 SP1 и почтовые клиенты Outlook 2010, ОС Windows 7 Ent.

    Пример письма:

    ч УПЧТЕНЕООПК ЦЙЪОЙ, НХЦЮЙОБ РПТПК РТЙНЕТСЕФ ОБ УЕВС ТПМШ РТЕДУФБЧЙФЕМШОЙГЩ УМБВПЗП РПМБ, \ВПСУШ ОЕПВИПДЙНПУФЙ ДПЛБЪЩЧБФШ УЧПА УЙМХ УФПКЛПУФШ Й ГЕМЕХУФТЕНМЕООПУФШ.\ (ОЕ ЪОБА, НПЦЕФ ЬФП МЙЫОЕЕ) ч УЧПА ЦЕ ПЮЕТЕДШ ЦЕОЭЙОЩ, ПУФБЧБСУШ ВЕЪ ЧЩВПТБ, ЧЩОХЦДЕОБ ПВЕУРЕЮЙФШ УЕВЕ ЖЙОБОУПЧХА ОЕЪБЧЙУЙНПУФШ, ЪБОСФШ ДПУФПКОПЕ НЕУФП Ч УПГЙХНЕ, ОП РТЙ ЬФПН ДПМЦОБ ЛБЪБФШУС УМБВПК Й ИТХРЛПК, ДМС ФПЗП ЮФПВЩ ОТБЧЙФШУС, ФБЛ ОБЪЩЧБЕНПНХ УЙМШОПНХ РПМХ. 

    В декодере Лебедева видно, чтобы прочитать письмо, нужно поменять кодировку CP1251 → KOI8-R.

    Помогите, пожалуйста, решить!

    4 октября 2011 г. 9:53

Ответы

  • Она в SP2 RU1 будет исправленна.
    MCSE:M 2003, MCITP:EA, SA, EMA, EMA:2010
    • Предложено в качестве ответа FL0od13 21 марта 2012 г. 11:52
    • Помечено в качестве ответа ILYA [ sie ] SazonovModerator 27 марта 2012 г. 6:41
    3 февраля 2012 г. 10:08
  • Вот с отправкой от вас сообщений с такими вложениями поможет установка кодировки в UTF-8

    С пересылкой уже пришедших сообщений ничего сделать не получиться, кроме того, как убрать "автовыбор кодировки исходящих сообщений"


    Innovation distinguishes between a leader and a follower - Steve Jobs
    • Помечено в качестве ответа Yuriy Lenchenkov 11 октября 2011 г. 13:30
    5 октября 2011 г. 9:49

Все ответы

  • В заголовке нет кавычек «»?


    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    4 октября 2011 г. 12:21
    Модератор
  • Даже если есть кавычки русские, то при пересылке письма, я думаю, даже UTF-8 не спасет.


    Innovation distinguishes between a leader and a follower - Steve Jobs
    4 октября 2011 г. 12:40
  • 5 октября 2011 г. 8:41
    Модератор
  • У нас такая же проблема :(

    Обнаруживается при отправке письма в кодировке KOI8-R с вложением, в имени которого встречаются символы (®,«,») через MS Exchange 2010 SP1 клиентом Outlook 2010 с SP1 и без SP1 кодировка тела сообщения клиентом Outlook 2010 распознаётся не верно.

    Если установить кодировку полученного письма в ручную на KOI8-R тело письма начинает читаться корректно.

    При отправке письма с установленной в настройках Outlook "кодировка исходящих сообщений" Windows-1251 и снятии галочки "автовыбор кодировки исходящих сообщений" имя файла и тело письма не искажаются.

    При отправке через почтовый сервер отличный от Exchange символы (®,«,») в имени файла подменяются на подчёркивание, тело письма Outlook читает правильно.

    5 октября 2011 г. 9:46
  • Вот с отправкой от вас сообщений с такими вложениями поможет установка кодировки в UTF-8

    С пересылкой уже пришедших сообщений ничего сделать не получиться, кроме того, как убрать "автовыбор кодировки исходящих сообщений"


    Innovation distinguishes between a leader and a follower - Steve Jobs
    • Помечено в качестве ответа Yuriy Lenchenkov 11 октября 2011 г. 13:30
    5 октября 2011 г. 9:49
  • Илья, у нас именно такая проблема. Если в теме письма вставлены кавычки «», то при пересылке писем сбивается кодировка. Не подскажете в чем может быть проблема?
    • Изменено aleksandr_k 29 октября 2011 г. 21:43
    29 октября 2011 г. 21:42
  • Это не проблема - это баг :-) Про выпуск фикса не знаю.
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    30 октября 2011 г. 13:42
    Модератор
  • Илья, может быть есть хоть какая-то информация по поводу планов выпуска фикса? Для нас это очень критично.
    1 ноября 2011 г. 8:15
  • У отправителя случаем клиент SAP R3 не установлен?
    1 ноября 2011 г. 8:26
    Отвечающий
  • У нас проблема присутствует в рамках одного сервера Exchange 2010 SP1 RU6. Никаких клиентов SAP мы не используем.
    1 ноября 2011 г. 10:23
  • Для получения проблемы надо следующее:

    1 Кодировка исходящего сообщения KOI-8R (Замена на UTF-8 решает проблему)

    2 В P2 заголовке должна быть русская кавычка (все равно в теме письма или в полях From или To)

    3 В письме должно быть влоджение (все равно in-line или нет)

    4 На серверах должно быть обновление SP1 RU3 или более новое

    Клиент не принципиален.

    Фикс планируется на RU7 и на SP2 RU1.

     


    MCSE:M 2003, MCITP:EA, SA, EMA, EMA:2010
    14 ноября 2011 г. 7:53
  • Дмитрий, говоря о SP2 (он ведь еще не совсем вышел :) ), имеется в виду, что фикс будет именно в плановом RU для SP2, который выйдет через некоторое время после самого SP2?

    Судя по всему сам SP2 выйдет раньше, чем RU7 для SP1.

    14 ноября 2011 г. 9:57
  • Вы сами себе ответили :-)
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    14 ноября 2011 г. 11:12
    Модератор
  • Отлично, но это были лишь мои догадки :)
    14 ноября 2011 г. 14:05
  • Вообще сервис паки собираются по полгода: бета, тестирование, вторая бета, тестирование, кандидат, тестирование, релиз - тестирование, только потом широкая доступность. Но все это время идет работа по подготовке и выпуску новых обновлений. 
    Сазонов Илья http://www.itcommunity.ru/blogs/sie-wl/
    14 ноября 2011 г. 16:44
    Модератор
  • SP2 нам в этом году обещают. А вот RU7 думается будет уже в следующем.

    В SP2 исправленны некоторые баги, не исправленные в SP1 RU6.

    Весь список не знаю. Знаю, что наконец то будем читать описание TZ из реестра сервера, а не ресурсного файла для региональных настроек OWA.


    MCSE:M 2003, MCITP:EA, SA, EMA, EMA:2010
    18 ноября 2011 г. 17:54
  • Этому вопросу будет посвященна KB2648682
    MCSE:M 2003, MCITP:EA, SA, EMA, EMA:2010
    25 ноября 2011 г. 18:47
  • Коллеги, добрый день.
    Дмитрий - большое спасибо за информацию. Сами бьемся с проблемой. Пока безуспешно к сожалению.
    Немного дополнений к сказанному вами.
    1) Проблема не воспроизводится на клиентах Win7 64bit
    2) Проблема не воспроизводится, если не использовать подпись в теме письма (ну или использовать только текст, без графики)

    Вы случайно не знаете, в "чистом " SP2 - проблема тоже воспроизводится ? Рассматриваем вариант откатиться с RU6 на голый SP1, который нас полностью устраивал до отмены перехода времени, а потом уже накатить сразу SP2 . Ошибка сохранится?

    Или может быть есть информация, как сохранить только SP1 без RU, но обеспечить корректную работу OWA с новыми TZ(куда-то подложить какой-то файл или еще что-то) ?
    Спасибо.

     

    6 декабря 2011 г. 15:02
  • проблема сохраняется после обновления до SP2

    6 декабря 2011 г. 15:10
  • Она в SP2 RU1 будет исправленна.
    MCSE:M 2003, MCITP:EA, SA, EMA, EMA:2010
    • Предложено в качестве ответа FL0od13 21 марта 2012 г. 11:52
    • Помечено в качестве ответа ILYA [ sie ] SazonovModerator 27 марта 2012 г. 6:41
    3 февраля 2012 г. 10:08
  • Проблема действительно исчезла, после установки Update Rollup 1 for Exchange Server 2010 Service Pack 2 (KB2645995).

    • Предложено в качестве ответа Roman.Polin 26 марта 2012 г. 11:52
    21 марта 2012 г. 11:52
  • Подтверждаю, проблема исчезла после установки роллапа
    26 марта 2012 г. 14:47
  • У нас установка RU1 для SP2 проблему не решила.
    27 марта 2012 г. 14:53
  • Всем доброго времени суток. Проблема аналогичная заголовку в теме. Принудительное выставление UTF-8 для исходящих сообщений проблему не решает, сегодня поставлю RU1 для Exchange 2010 SP2, отпишусь помогло ли.
    • Изменено azhurlov 2 апреля 2012 г. 11:18
    27 марта 2012 г. 15:04
  • Проблема после установки RU1 исчезла.



    • Изменено azhurlov 2 апреля 2012 г. 11:17
    • Предложено в качестве ответа mametyevpa 5 июня 2013 г. 5:52
    2 апреля 2012 г. 11:17
  • Доброе время суток.

    RU1 не желает ставиться. Пишет ошибку с кодом 1603. Кто-нибудь с таким сталкивался?

    3 апреля 2012 г. 7:29
  • Была та же проблема когда ставил RU1 из .msp файла, при установке через WSUS всё ОК. Самому интересно, что за ошибка, но не было времени разбираться.



    • Изменено azhurlov 3 апреля 2012 г. 7:55
    3 апреля 2012 г. 7:55
  • Приветствую.

    До установки Rollup update 1 для Exchange 2010 SP2 проблема отсутствовала. Сразу же после установки стали поступать жалобы пользователей на кривые имена файлов вложений, из выявленных случаев - отправки на mail.ru, yandex.ru.

    Есть ли какие-либо "постролапные" решения?

    5 апреля 2012 г. 12:36
  • Перешли на Exchange 2010 SP2 RU4 - проблема есть. Что делать не понятно

    4 октября 2012 г. 8:20
  • Сталкивался с проблемой. Причина была следующая:
     Выяснилось, что для адресатов были созданы почтовые контакты. Те из них, для которых значение параметра "Use MAPI rich text format" было уставлено "Always" или "Use Default Settings" получали письма с кривой кодировкой. Те у кого параметр был установлен "Never" не испытывали проблем. Решением стало отключение использования MAPI rich text format для всех внешних почтовых контактов. 

    PS. проблемы наблюдались на Exchange 2010 SP2 с различными ролапами включая 4тый.

    • Изменено Max Yakunin 4 октября 2012 г. 10:06
    4 октября 2012 г. 10:04
  • Сталкивался с проблемой. Причина была следующая:
     Выяснилось, что для адресатов были созданы почтовые контакты. Те из них, для которых значение параметра "Use MAPI rich text format" было уставлено "Always" или "Use Default Settings" получали письма с кривой кодировкой. Те у кого параметр был установлен "Never" не испытывали проблем. Решением стало отключение использования MAPI rich text format для всех внешних почтовых контактов. 

    PS. проблемы наблюдались на Exchange 2010 SP2 с различными ролапами включая 4тый.

    "Use MAPI rich text format" Просьба уточнить где хранятся эти настройки ???

    6 ноября 2014 г. 9:24
  • Exchange 2010 sp3 проблема с кодировкой так же сохраняется.

    Если кто решил - поделитесь пожалуйста.

    Версия Exchange: AdminDisplayVersion : Version 14.3 (Build 123.4)
    • Изменено Alistad 14 августа 2015 г. 11:51
    14 августа 2015 г. 11:50
  • exchange 2013 sp1 cu10 Outlook 2016. Проблема сохраняется =(
    22 декабря 2015 г. 12:13
  • отправляйте в формате RTF.

    22 декабря 2015 г. 12:17