none
Пропали отчеты после переустановки DW сервера RRS feed

  • Вопрос

  • Привет!

    После сбоя питания на вирутальном сервере с SQL порушилась одна из баз DW.

    Переустановил сервер DW c отменой регистрации и с последующей регистрацией.

    Появились вкладки "Хранилище данных" и "Отчеты".

    В хранилище данных в заданиях DW только три пункта, кажется было 5? Отсутствуют Transform и Load.Common.

    В отчетах пустота, только Отчеты и избранные отчеты.

    В логах DW сервера есть такие вещи:

    Management pack association ignored. This does not require any action. If you continue to frequently see this warning, contact your administrator. This process will continue to retry.

    Management pack ID: 9541d60e-9a8b-cfd2-2008-155c3e0ada5c

    Management pack name: ServiceManager.IncidentManagement.Report.Library

    Management pack version: 7.0.6555.0

    Data source name: Either the MP has failed deployment Or any of its references has failed deployment

     

    Соответственно для каждого вида отчетов, Изменения, Действия, Проблемы.

    И еще:

    Management pack association ignored. This does not require any action. If you continue to frequently see this warning, contact your administrator. This process will continue to retry.

    Management pack ID: c8474f80-5968-a83f-1c4e-093fff628870

    Management pack name: Microsoft.SystemCenter.Warehouse.System

    Management pack version: 7.0.6555.0

     Data source name: Either the MP has failed deployment Or any of its references has failed deployment

     

    Соответственно для каждого вида отчетов, Изменения, Действия, Проблемы.

    Помню еще на SCOMе проблемы были с DW базой.

     

    Можно, что либо сделать? Заранее спасибо!

     

    19 октября 2011 г. 9:27

Ответы

  • В моем случае помогла только полная переустановка DW, причем ошибки были абсолютно такие же... подключали к основной группе уже после установки CU2?
    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com
    • Помечено в качестве ответа Timur Mukhametov 20 октября 2011 г. 11:07
    19 октября 2011 г. 14:54
    Модератор
  • Спасибо!

    Помогла чистая переустановка роли DW, с удалением старых баз, в процессе установки роли базы создавались с дефолтными названиями. CU2 накатывал до регистрации в DW.

    • Помечено в качестве ответа Timur Mukhametov 20 октября 2011 г. 11:07
    20 октября 2011 г. 11:06

Все ответы

  • Видел такое, решается внимательной инсталяцией сервера DW. Скорее всего пропустили какое-то из требований.

    Обновления на основном сервере и DW совпадают? Старые базы были удалены перед переустановкой?


    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com
    19 октября 2011 г. 13:19
    Модератор
  • Старые базы удалены не были, но создавались новые под другим именем, это критично?

    После установки DW накатил CU последний, второй для SP1.

     

    Там особо пропускать-то вроде и нечего, при установке DW. Название баз и название группы управления.

     

    Переустановить с дефолтными названиями, попытаться?

     

    Сейчас кстати вижу в менджемент-паках Хранилища данных есть один сбойный

    Базовая библиотека хранилища данных System Center

     

    А от нее как раз зависят паки с отчетами, "Перезапустить развертывание" видимо не помогает, запускал пару раз уже.

    19 октября 2011 г. 13:38
  • В моем случае помогла только полная переустановка DW, причем ошибки были абсолютно такие же... подключали к основной группе уже после установки CU2?
    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com
    • Помечено в качестве ответа Timur Mukhametov 20 октября 2011 г. 11:07
    19 октября 2011 г. 14:54
    Модератор
  • Регистрировал до установки CU.

    Щас попробую снова переставить с удалением баз и апдейт до регистрации сделаю.

    20 октября 2011 г. 5:34
  • Спасибо!

    Помогла чистая переустановка роли DW, с удалением старых баз, в процессе установки роли базы создавались с дефолтными названиями. CU2 накатывал до регистрации в DW.

    • Помечено в качестве ответа Timur Mukhametov 20 октября 2011 г. 11:07
    20 октября 2011 г. 11:06
  • Скорее всего проблема именно в "Регистрировал до установки CU", потому что по "правильному" надо делать наоборот. и в моем случае люди сделали сначала регистрацию, а потом установили CU, и получили такую же ошибку. Скорее всего это связано с версиями системных пакетов управления.


    http://www.scsmsolutions.com/ freemanru (at) gmail (dot) com
    21 октября 2011 г. 15:55
    Модератор