none
Проблема с MPI RRS feed

  • Вопрос

  • Добрый день! Не могли Вы помочь в решении следующей проблемы.

    С помощью Hyper-V были созданы две виртуальные машины (с ОС Windows Server 2008). На каждой виртульной машине установлен Microsoft HPC Pack 2008 SDK. Хотелось бы запускать MPI-приложение так, чтобы часть процессов выполнялась на VM1, а часть процессов на VM2. Для этого на каждой виртуальной машине запускается скрипт smpd.exe -d, а потом в cmd одной из виртуальных машин выполняется следующая команда:

    >"C:\Program Files\Microsoft HPC Pack 2008 SDK\Bin\mpiexec.exe" -machinefile file.txt GlimpseOfMPI.exe

    где

    file.txt содержит:

    10.0.16.6 5

    10.0.16.7 5

    Возникает ошибка:

    job aborted:

    [ranks] message

     

    [0-4] terminated

     

    [5] fatal error

    Fatal error in MPI_Send: Other MPI error, error stack:

    MPI_Send(175)..................: MPI_Send(buf=0x00267880, count=101, MPI_DOUBLE,

     dest=0, tag=0, MPI_COMM_WORLD) failed

    MPIDI_EagerContigSend(177).....: failure occurred while attempting to send an ea

    ger message

    MPIDI_CH3_iStartMsgv(240)......:

    MPIDI_CH3I_VC_post_connect(405): MPIDI_CH3I_Shm_connect failed in VC_post_connec

    t

    MPIDI_CH3I_Shm_connect(194)....: failed to attach to a bootstrap queue

     

    [6] fatal error

    Fatal error in MPI_Send: Other MPI error, error stack:

    MPI_Send(175)..................: MPI_Send(buf=0x021D7880, count=101, MPI_DOUBLE,

     dest=0, tag=0, MPI_COMM_WORLD) failed

    MPIDI_EagerContigSend(177).....: failure occurred while attempting to send an ea

    ger message

    MPIDI_CH3_iStartMsgv(240)......:

    MPIDI_CH3I_VC_post_connect(405): MPIDI_CH3I_Shm_connect failed in VC_post_connec

    t

    MPIDI_CH3I_Shm_connect(194)....: failed to attach to a bootstrap queue

     

    [7] fatal error

    Fatal error in MPI_Send: Other MPI error, error stack:

    MPI_Send(175)..................: MPI_Send(buf=0x020E7880, count=101, MPI_DOUBLE,

     dest=0, tag=0, MPI_COMM_WORLD) failed

    MPIDI_EagerContigSend(177).....: failure occurred while attempting to send an ea

    ger message

    MPIDI_CH3_iStartMsgv(240)......:

    MPIDI_CH3I_VC_post_connect(405): MPIDI_CH3I_Shm_connect failed in VC_post_connec

    t

    MPIDI_CH3I_Shm_connect(194)....: failed to attach to a bootstrap queue

     

    [8] fatal error

    Fatal error in MPI_Send: Other MPI error, error stack:

    MPI_Send(175)..................: MPI_Send(buf=0x02267880, count=101, MPI_DOUBLE,

     dest=0, tag=0, MPI_COMM_WORLD) failed

    MPIDI_EagerContigSend(177).....: failure occurred while attempting to send an ea

    ger message

    MPIDI_CH3_iStartMsgv(240)......:

    MPIDI_CH3I_VC_post_connect(405): MPIDI_CH3I_Shm_connect failed in VC_post_connec

    t

    MPIDI_CH3I_Shm_connect(194)....: failed to attach to a bootstrap queue

     

    [9] fatal error

    Fatal error in MPI_Send: Other MPI error, error stack:

    MPI_Send(175)..................: MPI_Send(buf=0x008B7880, count=100, MPI_DOUBLE,

     dest=0, tag=0, MPI_COMM_WORLD) failed

    MPIDI_EagerContigSend(177).....: failure occurred while attempting to send an ea

    ger message

    MPIDI_CH3_iStartMsgv(240)......:

    MPIDI_CH3I_VC_post_connect(405): MPIDI_CH3I_Shm_connect failed in VC_post_connec

    t

    MPIDI_CH3I_Shm_connect(194)....: failed to attach to a bootstrap queue

     

    ---- error analysis -----

     

    [5-9] on 10.0.16.7

    mpi has detected a fatal error and aborted GlimpseOfMPI.exe

     

    ---- error analysis -----

    При этом если файл file.txt содержит только

    10.0.16.6 5

    или только

    10.0.16.7 5

    все выполняется корректно 

    Очень надеюсь на Вашу помощь. Заранее большое спасибо!

    30 августа 2011 г. 13:57