none
SQL SERVER EXPRESS 2012 sp2 - installation error 0x84B40001 RRS feed

  • Вопрос

  • I'm trying to install SQL Server Express  2012 sp2, through command line,

    SQLEXPR_x86_ENU.exe  /ACTION=Install /HIDECONSOLE  /FEATURES=SQL /INSTANCENAME=SQLEXPRESS /SECURITYMODE=SQL /SAPWD="SOMEPWD" /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /SQLSYSADMINACCOUNTS="Builtin\Administrators" /AGTSVCACCOUNT="NT AUTHORITY\Network Service"

    but i'm getting this error "The syntax of argument "/HIDECONSOLE" is incorrect;Either the delimiter '=' is missing or there is one or more space characters before the '='"  Error 0x84B40001

    I removed the entire /HIDECONSOLE argument in my command, and still get the same error.

    Plz help me!!!


    • Изменено Nissanna 24 января 2016 г. 10:31
    24 января 2016 г. 10:18

Все ответы

  • Hi Nissanna,

    The above error is caused by that there are two  or more space characters before parameters ” /ACTION” and “/FEATURES”, please change the commands to be the following code and check if you can install SQL Server successfully.

    SQLEXPR_x86_ENU.exe /QS /ACTION=Install /FEATURES=SQL /INSTANCENAME=SQLEXPRESS /SECURITYMODE=SQL /SAPWD="SOMEPWD" /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /SQLSYSADMINACCOUNTS="Builtin\Administrators" /AGTSVCACCOUNT="NT AUTHORITY\Network Service" /IACCEPTSQLSERVERLICENSETERMS="True"

    For more information of installing SQL Server from command prompt, please review this link.
    https://msdn.microsoft.com/en-us/library/ms144259(v=sql.110).aspx

    Regards,
    Ice fan


    Ice Fan
    TechNet Community Support


    25 января 2016 г. 7:15
  • HI, 

    that didn't worked for me, and this the log that i get : 

    01/24/2016 23:53:12.038 ======================================================================
    01/24/2016 23:53:12.054 Setup launched
    01/24/2016 23:53:12.054 Attempting to determine media source
    01/24/2016 23:53:12.069 Media source value not specified on command line argument.
    01/24/2016 23:53:12.069 Setup is launched from media directly so default the value to the current folder.
    01/24/2016 23:53:12.069 Media source: C:\0070169c9fe10b9296\
    01/24/2016 23:53:12.069 Attempt to determine media layout based on file 'C:\0070169c9fe10b9296\mediainfo.xml'.
    01/24/2016 23:53:12.179 Media layout is detected as: Core
    01/24/2016 23:53:12.179 Media is a slipstream package
    01/24/2016 23:53:12.179 Only patch related actions can run patch setup.exe, so continuing to run setup.exe from media.
    01/24/2016 23:53:12.304 SQM key not found
    01/24/2016 23:53:12.304 /? or /HELP or /ACTION=HELP specified: false
    01/24/2016 23:53:12.304 Help display: false
    01/24/2016 23:53:12.320 .Net version 3.5 is installed
    01/24/2016 23:53:12.335 .Net version 2.0 is installed
    01/24/2016 23:53:12.335 Local setup.exe not found, so continuing to run setup.exe from media.
    01/24/2016 23:53:12.335 Attempt to initialize SQL setup code group
    01/24/2016 23:53:12.335 Attempting to determine security.config file path
    01/24/2016 23:53:12.335 Checking to see if policy file exists C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG\security.config
    01/24/2016 23:53:12.335 .Net security policy file does exist
    01/24/2016 23:53:12.350 Attempting to load .Net security policy file
    01/24/2016 23:53:12.366 Processing entry ("MSVCM80", "Native")

    01/24/2016 23:53:34.522 Saved .Net security policy file
    01/24/2016 23:53:34.522 Attempting to release setup mutex
    01/24/2016 23:53:34.539 Setup mutex has been released
    01/24/2016 23:53:34.539 SQM key not found
    01/24/2016 23:53:34.553 Setup closed with exit code: 0x84C40013
    01/24/2016 23:53:34.553 ======================================================================

    25 января 2016 г. 8:32
  • This is different message from what was coming before. Please upload the whole content on shared drive I want to see the complete file. Please also add summary.txt file

    Please mark this reply as answer if it solved your issue or vote as helpful if it helped so that other forum members can benefit from it

    My Wiki Articles

    MVP

    25 января 2016 г. 8:59
    Модератор
  • Hi, i need your help as soon as possible

    I'm using Sql Server 2012 express sp2 as prerequisite in installshield 2010 premier.

    When i run it alone , it's works nicely, but when i run with the installshield (i mean with the setup), it stoped at the installtion 's file 

    Remarque : i have juste 3 options (first image) while i should have more (picture 2)

    plz help me

    27 января 2016 г. 19:31
  • Hello,

    There is a known issue with InstallShield and SQL Server 2012 as explained on the following article:

    https://support.microsoft.com/en-us/kb/2820068

    Hope this helps.



    Regards,



    Alberto Morillo
    SQLCoffee.com

    27 января 2016 г. 19:41
    Модератор
  • hi, 

    that doesn't worked for me bcz another error occurs  

    27 января 2016 г. 20:04
  • Hi Nissanna,

    Thank you for your question.

    I am trying to involve someone more familiar with this topic for a further look at this issue. Sometime delay might be expected from the job transferring. Your patience is greatly appreciated.
    Thank you for your understanding and support.

    Thanks,
    Ice fan


    Ice Fan
    TechNet Community Support


    2 февраля 2016 г. 5:56
  • Hi Nissanna,

    For the error "01/24/2016 23:53:34.553 Setup closed with exit code: 0x84C40013", please make sure you have Microsoft .Net Framework 3.5 SP1 installed.

    For the screenshot that only have 3 options, after you click Next, it will reload the wizard, and more options will be visible.

    2 февраля 2016 г. 16:40