none
При разворачивании приложения ошибка 0x87D00213 (-2016411117) + удаленный помощник в SCCM 2012 RRS feed

  • Вопрос

  • При попытках развернуть (видимость программы установки "свернуто") на тестовой машине Приложение (пробовал MS Office 2010 и MS Visio 2013) возвращает код ошибки 0x87D00213 (-2016411117). В Центре программного обеспечения в поле состояние выдается сообщение "Крайний срок прошел - будет предпринята повторная попытка".

    Разворачивание приложения производил в соответствии со статьей в интернет: blog.it-kb.ru/2012/12/17/deployment-office-2013-via-system-center-configuration-manager-sccm-2012/

    При разворачивании "простых" пакетов (7zip, Total Commander) ошибок на выходе не получал. Приложения устанавливаются. Пытался развренуть пакет MS Office 2010, на выходе получил ошибку 0x103(259).

    Так же есть еще один вопрос по SCCM 2012: крутится на Windows Server 2012 R2 Standard; не могу заходить на машины с помощью "удаленного помощника" (выдает сообщение "Удаленный помощник Windows не установлен на этом компьютере. Сначала установите удаленный помощник."). Галочка разрешения использования удаленного помощника на сервере не активна, файл msra.exe на сервере не найден. В чем заключаться может данная проблема? Как использовать удаленного помощника в SCCM 2012 в таком случае можно?


    • Изменено 4EJLOBE4EK 29 января 2015 г. 6:28
    29 января 2015 г. 6:15

Ответы

    • Помечено в качестве ответа 4EJLOBE4EK 3 февраля 2015 г. 10:53
    3 февраля 2015 г. 9:12
    Модератор
  • Удаленный помощник жизненно необходим при использовании терминальных серверов.

    Без него не возможно подключиться к терминальной сессии пользователя.

    Для того чтобы работал, его необходимо установить на сервер терминалов и на рабочие станции администраторов с консолью sccm. Ну и политики, разумеется настроить надо.

    А если подключаться на сервер терминалов при помощи обычного клиента удаленного управления SCCM, то всегда будешь попадать в окно с приглашением нажать ctrl+alt+del.

    • Помечено в качестве ответа 4EJLOBE4EK 30 января 2015 г. 7:31
    29 января 2015 г. 18:41

Все ответы

  • покажите AppEnforce.log с клиента, строку установки office и visio и XML файл конфига, который вы применяете. Такое ощущение, что путь до xml не находит и ожидает каких-то действий и в итоге отваливается по таймауту. 

    http://masyan.ru/2012/08/office-2010-i-sccm-2012/

    http://masyan.ru/2014/02/install-skydrive-pro-2013-for-office-2013/

    Установка Visio или Project ничем не отличается от установки Office.

    По второму вопросу: смотрите политики агента, других идей нет, если честно, сколько себя помню ни разу им не пользовался. ))


    29 января 2015 г. 9:02
    Модератор
  • Удаленный помощник жизненно необходим при использовании терминальных серверов.

    Без него не возможно подключиться к терминальной сессии пользователя.

    Для того чтобы работал, его необходимо установить на сервер терминалов и на рабочие станции администраторов с консолью sccm. Ну и политики, разумеется настроить надо.

    А если подключаться на сервер терминалов при помощи обычного клиента удаленного управления SCCM, то всегда будешь попадать в окно с приглашением нажать ctrl+alt+del.

    • Помечено в качестве ответа 4EJLOBE4EK 30 января 2015 г. 7:31
    29 января 2015 г. 18:41
  • 1. Лога не смог найти, поиск результатов не дал.

    2.1. Файл конфигурации у меня в формате MSP: (\Update\CustomSetup.MSP)

    ссылка - cloud.mail.ru/public/02b426368f97/CustomSetup.MSP

    2.2. В XML только SilentUninstallProPlus.xml (для uninstall'а офиса):

    <Configuration Product="ProPlus"> 
        <Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" /> 
        <Setting Id="SETUP_REBOOT" Value="Never" /> 
    </Configuration>

    3. Строка состояния установки на клиенте в центре ПО имеет следующий вид:

    ссылка -  https://cloud.mail.ru/public/ed005c6839c3/%D0%A6%D0%B5%D0%BD%D1%82%D1%80%20%D0%9F%D0%9E.JPG

    Буду сейчас пробовать по вашей статье развернуть офис.

    30 января 2015 г. 7:28
  • Что-то я запамятовал и про роли/компоненты действительно забыл. Установил нужную роль и компоненты к ней, удаленный помощник заработал. Спасибо!

    Политики уже были настроены. Осталось у всех машин включить и поднастроить в конфигурации компьютера Удаленного помощника.

    30 января 2015 г. 7:31
  • лог на клиенте лежит windows\ccm\logs и покажите строку установки в sccm для офиса.

    30 января 2015 г. 20:03
    Модератор
  • Антон, спасибо, лог нашел:

    https://cloud.mail.ru/public/2d9da1174d6c/AppEnforce.log

    Последняя установка офиса по Вашей статье "Office 2010 и SCCM 2012" производилась.

    Если верно понял какую строку установки в sccm необходимо приложить, то скриншот прилагаю:

    https://cloud.mail.ru/public/bc01d4bd746a/sccm%20error%20install%20ms%20office%202010.JPG


    • Изменено 4EJLOBE4EK 2 февраля 2015 г. 5:52
    2 февраля 2015 г. 5:45
  • я спрашивал про это:

    ну по таймауту отваливается установка 

    Exceeded timeout of 180 minutes while waiting for process 3528 to finish. AppEnforce 30.01.2015 17:19:06 1380 (0x0564)

        App enforcement environment: 
    Context: Machine
    Command line: setup.exe /adminfile "CustomSetup.msp"
    Allow user interaction: No
    UI mode: 1
    User token: null
    Session Id: 4294967295
    Content path: C:\Windows\ccmcache\7
    Working directory: AppEnforce 30.01.2015 17:19:06 1380 (0x0564)

    вы либо CustomSetup.MSP положите в корень дистрибутива office, либо в свойствах развертывания укажите правильный путь до него, он у вас лежит в \Update\CustomSetup.MSP, а вы его вызываете из корня setup.exe /adminfile "CustomSetup.msp". После того, как выполните изменения в папке с дистрибутивом, обязательно приложение надо передоставить (update content) на точку распространения. 


    2 февраля 2015 г. 7:14
    Модератор
  • Антон, спасибо за активную помощь!

    Разместил CustomSetup.MSP в корень дистрибутива офиса (хотя если мне не изменяет память, где-то при настройке пакета прямо указывалось на этот файл в папке update). На данный момент файл в двух экземплярах лежит и в корне и в Update. Ошибка не исчезла.

    На точке распространения обновил содержимое пакета развертывания.

    Ошибка та же самая. Лог новый прилагаю:

    https://cloud.mail.ru/public/d83a33edf99a/AppEnforce%20(2).log

    Строку установки прилагаю:

    https://cloud.mail.ru/public/cee354f30659/program.JPG

    3 февраля 2015 г. 5:14
  • а вы кэш на клиенте почистите.
    3 февраля 2015 г. 5:52
    Модератор
  • а есть просто запустить setup.exe /adminfile "CustomSetup.msp" - как при этом происходит установка?

    что видит пользователь?

    Появляются ли какие-то диалоги, ждущие от пользователя ответа?

    3 февраля 2015 г. 5:54
  • Anton Masyan, почистил. Повторно пробую установить.

    Антон Петров, настройки выполнены на скрытую установку офиса. Наврятли пользователь что-то увидит. Если я правильно понял, Вы имеете ввиду запустить команду в cmd на выполнение с машины клиента? Если да, то позднее, в случае очередной неудачи (если чистка кэша не поможет), проверю.

    3 февраля 2015 г. 6:58
  • Да, Антон, хороший вариант предложил, так будет понятно, все ли хорошо с самим файлом ответа, который вы в OCT собирали и распакованным образом самого офиса.
    3 февраля 2015 г. 7:03
    Модератор
  • выскочило окно:

    https://cloud.mail.ru/public/ebda82e073aa/install_office_10.JPG

    Дальше кликнул "установить" и офис разворачивается сам в соответствии с настройками CustomSetup.msp

    Процесс установки в виде "прогресс-бара" наблюдал. Аналогично при удалении. Спросило диологовое окно точно ли удалить или нет и далее наблюдал процесс удаления.

    Собственно при "насильном" запуске всё отрабатывает. При развертывании на SCCM данное окно не выскакивает и процесс установки не происходит. Как можно избежать появления этих окон и полностью скрыть процесс установки/удаления (по умолчанию сделать, чтобы без разрешения пользователя начинал ставить/удалять офис)?

    3 февраля 2015 г. 8:58
    • Помечено в качестве ответа 4EJLOBE4EK 3 февраля 2015 г. 10:53
    3 февраля 2015 г. 9:12
    Модератор
  • Процесс в SCCM потому и висит, что это окно также висит, но пользователь его не видит.

    Что-то в этом msp вы недопилили. 

    Показывайте скриншоты настройки CustomSetup.

    Ну или сделайте как Антон показал.

    3 февраля 2015 г. 9:13
  • Парни, добра Вам и спасибо! победил беду :)

    Беда была действительно в Лицензировании в графе "отображать уровень"

    3 февраля 2015 г. 10:54