none
Проблемы при внедрении SCCM RRS feed

  • Вопрос

  • Начал внедрение SCCM, установка прошла успешно, НО:
    Проблема 1: Клиенты поставились на подавляющее большинство компов, но на некоторые ни в какую не ставятся(даже не копируется папка ccmsetup). Копмонент SMS_CLIENT_CONFIG_MANAGER выдает на эти компы предупреждение: "SMS Client Configuration Manager не смог обнаружить компьютер "XXXXX" в сети. Операционная система сообщила об ошибке 53. Не найден сетевой путь" ID сообщения: 3015, ID процесса: 2252, ID потока:4932. Однако этот комп включен, и доступен. В клиентских логах пусто.
    Проблема 2: Хотелось бы развернуть систему обновлений через SCCM(раньше обновлялись через WSUS), но почему то в SCCM не определяется что обновления уже установлены на данных компах(в состоянии обновления пишет "Неизвестно") С чем это может быть связано, ведь WSUS отлично определяет процент установленных обновлений?
    Проблема 3: Как то странно происходит отслеживание установленного на компах и запускаемого пользователями ПО. Т.е. в отчётах почему то отображаются не всё установленное ПО и уж точно не всё запускаемое. Не работает ни 1 отчёт по использованию лицензий(хотя может просто не понимаю как он должен работать и что отображать), не отображаются семейства ПО и соответственно категории ПО(или их надо заносить куда-то вручную?). Таким образом не работает часть отчётов необходимых для мониторинга клиенских систем.

    Буду очень благодарен если поможете в решении сложившейся ситуации и успешном внедрении SCCM.

    P.S. SCCM SP1 R2, OS - Windows Server 2008 R2
    17 декабря 2009 г. 10:40

Ответы

  • о! вот чего нарыл в логах... Unable to connect to WMI (r) on remote machine "XXXXX", error = 0x8004100e. (попробую погуглить как исправить, но буду благодарен если кто-то тут напишет решение проблемы :))
    http://ccmexec.blogspot.com/2009/10/wmi.html
    мой блог - http://ccmexec.blogspot.com/
    • Помечено в качестве ответа Senser 17 декабря 2009 г. 14:14
    17 декабря 2009 г. 13:30
    Отвечающий

Все ответы

  • Попробуем взглянуть глубже...
    Проблема 1. Расширена ли схема? Настроены ли Discovery? Корректно ли работает DNS? Есть ли у аккаунта под которым ставится клиент административные права на клиентские компьютеры? Что отображается в логах на сервере (как Вам наверное известно у каждого компонента отдельный лог-файл).
    Установите SCCM 2007 Toolkit, будет удобнее.
    Проблема 2. Настроена ли программная инвентаризация на клиентах?
    проблема 3. Могут быть некорректно настроены правила для мониторинга зарпущеных приложений, не забывайте корректно указывать версию программы и языковую версию в правилах. Что же касается отчетов по использованию лицензий, в моем понимании речь идет о взаимодействии с локальной службой лицензий в операционных системах, которая по умолчанию отключена, но я могу ошибаться, читайте документацию, там есть ограничения. В любом случае отчеты по умолчанию будут работать лишь те, которые будут отображать информацию которую собирает клиент. Если клиент ничего не собирает информации в БД не будет. У каждого отчета есть область за которую отвечает часть настроек клиента, так же не забывайте что данные появляются не спешно, по мере их сбора с Secondary Site-ов. А отчеты Assets Intellegence вообще настраиваются отдельно.

    Судя по Вашим вопросам Вы плохо ознакомились с документацией, она на русском языке, прочитайте и половина вопросов отпадет.
    Успехов!

    17 декабря 2009 г. 11:53
  • 1.
    Расширена ли схема? Конечно расширена, иначе SCCM не смог бы продолжить установку после проверки необходимых компонентов

    Настроены ли Discovery? помоему тоже естественно что они настроены, иначе как бы я увидел что у меня клиенты не на все компы установились?

    Корректно ли работает DNS? все компы отображаются в DNS и ко всем есть доступ как через IP так и по имени хоста. Понимаю еще если бы проблема была на всех компах...а у нас проблема примерно на 10 из 130.

    Есть ли у аккаунта под которым ставится клиент административные права на клиентские компьютеры? Есть. Никаких отличий этих 10 компов от остальных 120 нет, поэтому если бы не было админских прав то клиент не установился бы на всех компах сети.

    о! вот чего нарыл в логах... Unable to connect to WMI (r) on remote machine "XXXXX", error = 0x8004100e. (попробую погуглить как исправить, но буду благодарен если кто-то тут напишет решение проблемы :))


    2. Настроена ли программная инвентаризация на клиентах? имеете ввиду агента инвентаризации ПО? Да он включен.
    17 декабря 2009 г. 12:28
  • о! вот чего нарыл в логах... Unable to connect to WMI (r) on remote machine "XXXXX", error = 0x8004100e. (попробую погуглить как исправить, но буду благодарен если кто-то тут напишет решение проблемы :))
    http://ccmexec.blogspot.com/2009/10/wmi.html
    мой блог - http://ccmexec.blogspot.com/
    • Помечено в качестве ответа Senser 17 декабря 2009 г. 14:14
    17 декабря 2009 г. 13:30
    Отвечающий
  • Супер! Похоже в этом блоге есть ответы на все мои вопросы. Огромное спасибо!
    17 декабря 2009 г. 14:14
  • Столкнулся с такой же проблемой как у Вас под пунктом один.

    Ситуация аналогична, схема расширена, дискавери настроена, использую пуш инсталяцию и т.д.

    В логах имею:

    ---> Unable to connect to WMI on remote machine "KLD-RC01-PC50", error = 0x800706ba.    SMS_CLIENT_CONFIG_MANAGER    01.01.1601 0:00:00    4392 (0x1128)

     

    Кроме как этого, ничего не нашел.

    И вот еще попробуйте:
    1. Stopped the WMI service
    2. Stopped the Windows Firewall/Internet Connection Sharing service
    3. Deleted the items in C:\WINDOWS\system32\wbem\R
    epository
    4. Restarted the services WMI and Windows Firewall/ICS
    5. SCCM could now connect and push the clients and update the database.

     

    Но к сожелению, это не помогает.

    Перестановка ОС проблему решает, но машин довольно большое кол-во, что бы решать таким путем.

    Может кто нашел еще какие-нибудь пути решения?

    5 апреля 2011 г. 7:40
  • http://sccm.com.ua/?p=547
    http://sccm.com.ua/
    5 апреля 2011 г. 8:10
    Отвечающий
  • С прямыми записями все ок, проверял несколько из проблемных машин.

     

    Еще возник вопрос, при ручной учтановке в логе нахожу следующее:

    Couldn't get directory list for directory 'http://KLD-SRV-SCCM/CCM_Client/ClientPatch'.  This directory may not exist.    ccmsetup    05.04.2011 11:03:23    3280 (0x0CD0)

    Такой папки действительно нет, но при Push Installation на большинстве мащин все ок.

    При ручной установке запускаю со следующими параметрами:

    Command line: CCMSetup.exe /mp:KLD-SRV-SCCM /logon SMSSITECODE=VCT FSP=KLD-SRV-SCCM SMSSLP=SRV-SCCM DISABLESITEOPT=TRUE DISABLECACHEOPT=TRUE    ccmsetup    05.04.2011 11:02:50    3280 (0x0CD0)

    5 апреля 2011 г. 8:52
  • Поподробнее посмотрел лог на машине где клиент встал без проблем через Push Installation.

    На отсуствие данной папки тоже есть запись, но установка продолжается и заканчивается успешно.

    А тут заканчивается следующим:

    Adding file 'http://KLD-SRV-SCCM:80/CCM_Client/i386/msrdcoob_x86.exe' to BITS job, saving as 'C:\WINDOWS\system32\ccmsetup\msrdcoob_x86.exe'.    ccmsetup    04.04.2011 15:38:39    1124 (0x0464)
    Sending Fallback Status Point message, STATEID='309'.    ccmsetup    04.04.2011 15:38:39    1124 (0x0464)
    State message with TopicType 800 and TopicId {3576C13D-9422-49C9-853F-91B5EC254470} has been sent to the FSP    FSPStateMessage    04.04.2011 15:38:40    1124 (0x0464)
    Deleted file C:\WINDOWS\system32\ccmsetup\ccmsetup.cab    ccmsetup    04.04.2011 15:38:40    1124 (0x0464)
    Deleted file C:\WINDOWS\system32\ccmsetup\ccmsetup.xml    ccmsetup    04.04.2011 15:38:40    1124 (0x0464)

    и тишина

    5 апреля 2011 г. 12:02
  • С ручной установкой вроде разобрался.

    Взял конфигурационный файл, который используется при Push Instalation.

    И запустил в следующием виде:

    "C:\WINDOWS\system32\ccmsetup\ccmsetup.exe" /config:MobileClient.tcf

    Клиент встал, через некоторое время в оснастке начал отображать, что клиент установлен.

    Данные об инвентаризации прислал.

    НО:

    При попытке принудительного запуска любого круга сбора информации, пишет следующее:

    Unable to connect to WMI on COMPUTERXXX

    The remote server machine does not exist or is unavailable (462)


    6 апреля 2011 г. 7:47
  • Покажите из лога подробно расписанную ошибку.
    http://sccm.com.ua/
    6 апреля 2011 г. 13:34
    Отвечающий
  • Честно не знаю в каком конкретно логе это смотреть.

    Проблемный клиент относится к вторичному сайту, запуск соответственно осуществляю из оснастки на первичном.

    В каком логе поискать попытку запуска например Discovery Data Collection Cycle ?

    7 апреля 2011 г. 7:50