none
HELP! Маршрутизация почты RRS feed

  • Вопрос

  • Доброго времени суток всем!

    Общаюсь с Exchange недавно, поэтому сразу извините если вопрос из области FAQ.

    Итак. В организации один домен, 2 сайта. В сайты разнесены 2 филиала объедененные по медленному каналу.
    Начали внедрять Exchange. В головном филиале развернул сервер с Exchange (SERVER-1), все замечательно.
    Чтобы пользователи удаленного филиала при пересылке друг другу почты не загружали медленный канал связи принял решение развернуть в удаленном филиале еще один сервер Exchange (использую 2007 версию). Насколько я понял - это как раз рекомендованное решение не так ли?
    Прежде чем разворачивать сервер в удаленном филиале, я ради теста поднял Exchange еще на одном сервере(SERVER-TEST) в головном офисе. Ок, все поднялось без ошибок, сервера друг друга видят, все нормально.
    Роли на каждом одинаковы (hub транспорт, хранилище и доступ).
    На тестовом сервере я создал 2 почтовых ящика.
    Отсылаю письмо от одного пользователя (расположенного на тестовом сервере) другому пользователю (тоже расположенного на тестовом сервере). По заголовкам письма и по результатам прослушивания трафика вижу что письмо сначало ушло на основной сервер (SERVER-1), а затем вернулось получателю на SERVER-TEST.
    Непонимаю этой ситуации!!
    Судя по прочтенной документации письмо не должно было по сети гулять, а сразу лечь в ящик получателя не так ли?
    Или  же это нормальное поведение? Но как в таком случае снять нагрузку на медленный канал если я разверну Exchange в филиале? И вообще какой тогда смысл устанавливать еще один сервер?
    Помогите пожалуйста разобраться!

    • Перемещено Hengzhe Li 18 марта 2012 г. 6:24 forum merge (От:Exchange Server 2007)
    16 апреля 2008 г. 7:03

Все ответы

  • Покажите упоминаемый заголовок(и)

     

    16 апреля 2008 г. 12:20
  • Вот заголовки письма.
    Здесь srv-test.monotrans.local - это тестовый сервер на котором расположены почтовые ящики отправителя и получателя этого письма.
    srv-sql.monotrans.local - рабочий сервер.

    ----
    Received: from srv-test.monotrans.local ([192.168.15.3]) by
     srv-sql.monotrans.local ([192.168.15.6]) with mapi; Tue, 15 Apr 2008 16:30:01
     +0800
    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: =?koi8-r?B?68/O09TBztTJziD3LiDrwdTLz9f=?= <KatkovKV@monotrans.local>
    To: =?koi8-r?Q?=E9=CE=CE=C1_=F7._=E5=D2=CD=C1=CB=CF=D7=C1?=
        <ErmakovaIV@monotrans.local>
    Date: Tue, 15 Apr 2008 16:29:38 +0800
    Subject:
    Thread-Index: Acie0tff5imYlyalTbGR/PALS7i8gA==
    Message-ID: <E441125B3238804988158F9DF3B25D1331C5@srv-test.monotrans.local>
    Accept-Language: ru-RU
    Content-Language: ru-RU
    X-MS-Has-Attach: yes
    X-MS-Exchange-Organization-SCL: -1
    X-MS-TNEF-Correlator: <E441125B3238804988158F9DF3B25D1331C5@srv-test.monotrans.local>
    MIME-Version: 1.0

    17 апреля 2008 г. 0:42
  • На любом из этих двух серверов запустите Exchange Management Shell, выполните команду "get-exchangeserver |fl" и скопируйте результаты сюда, пожалуйста.

     

    Что-нибудь еще, кроме Exchange, на серверах установлено? (меня смущает имя рабочего сервера).

    17 апреля 2008 г. 2:21
  •  Pterodactyl написано:
    Непонимаю этой ситуации!!
    Судя по прочтенной документации письмо не должно было по сети гулять, а сразу лечь в ящик получателя не так ли?
    Или  же это нормальное поведение? Но как в таком случае снять нагрузку на медленный канал если я разверну Exchange в филиале? И вообще какой тогда смысл устанавливать еще один сервер?
    Помогите пожалуйста разобраться!

    Письмо не должно "ложиться сразу в ящик", это было так в Exchage 2003, но не в Exchange 2007. Письмо будет доставлено на транспортный сервер, обработано, и передано на почтовый сервер (даже если это тот же самый сервер). Какой именно транспортный сервер будет использоваться, определяется их принадлежностью к сайту AD. Поскольку в удаленном филиале сайт другой, то пересылка между сайтами будет происходить только если почтовые ящики отправителя и получателя находятся на разных почтовых серверах в разных сайтах.

     

    Снимете ли вы нагрузку на медленный канал или наоборот еще сильнее ее увеличите, на самом деле большой вопрос. Сервера ведь между собой тоже "разговаривают". Именно поэтому дизайн Exchange - не такая простая штука.

    Какие конкретно клиенты (софт, версии, процентное распределение) и в каком режиме (online / cached) будут работать с Exchange в каждом сайте?
    17 апреля 2008 г. 2:27

  • вывод комманды ниже.

    Правильно ли я понял, что если в одном сайте находятся 2 exchange сервера (как в моем случае) то только один из них будет работать траспортным сервером, даже если роли транспортного сервера установлены на обоих серверах?
    И тогда письмо в пределах одного сайта будет маршрутизироваться всегда через один сервер? А когда я уберу второй сервер (srv-test) в другой сайт то для пользователей в этом сайте он начнет выполнять роль транспортного сервера и уже через srv-sql гонять письма перестанет?

    По поводу разговоров между серверами и софта. Предполагается использование только Outlook 2007. Насчет режима работы - тут я признаюсь в безграмотности. Какой режим порекомендуете Вы для снижения нагрузок на канал связи (малого того что канал медленный, так еще и трафик дорогой Wink

    По поводу имени сервера - да изначально на этом сервере был установлен SQL 2005. Поскольку нагрузка на него очень мала, а сервер мощный то на нем и развернули Exchange.


    --- вывод get-exchangeserver

    Name                              : SRV-SQL
    DataPath                          : C:\Program Files\Microsoft\Exchange Server\
                                        Mailbox
    Domain                            : monotrans.local
    Edition                           : Enterprise
    ExchangeLegacyDN                  : /o=GKM/ou=Exchange Administrative Group (FY
                                        DIBOHF23SPDLT)/cn=Configuration/cn=Servers/
                                        cn=SRV-SQL
    Fqdn                              : srv-sql.monotrans.local
    IsHubTransportServer              : True
    IsClientAccessServer              : True
    IsExchange2007OrLater             : True
    IsEdgeServer                      : False
    IsMailboxServer                   : True
    IsMemberOfCluster                 : No
    IsProvisionedServer               : False
    IsUnifiedMessagingServer          : False
    NetworkAddress                    : {ncacn_vns_sppTongue TiedRV-SQL, netbiosTongue TiedRV-SQL, nc
                                        acn_npTongue TiedRV-SQL, ncacn_spxTongue TiedRV-SQL, ncacn_ip
                                        _tcpTongue Tiedrv-sql.monotrans.local, ncalrpcTongue TiedRV-S
                                        QL}
    OrganizationalUnit                : monotrans.local/SRV-SQL
    AdminDisplayVersion               : Version 8.0 (Build 685.24)
    Site                              : monotrans.local/Configuration/Sites/Default
                                        -First-Site-Name
    ServerRole                        : Mailbox, ClientAccess, HubTransport
    ErrorReportingEnabled             :
    StaticDomainControllers           : {}
    StaticGlobalCatalogs              : {}
    StaticConfigDomainController      :
    StaticExcludedDomainControllers   : {}
    CurrentDomainControllers          : {}
    CurrentGlobalCatalogs             : {}
    CurrentConfigDomainController     :
    ProductID                         : 90557-046-0000007-05729
    IsExchange2007TrialEdition        : False
    IsExpiredExchange2007TrialEdition : False
    RemainingTrialPeriod              : 00:00:00
    IsValid                           : True
    OriginatingServer                 : srv-fs.monotrans.local
    ExchangeVersion                   : 0.1 (8.0.535.0)
    DistinguishedName                 : CN=SRV-SQL,CN=Servers,CN=Exchange Administr
                                        ative Group (FYDIBOHF23SPDLT),CN=Administra
                                        tive Groups,CN=GKM,CN=Microsoft Exchange,CN
                                        =Services,CN=Configuration,DC=monotrans,DC=
                                        local
    Identity                          : SRV-SQL
    Guid                              : 1c514c7e-3f46-45dc-8788-d0012c2e6016
    ObjectCategory                    : monotrans.local/Configuration/Schema/ms-Exc
                                        h-Exchange-Server
    ObjectClass                       : {top, server, msExchExchangeServer}
    WhenChanged                       : 12.10.2007 9:43:27
    WhenCreated                       : 10.10.2007 14:03:23

    Name                              : SRV-TEST
    DataPath                          : C:\Program Files\Microsoft\Exchange Server\
                                        Mailbox
    Domain                            : monotrans.local
    Edition                           : Enterprise
    ExchangeLegacyDN                  : /o=GKM/ou=Exchange Administrative Group (FY
                                        DIBOHF23SPDLT)/cn=Configuration/cn=Servers/
                                        cn=SRV-TEST
    Fqdn                              : srv-test.monotrans.local
    IsHubTransportServer              : True
    IsClientAccessServer              : True
    IsExchange2007OrLater             : True
    IsEdgeServer                      : False
    IsMailboxServer                   : True
    IsMemberOfCluster                 : No
    IsProvisionedServer               : False
    IsUnifiedMessagingServer          : False
    NetworkAddress                    : {ncacn_vns_sppTongue TiedRV-TEST, netbiosTongue TiedRV-TEST,
                                        ncacn_npTongue TiedRV-TEST, ncacn_spxTongue TiedRV-TEST, ncac
                                        n_ip_tcpTongue Tiedrv-test.monotrans.local, ncalrpc:
                                        SRV-TEST}
    OrganizationalUnit                : monotrans.local/SRV-TEST
    AdminDisplayVersion               : Version 8.0 (Build 685.24)
    Site                              : monotrans.local/Configuration/Sites/Default
                                        -First-Site-Name
    ServerRole                        : Mailbox, ClientAccess, HubTransport
    ErrorReportingEnabled             :
    StaticDomainControllers           : {}
    StaticGlobalCatalogs              : {}
    StaticConfigDomainController      :
    StaticExcludedDomainControllers   : {}
    CurrentDomainControllers          : {}
    CurrentGlobalCatalogs             : {}
    CurrentConfigDomainController     :
    ProductID                         : 90557-046-0000007-05821
    IsExchange2007TrialEdition        : False
    IsExpiredExchange2007TrialEdition : False
    RemainingTrialPeriod              : 00:00:00
    IsValid                           : True
    OriginatingServer                 : srv-fs.monotrans.local
    ExchangeVersion                   : 0.1 (8.0.535.0)
    DistinguishedName                 : CN=SRV-TEST,CN=Servers,CN=Exchange Administ
                                        rative Group (FYDIBOHF23SPDLT),CN=Administr
                                        ative Groups,CN=GKM,CN=Microsoft Exchange,C
                                        N=Services,CN=Configuration,DC=monotrans,DC
                                        =local
    Identity                          : SRV-TEST
    Guid                              : 2e29e8e9-3831-4995-a652-6e25885495cb
    ObjectCategory                    : monotrans.local/Configuration/Schema/ms-Exc
                                        h-Exchange-Server
    ObjectClass                       : {top, server, msExchExchangeServer}
    WhenChanged                       : 15.04.2008 15:26:22
    WhenCreated                       : 15.04.2008 15:06:18


    17 апреля 2008 г. 4:22
  •  Jоker написано:

     

    Письмо не должно "ложиться сразу в ящик", это было так в Exchage 2003, но не в Exchange 2007. Письмо будет доставлено на транспортный сервер, обработано, и передано на почтовый сервер (даже если это тот же самый сервер).

     

    и в 6.* письмо не сразу "ложится в ящик" , другое дело что smtp роль (транспорт)  неразрывно связана с сервером п\я в отличии от 8.*  ( еще правда между транспортом и п\я в 8.* письма "гуляют" по mapi , даже в пределах одного сервера, в 6.* используется иной механизм)

    17 апреля 2008 г. 10:08
  •  Pterodactyl написано:


    Правильно ли я понял, что если в одном сайте находятся 2 exchange сервера (как в моем случае) то только один из них будет работать траспортным сервером, даже если роли транспортного сервера установлены на обоих серверах?
    И тогда письмо в пределах одного сайта будет маршрутизироваться всегда через один сервер?

     

    Да нет - в одном сайте не происходит передача между транспортами по smtp протоколу

     

    и сообщение у вас не должно покидать своего транспорта и должно оным же и обрабатываться

    17 апреля 2008 г. 10:59
  •  

    Я тоже так думаю, но посмотрите на заголовки письма.

    Кроме того я специально прослушивал трафик на интерфейсах обоих серверов. Письма упорно покидают свой транспортный сервер, уходят на другой сервер, затем возвращаются обратно на "свой" транспорт.

    Собственно из-за подобных странностей я и создал эту ветку.

    Спасибо, огромное всем отвечающим, надеюсь сообщество мне поможет разобраться!!

     

    17 апреля 2008 г. 13:28
  • А у вас служба MSExchangeTransport запущена на тестовом сервере ?

     

    17 апреля 2008 г. 14:29
  • Да. Запущены все службы, кроме POP3 и IMAP.

     

    Возникла мысль. Тестовый сервер запущен из-под виртуальной машины. Не может ли нехватка ресурсов привести к такому странному поведению транспорта?

    Хотя судя по мониторингу ресурсов памяти и процессора - более чем достаточно. Да и физически сервак с виртуалкой мощный

    17 апреля 2008 г. 15:41
  • У вас поведение транспорта таково - как будто его вообще нет на этом сервере или служба остановлена.

     

    Прогоните ExBPA на этом сервере и ExTRA

     

    Про вирт.маш ничего не могу сказать - я моелирую все на реальном железе, благо как грязи

     

     

    17 апреля 2008 г. 16:13
  •  Sergey Krylov написано:

    и в 6.* письмо не сразу "ложится в ящик"

    Сразу, если почтовые ящики отправителя и получателя находятся на одном сервере. SMTP стек при этом вообще не задействуется, только внутренний категоризатор и собственно store.exe.

    17 апреля 2008 г. 20:03
  • Начал прогонять ExBPA

    --
    "Server: SRV-TEST","Error","Exchange store does not start.","Server","SRV-TEST","The 'Services' string type value located in 'HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup\Services' registry key is missing or inaccessible. The Microsoft Exchange Information Store service will not start. As a result, all services that depend on this service will not be able to start. Please visit http://support.microsoft.com/kb/285116 for more information.","http://go.microsoft.com/fwlink/?linkid=30939&l=EN&v=ExBPA.2&id="
    --

    Посмотрел через regedit. Ключик есть, права к нему правильные прописаны. (По крайней мере точь-в-точь как на основном сервере). Все службы Exchange запущены. Перезапустил сервак - все ок, все службы в норме.

    Да кстати, проанализировал еще раз прослушанный трафик.
    Почта между серверами летает по каким угодно портам (например у меня 8381) кроме как 25...
    18 апреля 2008 г. 2:14
  •  Pterodactyl написано:
    Начал прогонять ExBPA



    Посмотрел через regedit. Ключик есть, права к нему правильные прописаны. (По крайней мере точь-в-точь как на основном сервере). Все службы Exchange запущены. Перезапустил сервак - все ок, все службы в норме.

    Да кстати, проанализировал еще раз прослушанный трафик.
    Почта между серверами летает по каким угодно портам (например у меня 8381) кроме как 25...

     

    ExTRA что сказал ?

     

    Трафик у вас и не будет ходить по 25-му порту - ходит он по MAPI (XSO)

    18 апреля 2008 г. 7:51
  •  Jоker написано:
     Sergey Krylov написано:

    и в 6.* письмо не сразу "ложится в ящик"

    Сразу, если почтовые ящики отправителя и получателя находятся на одном сервере. SMTP стек при этом вообще не задействуется, только внутренний категоризатор и собственно store.exe.

     

    При чем здесь стек SMTP ( протокольный уровень работы) ? Это лишь некоторая часть траспорта , но далеко не весь транспорт. AQEUE принадлежит к транспорту (IIS-SMTP), а от store (для не smtp передачи) через драйверa Drviis.dll-Epoxy.dll-ExSMTP.dll и попадает на aqueue (agueue.dll-phatcat.dll ...) - а затем ( в случае на том же сервере) идет в обратную сторону

    18 апреля 2008 г. 8:03
  • Вот на что ругнулся TRA.
    Вы были правы, теперь вопрос - как это исправить???

    --
    Unable to find any servers with Hub Transport server role installed in same Active Directory site as server srv-test using local Active Directory site GUID '%varSiteGuid%'.
    --

    В догонку - прогнал этот же тест для основного рабочего сервера. Выдал ту же ошибку...
    Я в панике Smile

    Может я неправильно сам тест запускаю?


    18 апреля 2008 г. 9:35
  • проверьте http://technet.microsoft.com/en-us/library/bb123496(EXCHG.80).aspx

     

    значение атрибута msExchCurrentServerRoles  у каждого из серверов каково

    18 апреля 2008 г. 9:55
  • Значение атрибута =38 для обоих серверов. Насколько я понимаю это соответствует транспорту+доступ+ящики.

     

    Согласно статьи проверил записи в реестре каждого сервера . Ключи Unpacked и ConfiguredVersion для каждой роли присутствуют и совпадают на обоих серверах.

     

    При этом почта в организации ходит нормально, никаких ругательных записей в журнале событий не обнаружено, обычные рапорты.

    Куда еще покопать можно?

     

    Статью буду читать, но что то боязно мне запускать setup /m:RecoveryServer на боевом серваке. Что не так пойдет - мне ж харакири чайной ложкой сделают Smile

    18 апреля 2008 г. 10:51
  • зачем вам запускать setup /m:RecoveryServer на рабочем ? запускаете на тестовом

     

    18 апреля 2008 г. 10:55
  • А ExTRA показал такую же ошибку и для рабочего сервера.

    18 апреля 2008 г. 11:04
  • Не трогайте пока рабочий - незачем , а тестовый можете "ломать" сколько душе угодно

     

    18 апреля 2008 г. 11:09
  • Какие мои дальнейшие шаги должны быть???

     

    D:\>setup /m:RecoverServer

    Автоматическая установка Microsoft Exchange Server 2007

    Подготовка программы установки Exchange

    Будут восстановлены следующие роли сервера
        Роль транспортного сервера-концентратора
        Роль клиентского доступа
        Роль хранилища почтовых ящиков
        Средства управления

     Уже установлены следующие роли сервера: BridgeheadRole, ClientAccessRole, Mailb
    oxRole, AdminToolsRole.

    В программе установки Exchange Server произошла ошибка.

    D:\>

     

    21 апреля 2008 г. 4:05
  •  

    Продолжаю разборки.

    Только что попробовал сделать следующее

    1) Через Пуск/Установка и удаление.... снес роль hub transport на тестовом сервере. Без ошибок

    2) Заново проинсталлировал роль. Без ошибок.

    Запуск ExTRA - то же сообщение (no local Hub Transport Server Role computers found)....

     

    Что еще сделать ума не приложу...

    Ошибка выдается и для рабочего сервера. Тем не менее почта ходит вполне нормально, за исключением того, с чего начали обсуждение...

    Подскажите господа чем еще поиграться?

     

    21 апреля 2008 г. 8:29
  • ExTRA как и где вы запускаете ?

    21 апреля 2008 г. 12:46
  •  

    Доброго времени суток Сергей!

     

    1) Благодарю Вас за долготерпение и помощь!

    2) Как я уже писал выше - в Exchange я пока что красноглазый чайник Smile так что вполне возможно мои прогоны ExTRA потянут на медаль по глупости не тем не менее. 

    3) Установил TRA как на тестовый сервер (srv-test) так и на свой десктоп (Всякий случай - firewall, антивир отключены)

    Далее после запуска TRA выбирал Mail Flow troubleshuter. Далее выбирал (как мне показалось наиболее близкое по смыслу к моей проблеме) - "Messages sent by user are pending submission on their mailbox server...."

    Далее указывал сервер с Exchange и сервер с глобальным каталогом. Какие либо параметры авторизации не указывал.

    Вот эта задача и выдает ошибку о "no local Hub Transport Server role found...."

     

    4) Как я понимаю, так как почта ходит, то что то я с ExTRA ExBPA неправильно делаю.

     

     

    С уважением, Роман

     

    21 апреля 2008 г. 13:28
  • что значит вы установили ExTRA ? он уже входит в поставку Exch 2007 - EMC- Toolbox - Mail Flow Troubleshooter

     

    21 апреля 2008 г. 13:39
  • Да, но для своего десктопа я утянул его как отдельный пакет. Возможно есть путь установить TRA из дистрибутива, но мне было проще в тот момент скачать как отдельную утиль Smile

    21 апреля 2008 г. 13:54
  • Давайте без десктопов и прочего обойдемся -) - выполните эти тесты прямо на сервере !

     

    21 апреля 2008 г. 14:18
  • Уфф.

    Действительно, запущенный из состава Exchangе, на сервере TRA ошибок не нашел.

    Показал что оба сервера (осн и рабочий) имеют роль Hub Transport и она корректно выполняется.

    Признаю себя ослом и жду ваших распоряжений (с) капитан Смоллет Smile

     

    У вас есть какие то мысли по поводу изначального вопроса о хождении почты через рабочий сервер, хотя почтовые ящики абонентов находятся на тестовом?

     

    21 апреля 2008 г. 14:52
  • Проведите тест - он простой и много времени не займет .

     

    На работающем сервере остановите MSExchangeTransport - и отправьте сообщения между пользователями как основного так и тестового сервера

     

     

    п.с. кстати - виртуализацию на чем делаете ? проблема (возможно) может быть связана именно с этим моментом

    21 апреля 2008 г. 15:22

  • Ок. Делал так:

    1) На рабочем сервере остановил службу "Транспорт MS Exchange"
    2) От имени пользователя , ящик которого расположен на тестовом сервере отправил 2 отдельных письма - одно получателю на основном сервере, другое получателю на тестовом сервере
    3) Подождал 10 мин.
    4) Письма не пришли ни одному ни другому получателю
    5) На рабочем сервере запустил службу "Транспорт MS Exchange"
    6) Прошло 7-7.5 мин - оба получателя одновременно получили письма.
    Посмотрел заголовки писем - они аналогичны тем, что я приводил выше, т.е. письмо передавалось через основной сервер в обоих случаях

    По поводу виртуализации. Хост машина - OC Vista x86.
    Гостевая ОС поднята под VMWare Server последней версии.
    Гостевая ОС - Win2003 server R2 x64.

    Доступная память под виртуалкой - 3Г. Занято 54%.


    22 апреля 2008 г. 7:05
  • Тест показал , что транспорта на тестовой платформе нет. Проблема у вас именно в виртуализации ( не думаю, что у вас на тестовом установлены специфические транспортные агенты)

     

    22 апреля 2008 г. 11:58
  • Ок. какая то ясность появилась.

    Не вполне понял про спецефические агенты - если вы имеете в виду, что Exchange на тестовом сервере установлен "по умолчанию" то да, я никакого дополнительного софта не ставил и конфигурацию сервера не менял, за исключением того, что создал соединитель отправки для тестового сервера и добавил пару почтовых ящиков.

     

    По поводу проблемы в виртуализации - у Вас случайно нет идей в какую сторону смотреть???

    Чего не хватает Exchange? Ведь службы запущены и работают. В какой ситуации запущеная служба "Транспорт MS Exchange" может отказаться пересылать почту?

     

    Кроме того - поправьте меня если я ошибаюсь - картина сейчас выглядит следующим образом

    1) Клиентский Outlook отправляет письмо.

    2) Письмо попадает на тестовый сервер

    3) Далее происходит выбор транспортного сервера

    4) Далее письмо должно быть обработано службами Hub Transport

    5) При попытке обратиться к транспорту на тестовом сервере происходит какой то сбой

    6) Для обработки письмо передается транспорту на основном сервере

    7) Транспорт основного основного сервера адресует письмо в почтовый ящик на тестовом сервере для чего передает его службам Mailbox на тестовом сервере

     

    Если я не напутал в основной картине то вопрос - может быть проблема возникает на этапе выбора транспорта?

    Как я понимаю - данные о существующих транспортах запрашиваются из схемы AD? может быть процесс выбирающий транспорт тупо берет первый из списка?

    Или может быть транспорт на тестовом сервере при попытке "вручить" ему письмо рапортует о недостаточности ресурсов например? и предлагает воспользоваться услугами другого транспорта?

     

     

    22 апреля 2008 г. 13:46
  •  Pterodactyl написано:

    По поводу проблемы в виртуализации - у Вас случайно нет идей в какую сторону смотреть???

     

    Нет - ибо не занимаюсь, а уж тем более VMWARE

     

    А идея проста как 2 копейки - использовать "железо"

     

     

     Pterodactyl написано:

    Если я не напутал в основной картине то вопрос - может быть проблема возникает на этапе выбора транспорта?

    Как я понимаю - данные о существующих транспортах запрашиваются из схемы AD? может быть процесс выбирающий транспорт тупо берет первый из списка?

     

    Нет , "тупо" первого он не берет, а вашем случае он "тупо" должен взять ближайшего т.е. самого себя

     

     

     Pterodactyl написано:

    Или может быть транспорт на тестовом сервере при попытке "вручить" ему письмо рапортует о недостаточности ресурсов например? и предлагает воспользоваться услугами другого транспорта?

     

     

     

    дело в том , что я не смогу смоделировать вашу ситуацию, причина выше названа

     

    Можно конечно поднять уровень диагностики и т.п. , но что это решит если проблема именно в вирутализации ?

     

    Кстати - прямое обращение к транспорту по smtp на вашем сервере работает в полном объеме ?

    22 апреля 2008 г. 15:01
  •  

    Даааааааа. Посыпаю голову пеплом.

     

    Всего то надо было сделать telnet srv-test 25

    На что он браво рапортует кодом 452 4.3.1 Insufficient system resourses

     

    Smile

     

    Спасибо огромное за советы и помощь! Подчерпнул для себя много интересного.

     

    P.S. Буду рыть документацию по поводу - сколько этому прожоре нужно ресурсов Smile

    Если проблема решиться - отпишу сюда как решение проблемы

    22 апреля 2008 г. 15:26
  •  Pterodactyl написано:

     

    Даааааааа. Посыпаю голову пеплом.

     

    Всего то надо было сделать telnet srv-test 25

    На что он браво рапортует кодом 452 4.3.1 Insufficient system resourses

     

     

    Спасибо огромное за советы и помощь! Подчерпнул для себя много интересного.

     

    P.S. Буду рыть документацию по поводу - сколько этому прожоре нужно ресурсов

    Если проблема решиться - отпишу сюда как решение проблемы

     

    попробуйте http://exchangepedia.com/blog/2007/03/exchange-server-2007-transport-452-431.html

    22 апреля 2008 г. 15:36
  • Надо же Smile Передам Бхарату, что его читают в России, ему будет приятно Smile

    23 апреля 2008 г. 0:14