none
Странности при отображении сообщений в UTF-8 в Outlook 2010 RRS feed

  • Вопрос

  • Outlook 2010 не отображает текст некоторых сообщений в кодировке UTF-8. Если для сообщения выбрать иную кодировку (1251 или KOI-8R), то отображаются крякозябры. После возвращения кодировки UTF-8 - снова пустота. Однако, текст сообщения виден, если сохранить сообщение в файл .MSG и затем открыть этот файл, либо воспользоваться функцией "Открыть в браузере". Кроме того, текст виден во всплывающем уведомлении о новом сообщении.

    Проблема проявляется в разных клиентских ОС, как в Windows 7, так и в Windows Vista.

    Версия Outlook 14.0.6112.5000 (32 bit). Outlook настроен на работу с Exchange 2007 SP3 Update 6.

Ответы

  • 1. От способа установки не зависит, есть как чистые установки 2010, так и апгрейд с 2007.

    2. Несколько дней назад отправитель сменил кодировку, пока проблем не наблюдается.

Все ответы

  • Какая изначально используется кодировка для отправки писем? UTF-8? Данная проблема на всех ПК?

    Просмотрите тело проблемного сообщения, откройте сообщение, далее Файл -  Сведения - Свойства. Приведите содержимое заголовка интернета.

    Так же укажите какой язык операционной системы ипользуется на проблемных компьютерах.

  • Сообщения исходят от внешней организации, поэтому информация скудна.

    Для отправки используется UTF-8, что косвенно подтверждается заголовками:
    Received: from xxx.xxx.ru (80.76.xxx.xxx) by yyy.yyy.ru (192.168.yyy.yyy)
     with Microsoft SMTP Server (TLS) id 8.3.245.1; Thu, 26 Apr 2012 12:30:19
     +0400
    Received: from localhost ([127.0.0.1]) by  xxx.xxx.ru; Thu, 26 Apr 2012
     12:30:33 +0400
    Date: Thu, 26 Apr 2012 12:30:18 +0400
    From: =?utf-8?B?0JrQsNGO0LzQvtCy0LAg0JPRg9C30LXQu9GM?= <zzz@zzz.ru>
    Reply-To: =?utf-8?B?0JrQsNGO0LzQvtCy0LAg0JPRg9C30LXQu9GM?= <zzz@zzz.ru>
    X-Priority: 3 (Normal)
    Message-ID: <1931071688.20120426123018@zzz.ru>
    To: =?utf-8?B?0JzQsNC70LDRhdC+0LLRgdC60LjQuSDQnNC40YXQsNC40Ls=?= <yyy@yyy.ru>
    CC: =?utf-8?B?0JHQsNGA0LDQvdC+0LLQsCDQmtCw0YLRjw==?= <zzz@zzz.ru>
    Subject: =?utf-8?B?UmU6INCd0LjQttC90LjQuSDQndC+0LLQs9C+0YDQvtC0?=
    In-Reply-To: <2E70FE1035F00F40A905B9237F9E0C7B1DC7E3B327@yyy.ru>
    References: <2E70FE1035F00F40A905B9237F9E0C7B1DC7E3B327@yyy.ru>
    MIME-Version: 1.0
    Content-Type: multipart/alternative; boundary="----------F7C06830D2D8DA"
    Return-Path: zzz@zzz.ru
    X-Spam-Ystatus: hits=-4.10
    X-Spam-Flag: NO
    X-Spam-Yversion: Spamooborona-3.4

    Проблема отмечается на всех ПК с Outlook 2010, но не со всеми сообщениями от этой организации, т.е. часть сообщений отображается нормально. В Outlook 2007 такой проблемы не наблюдается. На всех задействованных ПК используется русскоязычная ОС.

    1. Outlook 2010 ставился с нуля или обновлением с версии 2007?
    2. Если на стороне отправителя изменить формат письма, проблема остается?


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow us on TwitterFollow MSTechnetForum on Twitter

    Посетите Блог Инженеров
    Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html

    Модератор
  • Уважаемый пользователь!



    В вашей теме отсутствует активность в течение последних 5 дней. При отсутствии каких-либо действий в течение 2 последующих дней, тема будет переведена в разряд обсуждений. Вы можете возобновить дискуссию, просто оставив сообщение в данной теме.


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow us on TwitterFollow MSTechnetForum on Twitter

    Посетите Блог Инженеров
    Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html

    Модератор
  • 1. От способа установки не зависит, есть как чистые установки 2010, так и апгрейд с 2007.

    2. Несколько дней назад отправитель сменил кодировку, пока проблем не наблюдается.